You are not logged in.

#1 2013-02-23 19:03:40

dok
Member
Registered: 2013-02-18
Posts: 13

[SOLVED]Keyboard not working xserver

I am trying to run the default X environment, and despite mine having the evdev input driver, x seems to not be recognizing it.

My Xorg.0.log:
http://sebsauvage.net/paste/?3cf9326d37 … jfGNKI2ZE=

Last edited by dok (2013-03-12 02:06:21)

Offline

#2 2013-02-23 20:26:57

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,433

Re: [SOLVED]Keyboard not working xserver

How about the xorg-input-keyboard driver?

ewaller@odin:~[5] 1006 %pacman -Qi xf86-input-keyboard 
Name           : xf86-input-keyboard
Version        : 1.6.2-2
URL            : http://xorg.freedesktop.org/
Licenses       : custom
Groups         : xorg-drivers  xorg
Provides       : None
Depends On     : glibc
Optional Deps  : None
Required By    : None
Conflicts With : xorg-server<1.13.0  X-ABI-XINPUT_VERSION<18
                 X-ABI-XINPUT_VERSION>=19
Replaces       : None
Installed Size :  40.00 KiB
Packager       : Andreas Radke <andyrtr@archlinux.org>
Architecture   : x86_64
Build Date     : Fri Oct 5 11:40:08 2012
Install Date   : Sat Oct 13 17:06:46 2012
Install Reason : Explicitly installed
Install Script : No
Description    : X.Org keyboard input driver

ewaller@odin:~ 1007 %

You need it in addition to the evdev driver.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#3 2013-02-23 20:53:23

dok
Member
Registered: 2013-02-18
Posts: 13

Re: [SOLVED]Keyboard not working xserver

I did this, but it seems that the keyboard just outputs random strings into the xterm window. Anyone have a solution for this?

Offline

#4 2013-02-23 21:00:12

Gusar
Member
Registered: 2009-08-25
Posts: 3,413

Re: [SOLVED]Keyboard not working xserver

What's weird in that log is the kbd gets loaded for every input device. The evdev driver should get loaded. Do you have any configs in /etc/X11/xorg.conf.d/ besides 10-evdev.conf and 10-quirks.conf that got installed with xorg-server? And did you maybe mess with those files? 10-evdev.conf should have a Driver "evdev" line in the sections for keyboards and mice.

Offline

#5 2013-02-23 21:05:26

dok
Member
Registered: 2013-02-18
Posts: 13

Re: [SOLVED]Keyboard not working xserver

Well, I am on a laptop, so I added a 10-synaptics.conf, for my track pad, but besides that, no. Also, in 10-evdev.conf, evdev is set as driver. I can post all the conf's up if you want.

Offline

#6 2013-03-08 01:31:58

dok
Member
Registered: 2013-02-18
Posts: 13

Re: [SOLVED]Keyboard not working xserver

Not to necropost, but I still need help with this. Do I need to post any additional info?

Offline

#7 2013-03-08 02:53:39

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 939
Website

Re: [SOLVED]Keyboard not working xserver

dok wrote:

I did this, but it seems that the keyboard just outputs random strings into the xterm window. Anyone have a solution for this?

Can you give output to

setxkbmap -print -verbose 10

https://wiki.archlinux.org/index.php/Xo … d_settings

Last edited by frank604 (2013-03-08 02:54:26)


github       bible       blog

Offline

#8 2013-03-10 00:07:19

dok
Member
Registered: 2013-02-18
Posts: 13

Re: [SOLVED]Keyboard not working xserver

I get:

Setting verbose level to 10
Cannot open display "default display"

Offline

#9 2013-03-11 02:18:38

dok
Member
Registered: 2013-02-18
Posts: 13

Re: [SOLVED]Keyboard not working xserver

I have realized I have to type this command through X to get a solid output, but my problem is not being able to normally type anything in X. Thank you for the reply anyway smile

Offline

#10 2013-03-12 02:05:44

dok
Member
Registered: 2013-02-18
Posts: 13

Re: [SOLVED]Keyboard not working xserver

For anyone else having this problem(although it seems rare) a quick reinstall did it. Don't know why I didn't think of that before.

Offline

#11 2013-11-17 18:10:13

stripedpage
Member
Registered: 2013-11-17
Posts: 1

Re: [SOLVED]Keyboard not working xserver

Maybe problem is in your 10-synaptics.conf
I solve the problem by adding this:

#touchpad settings

Section "InputClass"
    Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        Option "TapButton1" "1"
        ...
EndSection

Offline

#12 2013-11-17 20:36:51

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,346
Website

Re: [SOLVED]Keyboard not working xserver

stripedpage, please don't bump solved threads; particularly when your "solution" is not relevant (keyboard != touchpad).


Closing.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

Board footer

Powered by FluxBB