You are not logged in.

#51 2013-02-12 13:24:01

JohnnyDeacon
Member
From: Colombia
Registered: 2012-01-18
Posts: 81

Re: Aura - 1.3.5 *Please update to fix breakage*

Here is:

  ╒══[ /home/jairo ]═══════╕
  └> aura -Ss kde --auradebug
User              => root
True User         => jairo
Using Sudo?       => Yes!
Pacman Flags      => -S
Other Flags       => Search Debug
Other input       => kde
Language          => English
Pacman Command    => /usr/bin/powerpill
Editor            => vi
$CARCH            => x86_64
Ignored Pkgs      => 
Pkg Cache Path    => /var/cache/pacman/pkg/
Log File Path     => /var/log/pacman.log
Silent Building?  => Yes!
Must Confirm?     => Yes!
PKGBUILD editing? => No.
Diff PKGBUILDs?   => No.
Rebuild Devel?    => No.
Colour Test       => REDGREENYELLOWBLUEMAGENTACYANWHITE
error: no argument for option -s
aura >>= Please check your input.

The extra s show me results:

  ╒══[ /home/jairo ]═══════╕
  └> aura -Sss kde --auradebug                                                                                                                                                         
User              => root                                                                                                                                                                       
True User         => jairo                                                                                                                                                                      
Using Sudo?       => Yes!                                                                                                                                                                       
Pacman Flags      => -S                                                                                                                                                                         
Other Flags       => Search Search Debug                                                                                                                                                        
Other input       => kde                                                                                                                                                                        
Language          => English                                                                                                                                                                    
Pacman Command    => /usr/bin/powerpill                                                                                                                                                         
Editor            => vi                                                                                                                                                                         
$CARCH            => x86_64                                                                                                                                                                     
Ignored Pkgs      =>                                                                                                                                                                            
Pkg Cache Path    => /var/cache/pacman/pkg/                                                                                                                                                     
Log File Path     => /var/log/pacman.log                                                                                                                                                        
Silent Building?  => Yes!                                                                                                                                                                       
Must Confirm?     => Yes!                                                                                                                                                                       
PKGBUILD editing? => No.                                                                                                                                                                        
Diff PKGBUILDs?   => No.                                                                                                                                                                        
Rebuild Devel?    => No.                                                                                                                                                                        
Colour Test       => REDGREENYELLOWBLUEMAGENTACYANWHITE
extra/amarok 2.7.0-2 [installed]
    The powerful music player for KDE
extra/archlinux-themes-kdm 1.4-3 [installed]
    Arch Linux branded KDM greeter themes for KDE
extra/basket 1.81-3
    All-purpose notes taker for KDE.
extra/bluedevil 1.3-1
    KDE bluetooth framework
extra/digikam 3.0.0-2
    Digital photo management application for KDE
extra/docker 1.5-6
    Docker is a docking application (WindowMaker dock app) which acts as a system tray for KDE and GNOME2.
extra/icon-naming-utils 0.8.90-2
. . . . . 

Last edited by JohnnyDeacon (2013-02-12 13:28:42)

Offline

#52 2013-02-12 21:45:29

fosskers
Member
Registered: 2012-02-21
Posts: 142
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

rg_arc wrote:

So if you do that and we delete the deps.. we will only need them whenever we want to upgrade aura?

Yeah. You can do that automatically if you update with the `-a` option, as in `aura -Aua`. Even better if you use `aura -Akua`. `-k` shows PKGBUILD diffs, and `-a` removes unneeded build deps.

@Johnny: Thanks for the update. I made a tiny change to the arg order when using pacman flags. It's been pushed to the repo, so would you mind reinstalling aura-git and trying it?
Also, why is it showing you as the root user? Do you have `aura` aliased to `sudo aura`?

Last edited by fosskers (2013-02-12 21:55:49)


Author of Aura

Offline

#53 2013-02-12 23:21:48

JohnnyDeacon
Member
From: Colombia
Registered: 2012-01-18
Posts: 81

Re: Aura - 1.3.5 *Please update to fix breakage*

fosskers wrote:

@Johnny: Thanks for the update. I made a tiny change to the arg order when using pacman flags. It's been pushed to the repo, so would you mind reinstalling aura-git and trying it?

Thanks for the fix

  ╒══[ /home/jairo ]════╕
  └> aura -Ss kde
extra/amarok 2.7.0-2 [installed]
    The powerful music player for KDE
extra/archlinux-themes-kdm 1.4-3 [installed]
    Arch Linux branded KDM greeter themes for KDE
extra/basket 1.81-3
    All-purpose notes taker for KDE.
extra/bluedevil 1.3-1
    KDE bluetooth framework
extra/digikam 3.0.0-2
    Digital photo management application for KDE
. . . .
fosskers wrote:

Also, why is it showing you as the root user? Do you have `aura` aliased to `sudo aura`?

Exactly.

Thanks again.

Offline

#54 2013-02-13 11:10:55

fosskers
Member
Registered: 2012-02-21
Posts: 142
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

Alright, I'm glad that fixed it. Thanks again for reporting this problem!


Author of Aura

Offline

#55 2013-02-17 12:19:49

fosskers
Member
Registered: 2012-02-21
Posts: 142
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

1.1.4.0
-------
- Serbian translation added. Thank you, Filip Brcic!
- Fixed bug that was breaking `aura -Ss`.


Author of Aura

Offline

#56 2013-02-18 07:42:49

zoqaeski
Member
From: /earth/australia/.
Registered: 2009-09-30
Posts: 124

Re: Aura - 1.3.5 *Please update to fix breakage*

Is there a configuration file for aura? I can’t seem to change the editor from vi to vim, and there’s a few other things I’d like to adjust (such as package building location).

Offline

#57 2013-02-18 11:27:32

fosskers
Member
Registered: 2012-02-21
Posts: 142
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

zoqaeski wrote:

Is there a configuration file for aura? I can’t seem to change the editor from vi to vim, and there’s a few other things I’d like to adjust (such as package building location).

For a while I've been on and off the fence over this, mostly because pretty much everything I could think to put in a config file could be done with command-line flags and aliases. However, build location is one thing that at present can't be changed. If you'd really like that as a feature, I could add it.


Author of Aura

Offline

#58 2013-02-18 17:00:13

Malsasa
Member
From: Indonesia
Registered: 2013-02-13
Posts: 4
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

I am interested in the name of this your app: AURA. AUR + A. It is simple but beautiful...

Your genius feature save and restore, I don't understand yet. Please give me simple analogy. Is this like Deepfreeze system in Windows? CMIIW.

But thank you so much for these your effort... +1!

smile

Offline

#59 2013-02-19 10:41:52

zoqaeski
Member
From: /earth/australia/.
Registered: 2009-09-30
Posts: 124

Re: Aura - 1.3.5 *Please update to fix breakage*

fosskers wrote:
zoqaeski wrote:

Is there a configuration file for aura? I can’t seem to change the editor from vi to vim, and there’s a few other things I’d like to adjust (such as package building location).

For a while I've been on and off the fence over this, mostly because pretty much everything I could think to put in a config file could be done with command-line flags and aliases. However, build location is one thing that at present can't be changed. If you'd really like that as a feature, I could add it.

The configuration file would be useful to allow a user to set default switches that they’re almost always likely to use. Aria2c and wget do this AFAIK: every configuration option is a long-form command-line switch, and they can be overrided by using the switch in an invocation of the program. But the main features missing are customising editor and package-build location (also, aura doesn’t display nor offer to edit .install scripts).

Overall, aura is really useful; I’ve started using it full-time for all my package-management needs.

Offline

#60 2013-02-19 12:42:03

fosskers
Member
Registered: 2012-02-21
Posts: 142
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

Malsasa wrote:

I am interested in the name of this your app: AURA. AUR + A. It is simple but beautiful...

Your genius feature save and restore, I don't understand yet. Please give me simple analogy. Is this like Deepfreeze system in Windows? CMIIW.

But thank you so much for these your effort... +1!

smile

Thanks for noticing the pun smile

`--save` simply stores a record of all packages currently installed in a text file. You can see what one of these records looks like by checking `/var/cache/aura/states`. `--restore` compares the current state with a saved one you choose, then attempts to revert/delete as necessary. Note that packages can only be reverted if the previous versions are still available in the package cache.

zoqaeski wrote:

But the main features missing are customising editor and package-build location (also, aura doesn’t display nor offer to edit .install scripts).
Overall, aura is really useful; I’ve started using it full-time for all my package-management needs.

$EDITOR will actually be respected if you run sudo with `-E`. But you're absolutely right about the .install file. I should have those checked as well using `--hotedit`.

Alright, I think if you're this passionate about a config file, I'm sure there are others who feel the same way. I'll get to adding one. Expect it in a few weeks.


Author of Aura

Offline

#61 2013-02-20 08:04:10

zoqaeski
Member
From: /earth/australia/.
Registered: 2009-09-30
Posts: 124

Re: Aura - 1.3.5 *Please update to fix breakage*

fosskers wrote:
zoqaeski wrote:

But the main features missing are customising editor and package-build location (also, aura doesn’t display nor offer to edit .install scripts).
Overall, aura is really useful; I’ve started using it full-time for all my package-management needs.

$EDITOR will actually be respected if you run sudo with `-E`. But you're absolutely right about the .install file. I should have those checked as well using `--hotedit`.

I’ve got sudo set up so it defaults to using vim when called with `sudo -e`, and it ignores environment variables, but aura doesn’t seem to respect this.

/etc/sudoers
…
## Use Vim instead of VI. Vim is good. I like Vim.
Defaults env_reset
Defaults env_editor
Defaults editor=/usr/bin/vim
…

Offline

#62 2013-02-20 10:19:42

fosskers
Member
Registered: 2012-02-21
Posts: 142
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

At the moment, if Aura can't find the EDITOR variable, it defaults to `vi`.


Author of Aura

Offline

#63 2013-02-20 11:51:37

zoqaeski
Member
From: /earth/australia/.
Registered: 2009-09-30
Posts: 124

Re: Aura - 1.3.5 *Please update to fix breakage*

fosskers wrote:

At the moment, if Aura can't find the EDITOR variable, it defaults to `vi`.

I’ve always thought it to be good practice, security-wise, to not pass on $EDITOR to a sudo session as a malicious users could hijack this. It’s in the sudoers manual, after all.

sudoers(5) wrote:

env_editor
If set, visudo will use the value of the EDITOR or VISUAL environment variables before falling back on the default editor list.  Note that this may create a security hole as it allows the user to run any arbitrary command as root without logging.  A safer alternative is to place a colon-separated list of editors in the editor variable.  visudo will then only use the EDITOR or VISUAL if they match a value specified in editor.  This flag is on by default.

I’ve tried enabling, disabling and all sorts of playing around my sudoers file to no avail.

EDIT Completely off-topic: Is the Pacman animation from `aura -V` an easter egg? Nice.

Last edited by zoqaeski (2013-02-20 11:57:01)

Offline

#64 2013-02-24 07:54:01

fosskers
Member
Registered: 2012-02-21
Posts: 142
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

I believe `env_editor` only applies to using visudo... Aura doesn't read the sudoers file at all, so it's not a surprise that it wasn't working for you.

`aura -V` is a bit of an easter egg... it took me a long time to do, too. I wonder how much people have seen it?


Author of Aura

Offline

#65 2013-02-24 10:33:33

Spyhawk
Member
Registered: 2006-07-07
Posts: 392

Re: Aura - 1.3.5 *Please update to fix breakage*

fosskers wrote:

I wonder how much people have seen it?

Unfortunately, it doesn't work on most terminal sad
But I've seen it when using Putty on a Windows machine tongue

Offline

#66 2013-02-24 11:39:28

fosskers
Member
Registered: 2012-02-21
Posts: 142
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

Spyhawk wrote:

Unfortunately, it doesn't work on most terminal sad

Whaaat. I even fixed it after someone complained about this a while ago. It works in uxvrt, sakura, and xterm, as far as I've tested.

Also... new release!

1.1.4.1
-------
- Support for the $LANG environment variable.
- Aura will now pause before post-build installation if the package database
  lock exists. This means you can run multiple instances of Aura and avoid
  crashes.


Author of Aura

Offline

#67 2013-02-24 13:15:38

Spyhawk
Member
Registered: 2006-07-07
Posts: 392

Re: Aura - 1.3.5 *Please update to fix breakage*

fosskers> At least, this still doesn't work with konsole/yakuake, which are the only term I care about tongue

Last edited by Spyhawk (2013-02-24 13:16:16)

Offline

#68 2013-02-26 06:26:33

zoqaeski
Member
From: /earth/australia/.
Registered: 2009-09-30
Posts: 124

Re: Aura - 1.3.5 *Please update to fix breakage*

fosskers wrote:

I believe `env_editor` only applies to using visudo... Aura doesn't read the sudoers file at all, so it's not a surprise that it wasn't working for you.

The documentation on `env_editor` is fairly confusing actually. Some sources imply it sets the $EDITOR variable for su sessions, and others imply it’s only for visudo. I’ve told my sudoers file to keep $EDITOR and Aura now uses vim to edit the PKGBUILDs so I guess it’s ok now.

Offline

#69 2013-02-26 13:07:12

ksira
Member
Registered: 2009-10-27
Posts: 31

Re: Aura - 1.3.5 *Please update to fix breakage*

Just wanted to say thx fosskers, using this on one of my many Arch installs at the moment. I am satisfied so far, and may be migrating more of my boxes in the future. It helps that I'm learning Haskell as well.

Offline

#70 2013-02-26 13:19:43

JohnnyDeacon
Member
From: Colombia
Registered: 2012-01-18
Posts: 81

Re: Aura - 1.3.5 *Please update to fix breakage*

Spyhawk wrote:

fosskers> At least, this still doesn't work with konsole/yakuake, which are the only term I care about tongue


I use Konsole (kde 4.10) and I can see the output of aura -V (maybe encoding?)

Very nice indeed.

Last edited by JohnnyDeacon (2013-02-26 13:22:31)

Offline

#71 2013-02-26 22:33:19

fosskers
Member
Registered: 2012-02-21
Posts: 142
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

ksira wrote:

Just wanted to say thx fosskers, using this on one of my many Arch installs at the moment. I am satisfied so far, and may be migrating more of my boxes in the future. It helps that I'm learning Haskell as well.

Glad to hear that you like it.


Author of Aura

Offline

#72 2013-02-27 12:57:19

Spyhawk
Member
Registered: 2006-07-07
Posts: 392

Re: Aura - 1.3.5 *Please update to fix breakage*

JohnnyDeacon wrote:
Spyhawk wrote:

fosskers> At least, this still doesn't work with konsole/yakuake, which are the only term I care about tongue


I use Konsole (kde 4.10) and I can see the output of aura -V (maybe encoding?)

Very nice indeed.

Weird. I'm also using kde 4.10, with default settings (environment is set to TERM=xterm, encoding to utf-8), but the output of aura -V is still not shown as expected. New lines are added instead of refreshing the terminal.

Offline

#73 2013-02-27 13:06:38

JohnnyDeacon
Member
From: Colombia
Registered: 2012-01-18
Posts: 81

Re: Aura - 1.3.5 *Please update to fix breakage*

Strange, my settings are utf8 and xterm too, but I don't use yakuake, only konsole. . .

Offline

#74 2013-03-03 11:55:24

fosskers
Member
Registered: 2012-02-21
Posts: 142
Website

Re: Aura - 1.3.5 *Please update to fix breakage*

1.1.4.2
-------
- Haskell deps have been moved back to `makedepends`.
- haskell-http removed as dependency.
- API Change: function naming conventions in `Aura/Languages.hs` has been
  changed. The localisation guide was also updated to reflect this.


Author of Aura

Offline

#75 2013-03-09 17:06:18

Reded
Member
From: Manchester, England
Registered: 2012-02-21
Posts: 233

Re: Aura - 1.3.5 *Please update to fix breakage*

Hi, I think I'm making a dumb mistake here but figured I'd ask!

When I do 'sudo aura -Ayu' to update AUR packages, I get this message:

aura >>= Fetching package information...
aura >>= AUR API lookup failed. Please check your connection.

And Aura exits. I can update AUR packages using something else like yaourt, but Aura doesn't seem to manage it sad Is this a bug could something on my end be broken? smile


"Some humans would do anything to see if it was possible to do it. If you put a large switch in some cave somewhere, with a sign on it saying "End-of-the-World Switch. PLEASE DO NOT TOUCH", the paint wouldn't even have time to dry."

Offline

Board footer

Powered by FluxBB