You are not logged in.

#1 2013-02-26 10:16:45

corruption2013
Member
Registered: 2013-02-26
Posts: 6

startx as user does not load nvidia-settings, but as root it does

Hi,

couldn't find a answer to that on google so i ask here.

Problem:

If i run X as User with the "startx" command my nvidia x server settings does not load.
Also my primarydisplay (set in the nvidia-x-server-settings in a x-session before) isn't the right one.
I can manually fix for a X-session. But i have to do it in the nvidia-settings, i CAN'T load the settings like: nvidia-settings --load-config-only...

xinitrc is correct (i think): [..]  nvidia-settings --load-config-only & exec mate-session

If i run startx as root there are no problems, the nvidia-settings load correctly and the primary display is correct, too.

Can someone tell me where the permission problem is?


Thanks!

Last edited by corruption2013 (2013-02-26 10:18:39)

Offline

#2 2013-02-26 11:28:13

corruption2013
Member
Registered: 2013-02-26
Posts: 6

Re: startx as user does not load nvidia-settings, but as root it does

Ok fixed this:

The Configfile looks like:

[user@ArchHome ~]$ cat .nvidia-settings-rc
#
# /home/user/.nvidia-settings-rc
#
# Configuration file for nvidia-settings - the NVIDIA X Server Settings utility
# Generated on Tue Feb 26 13:18:25 2013
#

# ConfigProperties:

RcFileLocale = C
ToolTips = Yes
DisplayStatusBar = Yes
SliderTextEntries = Yes
IncludeDisplayNameInConfigFile = Yes
ShowQuitDialog = Yes
Timer = Memory_Used_(GPU_0),Yes,3000
Timer = Thermal_Monitor_(GPU_0),Yes,1000
Timer = PowerMizer_Monitor_(GPU_0),Yes,1000

# Attributes:

ArchHome:0.0/CursorShadow=0
ArchHome:0.0/CursorShadowAlpha=64
ArchHome:0.0/CursorShadowRed=0
ArchHome:0.0/CursorShadowGreen=0
ArchHome:0.0/CursorShadowBlue=0
ArchHome:0.0/CursorShadowXOffset=4
ArchHome:0.0/CursorShadowYOffset=2
ArchHome:0.0/SyncToVBlank=0
ArchHome:0.0/LogAniso=0
ArchHome:0.0/FSAA=0
ArchHome:0.0/TextureSharpen=0
ArchHome:0.0/TextureClamping=1
ArchHome:0.0/FXAA=0
ArchHome:0.0/AllowFlipping=0
ArchHome:0.0/FSAAAppControlled=1
ArchHome:0.0/LogAnisoAppControlled=1
ArchHome:0.0/OpenGLImageSettings=3
ArchHome:0.0/FSAAAppEnhanced=0
ArchHome:0.0/DigitalVibrance[CRT-0]=0
ArchHome:0.0/DigitalVibrance[DFP-3]=0
ArchHome:0.0/XVideoSyncToDisplay=1
ArchHome:0[dpy:0]/RedBrightness=0.000000
ArchHome:0[dpy:0]/GreenBrightness=0.000000
ArchHome:0[dpy:0]/BlueBrightness=0.000000
ArchHome:0[dpy:0]/RedContrast=0.000000
ArchHome:0[dpy:0]/GreenContrast=0.000000
ArchHome:0[dpy:0]/BlueContrast=0.000000
ArchHome:0[dpy:0]/RedGamma=1.000000
ArchHome:0[dpy:0]/GreenGamma=1.000000
ArchHome:0[dpy:0]/BlueGamma=1.000000
ArchHome:0[dpy:4]/RedBrightness=0.000000
ArchHome:0[dpy:4]/GreenBrightness=0.000000
ArchHome:0[dpy:4]/BlueBrightness=0.000000
ArchHome:0[dpy:4]/RedContrast=0.000000
ArchHome:0[dpy:4]/GreenContrast=0.000000
ArchHome:0[dpy:4]/BlueContrast=0.000000
ArchHome:0[dpy:4]/RedGamma=1.000000
ArchHome:0[dpy:4]/GreenGamma=1.000000
ArchHome:0[dpy:4]/BlueGamma=1.000000






Copied it and create a own that looks like this:



RcFileLocale = C
ToolTips = Yes
DisplayStatusBar = Yes
SliderTextEntries = Yes
IncludeDisplayNameInConfigFile = Yes
ShowQuitDialog = Yes
Timer = PowerMizer_Monitor_(GPU_0),Yes,1000
Timer = Thermal_Monitor_(GPU_0),Yes,1000
Timer = Memory_Used_(GPU_0),Yes,3000

# Attributes:

0/CursorShadow=0
0/CursorShadowAlpha=64
0/CursorShadowRed=0
0/CursorShadowGreen=0
0/CursorShadowBlue=0
0/CursorShadowXOffset=4
0/CursorShadowYOffset=2
0/SyncToVBlank=0
0/LogAniso=0
0/FSAA=0
0/TextureSharpen=0
0/TextureClamping=1
0/FXAA=0
0/AllowFlipping=0
0/FSAAAppControlled=1
0/LogAnisoAppControlled=1
0/OpenGLImageSettings=3
0/FSAAAppEnhanced=0
0/DigitalVibrance[CRT-0]=0
0/DigitalVibrance[DFP-3]=0
0/XVideoSyncToDisplay=524288





and load it on xstart (nvidia-settings -l config=/home/user/.myownnvidiaconfig & exec mate-session)

It works! But its only a workaround. Becouse i dont know why it works out of the box as root and as user need this workaround.

If someone have a better solution let me know.

The primary-display thing have i fixed with xrandr command.

Thanks!

Last edited by corruption2013 (2013-02-26 11:29:30)

Offline

Board footer

Powered by FluxBB