You are not logged in.

#1 2013-02-25 23:04:09

grobar87
Member
From: Македонија
Registered: 2010-08-25
Posts: 164

[SOLVED]Bluetooth not working

Hi,
Laptop model is Acer Aspire V5-571 ultrabook.Bluetooth is not working.I installed bluez and start bluetooth service with:

 systemctl enable bluetooth.service

and reboot laptop.Then i installed blueman and start the blueman-applet but when i try to search for device nothing found.
Here is hciconfig output:

┌─[dejan@archtop]──[~]
└─[25 Feb ■ 23:56]─╼ hciconfig
hci0:	Type: BR/EDR  Bus: USB
	BD Address: 84:4B:F5:2E:52:BC  ACL MTU: 1022:8  SCO MTU: 183:5
	UP RUNNING PSCAN 
	RX bytes:503 acl:0 sco:0 events:24 errors:0
	TX bytes:831 acl:0 sco:0 commands:24 errors:0

Scan for device:

┌─[dejan@archtop]──[~]
└─[25 Feb ■ 23:57]─╼ hcitool scan
Scanning ...

And rfkill:

┌─[dejan@archtop]──[~]
└─[25 Feb ■ 23:58]─╼ rfkill list
1: acer-wireless: Wireless LAN
	Soft blocked: no
	Hard blocked: no
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
3: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

Am i doing something wrong?
Thanks.

Last edited by grobar87 (2013-05-14 19:51:15)


And... here... we... go!

Offline

#2 2013-02-26 01:31:17

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: [SOLVED]Bluetooth not working

Well the interface seems to be up. What are you scanning for? Is that device setup to show itself when you scan?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#3 2013-02-26 10:36:40

grobar87
Member
From: Македонија
Registered: 2010-08-25
Posts: 164

Re: [SOLVED]Bluetooth not working

Yes it is.I try with two android smartphones and with laptop... Nothing found. And when i try to send something from my andorid smartphone to laptop same thing happend.Smartphone can't found the laptop.How to make laptop discoverable?


And... here... we... go!

Offline

#4 2013-02-26 21:42:18

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: [SOLVED]Bluetooth not working

If you want to do it that way, you need to make the laptop visible/discoverable. I asked about the other device because when I did something similar (phone but not smart), I made the phone visible (temporarily) and had the laptop scan for the phone, I think. But I assume either way should work. You just need to get them paired. You won't be able to send files until the pairing is set up, though.

In KDE, I can make the laptop "discoverable" via the systray bluetooth icon but obviously you can do it in other ways, too. I'm not sure how those terms map onto the options for hciconfig, hcitool etc. but I'm assuming they are what you'd use at the command line.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#5 2013-02-27 19:48:36

grobar87
Member
From: Македонија
Registered: 2010-08-25
Posts: 164

Re: [SOLVED]Bluetooth not working

I try to pair laptop and smartphone with blueman but not working.And i make laptop discoverable with blueman too but nothing found.


And... here... we... go!

Offline

#6 2013-02-27 23:19:49

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: [SOLVED]Bluetooth not working

"not working" isn't much to go on. You'll have to do better than that if you want help. What errors do you get? Check the log files?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#7 2013-05-14 19:50:56

grobar87
Member
From: Македонија
Registered: 2010-08-25
Posts: 164

Re: [SOLVED]Bluetooth not working

Fixed in kernel 3.9


And... here... we... go!

Offline

Board footer

Powered by FluxBB