You are not logged in.

#1 2013-03-02 11:34:20

blackout23
Member
Registered: 2011-11-16
Posts: 780

NVIDIA + UEFI = Problems?

Hello,

on the Arch Linux - NVIDIA Wiki page I read that UEFI *might* cause problems with the proprietary driver.
I searched for thread and found some also referring to this post by NVIDIA Linux devs:
http://www.nvnews.net/vbulletin/showpos … stcount=13


I couldn't find any information if the latest 313.18 driver still has these problem or if it's good to go now.
I'm planning on setting up my PC with UEFI but of course wouldn't even try if it simply doesn't work with the latest driver.

So if you use the latest driver and a UEFI boot setup I would appreciate if you could give me a quick thumbs up or thumbs down.

Regards,

blackout23

Offline

#2 2013-03-02 11:40:54

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: NVIDIA + UEFI = Problems?

It seems to work. Though the nvidia driver complains about:

NVRM: Your system is not currently configured to drive a VGA console
NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
NVRM: requires the use of a text-mode VGA console. Use of other console
NVRM: drivers including, but not limited to, vesafb, may result in
NVRM: corruption and stability problems, and is not supported.

Offline

#3 2013-03-02 11:44:33

blackout23
Member
Registered: 2011-11-16
Posts: 780

Re: NVIDIA + UEFI = Problems?

Thank you. I remeber these messages from my BIOS based laptop, when passing vga=somenumber in the kernel line. Without it i never had it in my dmesg but didn't cause any problem when I used vga option anyway.

If enough people can confirm that there is no severe issue with latest nvidia and UEFI I would add this information to the Wiki.

Offline

#4 2013-03-02 11:47:41

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: NVIDIA + UEFI = Problems?

I did not find a way to disable efifb and still have console output.

Offline

#5 2013-03-02 11:59:36

Šaran
Member
From: Bosnia
Registered: 2011-09-03
Posts: 407

Re: NVIDIA + UEFI = Problems?

I have been UEFI booting for almost two years and haven't had a single gpu-related problem with my Nvidia 460M.

Offline

#6 2013-03-02 12:43:24

ronmon
Member
Registered: 2011-04-15
Posts: 29

Re: NVIDIA + UEFI = Problems?

Biostar TA970XE and a NVIDIA GeForce GT 520 here. Using rEFInd with efistub. No problems whatsoever.

Offline

#7 2013-03-02 18:59:13

mynis01
Member
Registered: 2011-04-29
Posts: 66

Re: NVIDIA + UEFI = Problems?

I use UEFI and the NVIDIA blob with a GTX 670 and it's mostly stable. If I use tmux/screen and certain other apps from a tty while X is running I get some video corruption in the tty. However, it goes away once I switch back to X. Sometimes, if I trigger the video corruption when I'm using a CUDA app it can cause some workloads to fail. Some people can actually apparently get the error messages to go away by using certain bootloader and tty settings, but I never had any such luck and just stuck with the nicer looking TTY since it didn't seem to impact performance or anything. One of these days I need to set up EFISTUB to see if that changes anything.

Offline

Board footer

Powered by FluxBB