You are not logged in.

#1 2013-03-04 15:17:16

x-yuri
Member
Registered: 2013-01-06
Posts: 98

virtualbox: shared folder doesn't get auto-mounted

I created shared folder on host with auto-mounted checkbox being set. But it doesn't get mounted after login. I can mount it manually without a hitch though. According to virtualbox documentation it's to be mounted in /media/sf_SHARED_FOLDER_NAME. As it turned out however /media directory is probably moved to /run/media/USER. But I can see neither /media, nor /run/media.

Any ideas? Thanks in advance.

Offline

#2 2013-03-04 15:54:02

stqn
Member
Registered: 2010-03-19
Posts: 1,189
Website

Re: virtualbox: shared folder doesn't get auto-mounted

For me this auto-mounting has been useless since the auto-mounted volumes require root permission to be accessed, so I’m manually mounting the volumes from rc.local anyway…

Offline

#3 2013-03-04 16:01:55

x-yuri
Member
Registered: 2013-01-06
Posts: 98

Re: virtualbox: shared folder doesn't get auto-mounted

stqn, did you try to do it with /media directory or with /run/media? Do you have them? What are the permissions?

Offline

#4 2013-03-04 16:04:24

stqn
Member
Registered: 2010-03-19
Posts: 1,189
Website

Re: virtualbox: shared folder doesn't get auto-mounted

I’m manually mounting to /mnt, and as far as auto-mounting is concerned, I didn’t see any option. They were mounted to /media if I remember correctly (under Ubuntu 10.04.)

Offline

#5 2013-03-22 09:11:36

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,750

Re: virtualbox: shared folder doesn't get auto-mounted

Having problems setting up shared folders too. Following this in wiki

https://wiki.archlinux.org/index.php/Vi … inux_Guest

Only link to pastebin (for me) is borken....


Mr Green

Offline

Board footer

Powered by FluxBB