You are not logged in.

#1 2013-03-06 03:18:10

prokonsole
Member
Registered: 2012-12-15
Posts: 28

[solved] - conflicting dependencies - desktop stage of installation

Goodday,

Installation to hard drive using USB drive with CD 2013.03.01

Installation went well and arch is up and running in text mode.
As is usual for me with Arch distros (or any other for that matter) I choose KDE for the graphical side of things.

Previous installations of arch (December release and February release) have proceeded from this point with no problems.
Today's output from:

pacman -S kde kde-l10n-en_gb

produced - after showing me the packages to be downloaded and allowing me to choose a phonon -

error:unresolvable package conflicts detected
error:failed to prepare transaction (confilcts dependencies)
::kdesk-dev-scripts and kdesdk-scripts are in conflict

Has anyone come across this before? If so how did you get past this sticking point?

Thanks,

Hugh

Last edited by prokonsole (2013-03-06 20:28:39)

Offline

#2 2013-03-06 04:28:21

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: [solved] - conflicting dependencies - desktop stage of installation

KDE is just being upgraded to the most recent version. This may involve some fluctuations in package naming schemes. Simply keep your local pacman database updated (pacman -Syy), and when necessary, let pacman replace older versions of packages with recent ones.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#3 2013-03-06 04:38:42

prokonsole
Member
Registered: 2012-12-15
Posts: 28

Re: [solved] - conflicting dependencies - desktop stage of installation

bohoomil wrote:

Simply keep your local pacman database updated (pacman -Syy), and when necessary, let pacman replace older versions of packages with recent ones.

Thanks for the reply.

I don't have any versions of KDE packages for pacman to replace since the installation could not proceed.

Hugh

Offline

#4 2013-03-06 04:42:57

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: [solved] - conflicting dependencies - desktop stage of installation

So temporarily remove the packages that stop the installation and after refreshing the database try installing them back.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#5 2013-03-06 06:40:33

prokonsole
Member
Registered: 2012-12-15
Posts: 28

Re: [solved] - conflicting dependencies - desktop stage of installation

bohoomil wrote:

So temporarily remove the packages that stop the installation and after refreshing the database try installing them back.

So that would be these two? The ones listed in my first post are kdesk-dev-scripts and kdesdk-scripts.

So I would instruct pacman by use of switches - added after careful consultation of the pacman wiki entry - to withold one or both of these packages.

Alas, I cannot remove them since they do not yet exist.

Hugh

Offline

#6 2013-03-06 07:55:00

Awebb
Member
Registered: 2010-05-06
Posts: 4,301

Re: [solved] - conflicting dependencies - desktop stage of installation

Wait a while. Your mirror is not fully sync with the new packages yet. This happened to me yesterday as well, but with different packages. Pick a more recent mirror and update using Syyu. The problem should solve itself, as all KDE packages move to the new version.

Offline

#7 2013-03-06 19:32:37

prokonsole
Member
Registered: 2012-12-15
Posts: 28

Re: [solved] - conflicting dependencies - desktop stage of installation

Awebb wrote:

Wait a while. Your mirror is not fully sync with the new packages yet. This happened to me yesterday as well, but with different packages. Pick a more recent mirror and update using Syyu. The problem should solve itself, as all KDE packages move to the new version.

Well I waited while - overnight in fact.

Went back to my full fresh Arch install with no Desktop Environment
ran reflector to make sure I had a properly synced mirror
issued

pacman -Syyu

accepted the two files offered for today's update
then issued the command

pacman -S kde kde-l10n-en_gb

accepted the default which is everything
chose gstreamer-phonon when offered
then still get the conflicting files whic means the installation does not proceed

pacman -Ss kdesdk-scripts

produces

kdesdk-scripts 4.10.0.2

pacman -Ss kdesdk-dev-scripts

produces

kdesdk-dev-scripts 4.10.1-1

That they have different version numbers is fairly obvious.

Maybe another 24 hours will see the older package disappear.

edit: on my regular fully updated Arch install the package kdesdk-dev-scripts does not exist. So it looks like I can do without it!

another edit: emailed the maintainer who has fixed the conflict.

marking post as solved.

Hugh

Last edited by prokonsole (2013-03-06 20:32:40)

Offline

Board footer

Powered by FluxBB