You are not logged in.

#1 2011-07-14 09:56:10

ashunter
Member
Registered: 2007-06-16
Posts: 47

Unable to contact KDED

KDE is kinda bloated after upgrade to 4.6 and haven't been fixed yet.
When i tried to disable some Services through System Setting -> Services Manager
I got a message said
Unable to contact KDED.
How to fix this?
And does anyone know why kde become so slow?Kde4.5 is fine.

Offline

#2 2011-07-14 14:06:30

karper
Member
Registered: 2008-08-10
Posts: 49

Re: Unable to contact KDED

Try rebooting.

kded is a daemon that takes care of very small tasks like ejecting your CD tray etc. There should only be one instance of this running. I had an issue recently where kded wasn't terminated when I logged out and back in. This resulted in two daemons competing with each other (and taking 100% of a CPU core each). The solution was to reboot.

In your case, the system settings kcm is trying to talk to kded through dbus, but for some reason, it's not responding. I'm guessing this is update-related. So, a reboot should clear things up.

Offline

#3 2013-03-08 01:57:26

szym
Member
Registered: 2007-11-16
Posts: 14

Re: Unable to contact KDED

When I have two KDE sessions (two X screens), each starts an instance of kded4. The result is "Unable to contact KDED". In all other aspects, user switching works just fine, but because requests to KDED need to time out, opening dolphin (or any file selector) takes a really long time.

Any ideas?

Offline

Board footer

Powered by FluxBB