You are not logged in.

#1 2013-03-13 14:00:05

xvedejas
Member
Registered: 2008-11-19
Posts: 18

[SOLVED] External encrypted harddrive mounting?

lsusb:

Bus 003 Device 004: ID 174c:55aa ASMedia Technology Inc. ASMedia 2105 SATA bridge

It is an external USB3 harddrive with a single 500GB lukscrypt encrypted partition on it. When plugging the drive in, nodes are created in /dev at /dev/bus/usb/003/006 and /dev/char/189:261 (these numbers change each time). However, using cryptsetup luksOpen on either of these nodes does not create an entry in /dev/mapper (on ubuntu, this works but the node is something like /dev/sdb1).

How do I mount this harddrive?

Last edited by xvedejas (2013-03-13 22:18:07)

Offline

#2 2013-03-13 14:12:01

vacant
Member
From: downstairs
Registered: 2004-11-05
Posts: 797

Re: [SOLVED] External encrypted harddrive mounting?

Google "174c:55aa", lots of problems with that hard drive usb controller. Tried it in a USB 2.0 port?

Offline

#3 2013-03-13 14:20:19

xvedejas
Member
Registered: 2008-11-19
Posts: 18

Re: [SOLVED] External encrypted harddrive mounting?

Things are pretty much exactly the same in a 2.0 port. The harddrive is fully functional in ubuntu, so I'm confident there's some workaround.

Offline

#4 2013-03-13 22:17:50

xvedejas
Member
Registered: 2008-11-19
Posts: 18

Re: [SOLVED] External encrypted harddrive mounting?

This problem was solved by installing linux-git from the AUR. So there was probably either a missing module or I needed a newer kernel version.

Offline

Board footer

Powered by FluxBB