You are not logged in.

#1 2013-03-07 21:52:35

Anders H
Member
From: Reno, NV
Registered: 2011-07-31
Posts: 43
Website

[solved]KDM.service is not starting at log-in

Update 03/14/13

For those of you with similar issues after a DE switch.

With some help I was able to fix this, it was a "I missed a little thing" issue. tongue 

Before I switched to KDE I was running Awesome with Slim as my log-in manager and was starting slim from systemd

When I ran the command that cfr mentioned I noticed that display-manager.service was linked to slim.service; a now removed file because I uninstalled slim for KDM.

[root@freki system]# ls -l /etc/systemd/system/display-manager.service 
lrwxrwxrwx 1 root root 36 Aug 13  2012 /etc/systemd/system/display-manager.service -> /usr/lib/systemd/system/slim.service

so I removed the symbolic link and re-enabled kdm.service

[root@freki anders]# sudo rm -r /etc/systemd/system/display-manager.service
[root@freki anders]# systemctl enable kdm.service

After a reboot all was well. Hope this helps someone, and thank you to cfr and eticre. big_smile

***********************************************************************************************************************************************************************'

Hello everyone,

Recently I switched to KDE and I'm having some difficulty in getting kdm.service to start at log-in.

Following the Wiki I used the command

sudo systemctl enable kdm.service

and

sudo systemctl start kdm.service

and everything went well, but on reboot I was kicked back to TTY1 at log-in. I can start kdm.service manually to log-in to KDE but no matter what I do no joy.

Here is the output of

sudo systemctl status kdm.service
kdm.service - K Display Manager
          Loaded: loaded (/usr/lib/systemd/system/kdm.service; disabled)
          Active: active (running) since Thu 2013-03-07 05:15:15 PST; 8h ago
        Main PID: 1025 (kdm)
          CGroup: name=systemd:/system/kdm.service
                  ├─1025 /usr/bin/kdm -nodaemon
                  └─1027 /usr/bin/X -br -novtswitch -quiet :0 vt7 -nolisten tcp -auth /var/run/xauth/A:0-SjSveb

Mar 07 05:15:15 freki systemd[1]: Started K Display Manager.
Mar 07 05:15:33 freki kdm[1104]: :0[1104]: pam_unix(kde:session): session opened for user anders by (uid=0)
Mar 07 05:15:33 freki kdm[1104]: :0[1104]: pam_ck_connector(kde:session): nox11 mode, ignoring PAM_TTY :0

and

sudo systemctl show kdm.service
Id=kdm.service
Names=kdm.service
Requires=systemd-journald.socket basic.target
Conflicts=shutdown.target
Before=shutdown.target
After=systemd-user-sessions.service systemd-journald.socket basic.target
Description=K Display Manager
LoadState=loaded
ActiveState=active
SubState=running
FragmentPath=/usr/lib/systemd/system/kdm.service
UnitFileState=disabled
InactiveExitTimestamp=Thu 2013-03-07 05:15:15 PST
InactiveExitTimestampMonotonic=183730500
ActiveEnterTimestamp=Thu 2013-03-07 05:15:15 PST
ActiveEnterTimestampMonotonic=183730500
ActiveExitTimestampMonotonic=0
InactiveEnterTimestampMonotonic=0
CanStart=yes
CanStop=yes
CanReload=no
CanIsolate=no
StopWhenUnneeded=no
RefuseManualStart=no
RefuseManualStop=no
AllowIsolate=no
DefaultDependencies=yes
OnFailureIsolate=no
IgnoreOnIsolate=no
IgnoreOnSnapshot=no
DefaultControlGroup=name=systemd:/system/kdm.service
ControlGroup=cpu:/system/kdm.service name=systemd:/system/kdm.service
NeedDaemonReload=no
JobTimeoutUSec=0
ConditionTimestamp=Thu 2013-03-07 05:15:15 PST
ConditionTimestampMonotonic=183725595
ConditionResult=yes
Type=simple
Restart=no
NotifyAccess=none
RestartUSec=100ms
TimeoutUSec=1min 30s
TimeoutStartUSec=1min 30s
TimeoutStopUSec=1min 30s
WatchdogUSec=0
WatchdogTimestampMonotonic=0
StartLimitInterval=10000000
StartLimitBurst=5
StartLimitAction=none
ExecStart={ path=/usr/bin/kdm ; argv[]=/usr/bin/kdm -nodaemon ; ignore_errors=no ; start_time=[n/a] ; stop_time=[n/a] ; pid=0 ; code=
PermissionsStartOnly=no
RootDirectoryStartOnly=no
RemainAfterExit=no
GuessMainPID=yes
MainPID=1025
ControlPID=0
Result=success
UMask=0022
LimitCPU=18446744073709551615
LimitFSIZE=18446744073709551615
LimitDATA=18446744073709551615
LimitSTACK=18446744073709551615
LimitCORE=18446744073709551615
LimitRSS=18446744073709551615
LimitNOFILE=4096
LimitAS=18446744073709551615
LimitNPROC=127201
LimitMEMLOCK=65536
LimitLOCKS=18446744073709551615
LimitSIGPENDING=127201
LimitMSGQUEUE=819200
LimitNICE=0
LimitRTPRIO=0
LimitRTTIME=18446744073709551615
OOMScoreAdjust=0
Nice=0
IOScheduling=0
CPUSchedulingPolicy=0
CPUSchedulingPriority=0
TimerSlackNSec=50000
CPUSchedulingResetOnFork=no
NonBlocking=no
StandardInput=null
StandardOutput=journal
StandardError=inherit
TTYReset=no
TTYVHangup=no
TTYVTDisallocate=no
SyslogPriority=30
SyslogLevelPrefix=yes
SecureBits=0
CapabilityBoundingSet=18446744073709551615
MountFlags=0
PrivateTmp=no
PrivateNetwork=no
SameProcessGroup=no
ControlGroupModify=no
ControlGroupPersistent=no
IgnoreSIGPIPE=yes
NoNewPrivileges=no
KillMode=control-group
KillSignal=15
SendSIGKILL=yes
ExecMainStartTimestamp=Thu 2013-03-07 05:15:15 PST
ExecMainStartTimestampMonotonic=183730446
ExecMainExitTimestamp=Thu 2013-03-07 05:15:15 PST
ExecMainExitTimestampMonotonic=183730446
ExecMainPID=1025
ExecMainCode=0
ExecMainStatus=0

Both commands were passed while KDE was running.

I'm no Systemd expert but I noticed that kde.service is listed as "disabled" despite being enabled by me also (related?) the "Unit File Status" is listed as disabled as well. I've tried to disable and then enable again kde.service but still no luck. I can't seem to figure out what is causing this? I've looked at my .xinitrc and I don't have kde enabled but I thought that systemd was supposed to take care of that for me.

Last edited by Anders H (2013-03-15 05:31:23)

Offline

#2 2013-03-09 16:43:40

eticre
Member
Registered: 2011-10-15
Posts: 49

Re: [solved]KDM.service is not starting at log-in

Hi

This is the output when enabling kdm

[alberto@gretto ~]$ sudo systemctl enable kdm.service
ln -s '/usr/lib/systemd/system/kdm.service' '/etc/systemd/system/display-manager.service'
[alberto@gretto ~]$

verify in your /etc/systemd/system directory if kdm.service is linked

Offline

#3 2013-03-10 03:43:14

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: [solved]KDM.service is not starting at log-in

I'm a bit confused about what's happening. Is it this:
1) On boot, you end up at the tty rather than getting a graphical login provided by KDM;
2) Once you've logged in on the tty, you can start KDM and then you can log in to KDE and everything is fine?

What does

ls -l /etc/systemd/system/display-manager.service

give?

And what is your kernel command line?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#4 2013-03-15 05:07:18

Anders H
Member
From: Reno, NV
Registered: 2011-07-31
Posts: 43
Website

Re: [solved]KDM.service is not starting at log-in

Hello and thank you for the responses, I've had to ignore this post for a bit because of a school paper so sorry for the late response, anyway...

eticre and cfr "display-manager.service" is in /etc/systemd/system/

BUT

 
[root@freki system]# ls -l /etc/systemd/system/display-manager.service 
lrwxrwxrwx 1 root root 36 Aug 13  2012 /etc/systemd/system/display-manager.service -> /usr/lib/systemd/system/slim.service

hmmm..... slim.service is running lets fix that.

I'll try removing the symbolic link and re-enabling kdm.service 

@cfr - yes that is what is happening, also what do you mean "kernel command line?" I just drop to TTY1 at log-in.

Offline

#5 2013-03-15 05:19:25

Anders H
Member
From: Reno, NV
Registered: 2011-07-31
Posts: 43
Website

Re: [solved]KDM.service is not starting at log-in

I was able to fix it, I'll mark this as solved and put a full how to in the first post

Offline

Board footer

Powered by FluxBB