You are not logged in.

#1 2013-03-16 09:21:27

mrb101
Member
Registered: 2012-06-30
Posts: 16

grub is not loading automatically

I have just finish installing my Archlinux on my Laptop with Gnome and Grub-bios Boot loader ! The problem i am having is i can't load Grub unless i use the live CD and then choose to boot another OS from the Hard Drive... Then i get Grub and i can boot into my archlinux ! other wise i will just get the Boot Menu Selection and when choosing my hard disk and just loops back to it !!

Any one have any idea why is it doing so ?!

Offline

#2 2013-03-16 11:20:25

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,217
Website

Re: grub is not loading automatically

Request: fewer exclamation points; more explanation points.

You say you installed grub-bios, but installing the package is not sufficient.  Did you follow the grub page on the wiki and run grub-install and the mk-config commands?


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#3 2013-03-16 11:29:19

mrb101
Member
Registered: 2012-06-30
Posts: 16

Re: grub is not loading automatically

Yes i have. I followed the exact steps. and i did it like 3 times over and over. But still the same result..

Offline

#4 2013-03-16 11:33:38

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,217
Website

Re: grub is not loading automatically

That's not informative.  There are four options in the wiki.  Each of those have commands that can be considered templates for what you need to run.  If you ran those exact steps, I doubt it would work.

Please elaborate exactly what you have actually done and include any errors or other messages that were received.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#5 2013-03-16 11:56:32

mrb101
Member
Registered: 2012-06-30
Posts: 16

Re: grub is not loading automatically

Thanks alot trilby smile

My Hard Drive is 3 partitions:

sda1: root, ext4
sda2: home, ext4
sda3: swap, swap

I have installed grub-bios.

Then

      # grub-install --target=i386-pc --recheck /dev/sda

and then

      # cp /usr/share/locale/en\@quot/LC_MESSAGES/grub.mo /boot/grub/locale/en.mo

No errors at all. it was all fine.

i rebooted And all i get is the fast boot menu from my laptop. unless i boot from the CD medium and choose the option: Boot another OS i can't get to Grub. and then to my archlinux system.

Offline

#6 2013-03-16 12:26:27

henk
Member
From: Weert, Netherlands
Registered: 2013-01-01
Posts: 332

Re: grub is not loading automatically

mrb101 wrote:

Thanks alot trilby smile

Then

      # grub-install --target=i386-pc --recheck /dev/sda

and then

      # cp /usr/share/locale/en\@quot/LC_MESSAGES/grub.mo /boot/grub/locale/en.mo

No errors at all. it was all fine.

As Trilby mentioned did you do the mk-config command?

# grub-mkconfig -o /boot/grub/grub.cfg

Last edited by henk (2013-03-16 12:27:16)

Offline

#7 2013-03-16 12:42:06

mrb101
Member
Registered: 2012-06-30
Posts: 16

Re: grub is not loading automatically

yes, i have

Offline

#8 2013-03-16 16:42:36

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,675

Re: grub is not loading automatically

Post /boot/grub/grub.cfg.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#9 2013-03-16 17:16:35

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: grub is not loading automatically

I guess if you are not booting initially via CD, your system boots into UEFI mode (guessing based on the fast boot option you mentioned, which again I guess exist only in UEFI systems). When you boot into CD which launches the syslinux (BIOS-based) with-in the CD and then you chainload grub-bios installed in your HDD. Check your firmware settings, and if you are not using UEFI for booting anything, disable it in the firmware setup. BTW you didn't mention what machine is that and what OS was pre-installed in the machine. If it is Windows 8, then you definitely are booting Windows via UEFI and the firmware tries only UEFI boot for the HDD, thus booting into Windows.

Offline

#10 2013-03-16 19:10:16

mrb101
Member
Registered: 2012-06-30
Posts: 16

Re: grub is not loading automatically

My Laptop is Toshiba c660 and i had Ubuntu installed and it didn't have a pre-installed OS and i didn't face any problems but i guess you are right in describing the problem. i just don't know how to fix it.
I was planning to install syslinux instead of Grub but i am not sure if that will solve the problem. Do you know of any way to fix grub ?!

Last edited by mrb101 (2013-03-16 19:11:25)

Offline

#11 2013-03-16 20:19:04

s1ln7m4s7r
Member
Registered: 2013-02-22
Posts: 262

Re: grub is not loading automatically

Are you using gpt or mbr partition table?

Remember the Preliminary Requirements for each one:

https://wiki.archlinux.org/index.php/GR … _for_GRUB2

Syslinux doesn't have any of those requirements, so a basic install will work with a basic disk setup.

Last edited by s1ln7m4s7r (2013-03-16 20:24:03)

Offline

#12 2013-03-16 21:31:14

mrb101
Member
Registered: 2012-06-30
Posts: 16

Re: grub is not loading automatically

Thanks a lot.

I just installed Syslinux and it worked perfectly smile

Really appreciate your help and time

Offline

#13 2013-03-16 21:31:44

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: grub is not loading automatically

Maybe check if you marked sda1 as "boot"-able in the partition table.

Offline

#14 2013-03-17 00:15:49

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,675

Re: grub is not loading automatically

Please mark your thread [solved] by editing your original post and tagging the subject line.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

Board footer

Powered by FluxBB