You are not logged in.

#1 2013-03-18 12:51:47

Pranavg1890
Member
From: Nagpur,India
Registered: 2012-09-07
Posts: 111

[SOLVED] After qt upgrade problem

Hello guys I upgraded my system. Now ,all the qt apps give this error when starting:

error while loading shared libraries: libaudio.so.2: cannot open shared object file: No such file or directory

Also, when i start kde , it gives me this error:


/usr/bin/kde4-config: symbol lookup error: /usr/lib/libkdecore.so.5: undefined symbol: qt_locale_initialized
kdostartupconfig4: symbol lookup error: /usr/lib/libkdecore.so.5: undefined symbol: qt_locale_initialized
kde4-config: symbol lookup error: /usr/lib/libkdecore.so.5: undefined symbol: qt_locale_initialized
kde4-config: symbol lookup error: /usr/lib/libkdecore.so.5: undefined symbol: qt_locale_initialized
kde4-config: symbol lookup error: /usr/lib/libkdecore.so.5: undefined symbol: qt_locale_initialized
kde4-config: symbol lookup error: /usr/lib/libkdecore.so.5: undefined symbol: qt_locale_initialized
startkde: ERROR: Could not locate lnusertemp in
/usr/bin/startkde: line 248: : command not found
startkde: Call to lnusertemp failed (temporary directories full?). Check your installation.

Before the upgrade all qt apps and KDE was running without problems. I have installed both the qt5 group(full) and qt4 on my system. Please help.

Last edited by Pranavg1890 (2013-03-20 14:45:41)


Using Openbox + Tint2 + Idesk

Offline

#2 2013-03-18 13:19:20

xacobe97
Member
From: Galicia, Spain
Registered: 2013-03-17
Posts: 5

Re: [SOLVED] After qt upgrade problem

You can install libaudio from yaourt in the multilib repository:

sudo yaurt -S lib32-libaudio2

Offline

#3 2013-03-18 13:30:24

Pranavg1890
Member
From: Nagpur,India
Registered: 2012-09-07
Posts: 111

Re: [SOLVED] After qt upgrade problem

I think that file is for 64-bit system. My Arch Installation is 32-bit. Anyway, Thanks for replying.


Using Openbox + Tint2 + Idesk

Offline

#4 2013-03-18 14:16:32

Pranavg1890
Member
From: Nagpur,India
Registered: 2012-09-07
Posts: 111

Re: [SOLVED] After qt upgrade problem

Also, When I run qtconfig, the qt3 configuration dialog appears.Earlier, the qt4 configuration dialog used to open up. Many Thanks.Please Help. I 'm not able to run my qt apps due to this.


Using Openbox + Tint2 + Idesk

Offline

#5 2013-03-18 14:28:20

progandy
Member
Registered: 2012-05-17
Posts: 2,151

Re: [SOLVED] After qt upgrade problem

qtconfig is the dialog fo qt3, qtconfig-qt4 is the new name for the qt4 version.

Offline

#6 2013-03-18 14:33:28

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,311

Re: [SOLVED] After qt upgrade problem

libaudio.so.2 probably came from the network audio system, nas .
The nas package was moved from community to aur in december 2011 .

Please post the output of pacman -Qm, this will show a list of all installed packages on your system that are not in any repo.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#7 2013-03-19 04:31:43

Pranavg1890
Member
From: Nagpur,India
Registered: 2012-09-07
Posts: 111

Re: [SOLVED] After qt upgrade problem

Hi Friends, the output of pacman -Qm is as folllows:

2a 20121016-1
9wm 1.2-3
adeskbar 0.5.1-1
alsaequal 0.6-6
archey 20120929-1
archiso-git 20121109-1
audacious-almond-themes 20090621-1
aurget 3.4.2-1
aurlizer 0.1-1
aurvote 1.5-1
awoken-icons 2.4-1
bashish 2.2.4-1
bashrun2 0.2.2-1
cadubi 1.3-2
cairo-compmgr-git 20121231-1
cairo-dock 3.1.2-1
cdf 0.2-1
cegui-0.6 0.6.2-13
celt0.5.1 0.5.1.3-1
chromium-pepper-flash-stable 11.4.31.110-2
cinnamon-theme-zukitwo 1.4-2
clockywock 0.2.3H-1
command-not-found 0.4.4-1
compton-git 20130101-1
conkeror-git 20121019-1
conky-colors 8.1.1git20120915-2
conky-lua 1.9.0-1
cower 6-1
cplay 1.49-3
curlew 0.1.14.1-1
customizepkg 0.2.1-1
dfc 3.0.1-1
dlpr-git 20121115-1
dmenfm 0.1.2-1
dmenu-launch 0.5.8-2
dmenu-tools-git 20121117-1
dmenu-xft-height 4.5-1
dmenu_mocp 0.4.1-1
elinks-git 20121012-1
enhanced-ctorrent dnh3.3.2-1
fbcmd 1.1-1
fbff-git 20121010-1
fbpdf-git 20121010-1
glyr-git 20121006-1
gnome-boxes 3.4.3-2
gnome-shell-theme-dark-shine 20120622-1
gnome-shell-theme-eos 1.4-1
gnome-shell-theme-faience 0.3-2
gnome-shell-theme-nord 1.4b-5
gnusim8085 1.3.7-1
google-chrome 25.0.1364.97-1
goomwwm 1.0.0-1
grub-customizer 3.0.2-2
gtk-theme-adwaita-cupertino-glassy 1.4.3-1
gtk-theme-config 0.3-1
hnb 1.9.17-5
i-nex-bzr 235-1
ibmonitor 1.4-1
iocane 0.2-1
isomaster 1.3.9-1
jed 0.99.19-2
jreen 1.1.1-1
ldm-git 20121109-1
lfm 2.3-1
libcacard 0.1.2-1
libdrm-nouveau1 2.4.33-1
libechonest2 2.0.1-2
libmpdclient-git 20121008-1
libosinfo 0.2.1-1
libswift 6.0.0-1
libvirt-glib 0.1.3-1
lightspark-git 20121121-1
links-g-directfb 2.7-1
lshw-gtk B.02.16-1
lsw 0.2-2
lsx 0.1-12
lyvi-git 20121231-1
mod_scgi 1.14-2
monsterwm-git 20121019-1
mp3blaster 3.2.5-3
musca 0.9.24-3
nano-syntax-highlighting-git 20121012-1
ncmatrix 1.0-1
neap 0.7-2
nemo-git 20121022-1
nitrotasks 1.5-1
nitrux-icon-theme 2.4a-1
obkey-git 20121225-1
obmenugen-bin 0.5-3
obmixer 0.11-5
openbox-autumn-theme 20091215-1
openssl098 0.9.8.x-1
orion-gtk-theme 20120616-1
pacaur 3.2.4-1
package-query 1.1-2
packer 20121029-1
pacman-color 4.0.3-3
pacmanexpress 2.4.1-1
pacmanxg4-bin 4.13.12-2
pcurses 1.5-1
pnmixer 0.5.1-1
python-glyr-git 20121006-1
python-pyalsaaudio 0.7-1
python2-apsw 3.7.9_r1-1
python2-glyr-git 20121022-1
qemu-kvm-spice 1.2.0-2
qtweetlib 0.5-1
ranger-git 20121103-1
rar 4.1.1-1
repacman-en 0.98-2
ruby-multi_json 1.3.6-1
ruby-multi_xml 0.5.1-1
rutorrent 3.4-3
rxvt-unicode-patched 9.15-5
sandy-hg 107-1
selectwm 0.4.1-3
simpleswitcher-git 20121209-1
slider-git 20121107-1
slmenu-hg 9-2
soundz 2.5-1
spice 0.12.0-1
spice-gtk3 0.13-1
spice-protocol 0.12.2-1
sysinfo-sui 0.2-1
systemd-arch-units 20120915-2
teamviewer 7.0.9377-1
telescope 8-1
tint2-svn 650-1
tint2-themes 0.10-1
tintwizard 0.3.4-2
tinywm 1.3-5
toluapp 1.0.93-5
tpp 1.3.1-1
transmission-remote-cli-git 20121016-1
tribler 6.0.1-1
ttf-chromeos-fonts 1.21.0-1
ttf-ms-fonts 2.0-9
ttwm-git 20121114-1
tty-clock 20121107-1
usbredir 0.4.4-1
utorrent-server 25376-3
vimprobable2-git 20121114-1
vuze 4.9.0.0-1
w9wm 0.4.2-2
wm2 4-1
xcursor-ecliz 1.0-1
xcursor-ecliz-arch 2.0-2
yaourt 1.2.1-1
yaourt-gui 0.9-2
yeahwm 0.3.5-2
yt-git 20130127-1
yturl-git 20130131-1
zukitwo-theme-openbox 20111021-3
zukitwo-themes 20121211-1

  Please Help.

Mod Edit:  Added code tags [ewaller]

Last edited by Pranavg1890 (2013-03-19 04:48:57)


Using Openbox + Tint2 + Idesk

Offline

#8 2013-03-19 04:38:56

Pranavg1890
Member
From: Nagpur,India
Registered: 2012-09-07
Posts: 111

Re: [SOLVED] After qt upgrade problem

Hi Freinds, I installed the nas package from aur. now all the qt apps give me this error:

error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

I bet this problem has something to do with installation of qt. but reinstalling qt4 gives me the same problem.

Also, I tried compiling qt apps such as qbittorrent from aur but they all fail at build step of :

Configuring qbittorrent ...
Verifying Qt 4 build environment ... .qconftemp/conf: symbol lookup error: .qconftemp/conf: undefined symbol: _ZN9QListData11detach_growEPii
fail

Please Help me Friends.

Last edited by Pranavg1890 (2013-03-19 05:12:52)


Using Openbox + Tint2 + Idesk

Offline

#9 2013-03-19 04:40:23

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,131

Re: [SOLVED] After qt upgrade problem

Pranavg1890 wrote:

  Please Help.

Okay, I edited your post and added bbcode code tags. wink
You can edit your post to see how it should be done.

Thanks.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#10 2013-03-19 11:29:44

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,311

Re: [SOLVED] After qt upgrade problem

Pranavg1890, the problems you have are most likely caused by packages that were build against qt 4 and have not been updated/rebuild to work with the new qt4 setup.

The only way i see to solve the porblems is to correct all problems 1 by 1.
Given the amount of packages you have from aur (or other sources), this will be a lot of work.
I suggest you look at the pacman -Qm list, and remove everything you don't need in the next few days/weeks .
After the problems are solved, you can put them back 1 by 1 .

Install the pkgfile program from extra, this will help a lot with determining which package provides a certain file.

[panoramix@obelix ~]$ pkgfile libpng12.so.0
extra/nxclient
community/libpng12
community/sage-mathematics
multilib/lib32-libpng12
[panoramix@obelix ~]$ 

as you can see libpng12.s0.0 is present in several packages, the libpng12 package in community appears to be the best choice for you.
install/upgrade it, then check again what errors qt apps give.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#11 2013-03-20 04:19:50

Pranavg1890
Member
From: Nagpur,India
Registered: 2012-09-07
Posts: 111

Re: [SOLVED] After qt upgrade problem

Hi Friends, After Installing libpng12 from community , now the qt apps give me this error:

symbol lookup error: /usr/lib/libQtOpenGL.so.4: undefined symbol: _ZNK14QWidgetPrivate17hasHeightForWidthEv

Please Help.

Edit: I removed qt5 andd qt3 both from my system and then again reinstalled qt4, but the same problem persists.

Last edited by Pranavg1890 (2013-03-20 05:08:26)


Using Openbox + Tint2 + Idesk

Offline

#12 2013-03-20 10:49:23

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,311

Re: [SOLVED] After qt upgrade problem

A search for that error indicates it's most commonly caused by having multiple QT installations, chances are you have leftovers somewhere.

As root, run updatedb and locate libQt and post the output.

for reference here's the output from my system :

# locate libQt
/usr/lib/libQt3Support.prl
/usr/lib/libQt3Support.so
/usr/lib/libQt3Support.so.4
/usr/lib/libQt3Support.so.4.8
/usr/lib/libQt3Support.so.4.8.4
/usr/lib/libQtCLucene.prl
/usr/lib/libQtCLucene.so
/usr/lib/libQtCLucene.so.4
/usr/lib/libQtCLucene.so.4.8
/usr/lib/libQtCLucene.so.4.8.4
/usr/lib/libQtCore.prl
/usr/lib/libQtCore.so
/usr/lib/libQtCore.so.4
/usr/lib/libQtCore.so.4.8
/usr/lib/libQtCore.so.4.8.4
/usr/lib/libQtDBus.prl
/usr/lib/libQtDBus.so
/usr/lib/libQtDBus.so.4
/usr/lib/libQtDBus.so.4.8
/usr/lib/libQtDBus.so.4.8.4
/usr/lib/libQtDeclarative.prl
/usr/lib/libQtDeclarative.so
/usr/lib/libQtDeclarative.so.4
/usr/lib/libQtDeclarative.so.4.8
/usr/lib/libQtDeclarative.so.4.8.4
/usr/lib/libQtDesigner.prl
/usr/lib/libQtDesigner.so
/usr/lib/libQtDesigner.so.4
/usr/lib/libQtDesigner.so.4.8
/usr/lib/libQtDesigner.so.4.8.4
/usr/lib/libQtDesignerComponents.prl
/usr/lib/libQtDesignerComponents.so
/usr/lib/libQtDesignerComponents.so.4
/usr/lib/libQtDesignerComponents.so.4.8
/usr/lib/libQtDesignerComponents.so.4.8.4
/usr/lib/libQtGui.prl
/usr/lib/libQtGui.so
/usr/lib/libQtGui.so.4
/usr/lib/libQtGui.so.4.8
/usr/lib/libQtGui.so.4.8.4
/usr/lib/libQtHelp.prl
/usr/lib/libQtHelp.so
/usr/lib/libQtHelp.so.4
/usr/lib/libQtHelp.so.4.8
/usr/lib/libQtHelp.so.4.8.4
/usr/lib/libQtMultimedia.prl
/usr/lib/libQtMultimedia.so
/usr/lib/libQtMultimedia.so.4
/usr/lib/libQtMultimedia.so.4.8
/usr/lib/libQtMultimedia.so.4.8.4
/usr/lib/libQtNetwork.prl
/usr/lib/libQtNetwork.so
/usr/lib/libQtNetwork.so.4
/usr/lib/libQtNetwork.so.4.8
/usr/lib/libQtNetwork.so.4.8.4
/usr/lib/libQtOpenGL.prl
/usr/lib/libQtOpenGL.so
/usr/lib/libQtOpenGL.so.4
/usr/lib/libQtOpenGL.so.4.8
/usr/lib/libQtOpenGL.so.4.8.4
/usr/lib/libQtScript.prl
/usr/lib/libQtScript.so
/usr/lib/libQtScript.so.4
/usr/lib/libQtScript.so.4.8
/usr/lib/libQtScript.so.4.8.4
/usr/lib/libQtScriptTools.prl
/usr/lib/libQtScriptTools.so
/usr/lib/libQtScriptTools.so.4
/usr/lib/libQtScriptTools.so.4.8
/usr/lib/libQtScriptTools.so.4.8.4
/usr/lib/libQtSql.prl
/usr/lib/libQtSql.so
/usr/lib/libQtSql.so.4
/usr/lib/libQtSql.so.4.8
/usr/lib/libQtSql.so.4.8.4
/usr/lib/libQtSvg.prl
/usr/lib/libQtSvg.so
/usr/lib/libQtSvg.so.4
/usr/lib/libQtSvg.so.4.8
/usr/lib/libQtSvg.so.4.8.4
/usr/lib/libQtTest.prl
/usr/lib/libQtTest.so
/usr/lib/libQtTest.so.4
/usr/lib/libQtTest.so.4.8
/usr/lib/libQtTest.so.4.8.4
/usr/lib/libQtUiTools.a
/usr/lib/libQtUiTools.prl
/usr/lib/libQtWebKit.prl
/usr/lib/libQtWebKit.so
/usr/lib/libQtWebKit.so.4
/usr/lib/libQtWebKit.so.4.10
/usr/lib/libQtWebKit.so.4.10.0
/usr/lib/libQtXml.prl
/usr/lib/libQtXml.so
/usr/lib/libQtXml.so.4
/usr/lib/libQtXml.so.4.8
/usr/lib/libQtXml.so.4.8.4
/usr/lib/libQtXmlPatterns.prl
/usr/lib/libQtXmlPatterns.so
/usr/lib/libQtXmlPatterns.so.4
/usr/lib/libQtXmlPatterns.so.4.8
/usr/lib/libQtXmlPatterns.so.4.8.4

Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#13 2013-03-20 11:07:49

Awebb
Member
Registered: 2010-05-06
Posts: 4,435

Re: [SOLVED] After qt upgrade problem

To accelerate that part, where you don't have locate installed:

find / -name libQt*

Offline

#14 2013-03-20 14:45:06

Pranavg1890
Member
From: Nagpur,India
Registered: 2012-09-07
Posts: 111

Re: [SOLVED] After qt upgrade problem

Thanks both @Lone_wolf And @Awebb, that solved my problem. I had multiple files on my system in /usr/lib and /lib. I deleted the ones in /lib and now all qt apps function properly. Many thanks to you.I now mark this thread as solved. Thanks Again.


Using Openbox + Tint2 + Idesk

Offline

#15 2013-03-20 14:56:20

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,185

Re: [SOLVED] After qt upgrade problem

If you have different files in /lib than in /usr/lib then your installation is broken. /lib has been a symlink to /usr/lib for a while now

Last edited by arojas (2013-03-20 14:57:24)

Offline

Board footer

Powered by FluxBB