You are not logged in.

#1 2013-03-20 03:37:24

smello
Member
Registered: 2013-03-20
Posts: 1

Not Resuming after suspend (revisited)

(Moderator edit:Split these new posts from an older thread about an ancient kernel.)

I found my workaround using kernel boot parameter: hpet=disable highres=off nohz=off
from: https://wiki.archlinux.org/index.php/Le … _Hibernate
Hope it helps.

P.S.: "nohpet" or "hpet=disable" did not work for me.

Last edited by ewaller (2013-03-22 04:45:15)

Offline

#2 2013-03-22 03:00:27

Loong
Member
From: China
Registered: 2012-03-01
Posts: 6

Re: Not Resuming after suspend (revisited)

It seems everything works fine except the screen after resuming from suspend, I can hear the sound of a streaming video started before suspend, but the screen is black. My laptop is a Lenovo IdeaPad Y450 with intel cpu and nvidia gpu, increasing brightness dose not work for me.

Offline

#3 2013-03-22 03:23:48

plenus
Member
Registered: 2012-04-19
Posts: 25

Re: Not Resuming after suspend (revisited)

Hey folks, I can't resume either. I'm not using a laptop, but my older setup with Debian used to resume just fine. Now my systems seems to suspend fine, but on resuming, all three keyboard leds start to blink (caps lock , scroll lock and num lock), there is no monitor signal and nothing responds.

I'm using standard floss xorg drivers for my AMD Radeon HD 4890 cards and running everything from the standard Arch repos. I use KDE 4.10.1. Any hints?

Offline

#4 2013-03-22 04:42:36

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,419

Re: Not Resuming after suspend (revisited)

Moderator:  Split these new posts from an older thread about an ancient kernel.

Last edited by ewaller (2013-03-22 04:43:58)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#5 2013-03-23 06:54:05

haidut
Member
Registered: 2012-03-13
Posts: 16

Re: Not Resuming after suspend (revisited)

I had the same issue with a Lenovo W520 with an Nvidia card after updating in December. I will suspend and on resume the screen will be black but the machine will be responsive (virtual console is working, sound is there and so on). After a while I managed to isolate the root cause to be with the nouveau driver. Replacing it with Nvidia fixed it for me but downgrading to something from the summer should work too.

Offline

#6 2013-03-23 09:49:27

benob
Member
Registered: 2008-11-11
Posts: 187

Re: Not Resuming after suspend (revisited)

I have the same issue with a Toshiba z835 (intel graphics "2nd Generation Core Processor Family Integrated Graphics Controller" according to lshw). linux-3.8.3 and 3.8.4 are affected while 3.7.10 works fine.

--- edit ---
Related topics:
https://bbs.archlinux.org/viewtopic.php?id=159379 (Laptop screen can't recover from suspend)
https://bbs.archlinux.org/viewtopic.php?id=157579 (older issue but new posts are about 3.8)

Last edited by benob (2013-03-23 09:57:12)

Offline

#7 2013-03-23 18:14:15

ParadoxNL
Member
Registered: 2013-03-08
Posts: 5

Re: Not Resuming after suspend (revisited)

I have the same problem. But I can blindly type into the terminal. "pkill X" seems to work, but I also lose my session data. Does anyone know a command to reset/reload the screen?

Offline

Board footer

Powered by FluxBB