You are not logged in.

#1 2013-03-13 15:39:34

Hyugga
Member
From: Santiago, Chile
Registered: 2010-03-26
Posts: 329

KDE 4.10.1: plasma crashes randomly with notifications

Since KDE 4.10 i have this problem. The plasma desktop crashes randomly when some notification pops up. Then the desktop is "relaunched" automatically after one or two seconds.
Someone have this problem??

Thanks in advance.

Last edited by Hyugga (2013-03-22 21:12:13)

Online

#2 2013-03-19 17:30:16

mindcloud
Member
Registered: 2008-06-16
Posts: 5

Re: KDE 4.10.1: plasma crashes randomly with notifications

Yes, I have this problem and sometimes the desktop does not come back, not sure how to get it back short of Alt-F2 and logging out and back in.

Offline

#3 2013-03-19 17:44:24

Vipermaseg
Member
From: Spain
Registered: 2008-12-12
Posts: 62

Re: KDE 4.10.1: plasma crashes randomly with notifications

I know you probably have, but I still have to ask. Have you tried the good-old "rm -r ~/.kde4"?

EDIT1: Plus, it sounds like what it's crashing is the process plasma-desktop, so if it doesn't come back up, but you are still able to "Alt+F2", just type "plasma-desktop".

Last edited by Vipermaseg (2013-03-19 17:46:24)

Offline

#4 2013-03-20 13:41:23

Hyugga
Member
From: Santiago, Chile
Registered: 2010-03-26
Posts: 329

Re: KDE 4.10.1: plasma crashes randomly with notifications

Vipermaseg wrote:

I know you probably have, but I still have to ask. Have you tried the good-old "rm -r ~/.kde4"?

Mmm, i guess i'm going to try that once more again.
Thanks.

Online

#5 2013-03-22 18:03:19

Hyugga
Member
From: Santiago, Chile
Registered: 2010-03-26
Posts: 329

Re: KDE 4.10.1: plasma crashes randomly with notifications

So far so good...
Marking as solved...
Thanks!

EDIT: it happened again...

Last edited by Hyugga (2013-03-22 21:12:31)

Online

#6 2013-04-03 21:03:15

Hyugga
Member
From: Santiago, Chile
Registered: 2010-03-26
Posts: 329

Re: KDE 4.10.1: plasma crashes randomly with notifications

I used every possible phonon backend and different external players for notifications.
Additionally, i have sound notifications only using choqok , so maybe its a choqok problem.

Thanks!

Online

#7 2013-04-04 18:13:52

Hyugga
Member
From: Santiago, Chile
Registered: 2010-03-26
Posts: 329

Re: KDE 4.10.1: plasma crashes randomly with notifications

No luck with choqok...No problem detected in choqok debug.
Here's the output of the KDE error. It says that the generated information isn't useful:

Application: Shell de escritorio Plasma (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb5417980 (LWP 8326))]

Thread 3 (Thread 0xae0e7b40 (LWP 8327)):
#0  0xb7705424 in __kernel_vsyscall ()
#1  0xb6b966fb in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#2  0xb0c672fd in ?? () from /usr/lib/libQtScript.so.4
#3  0xb0c6732f in ?? () from /usr/lib/libQtScript.so.4
#4  0xb6b92cf0 in start_thread () from /usr/lib/libpthread.so.0
#5  0xb5f164ce in clone () from /usr/lib/libc.so.6

Thread 2 (Thread 0xa7bc4b40 (LWP 8328)):
#0  0xb7705424 in __kernel_vsyscall ()
#1  0xb5f0b92b in poll () from /usr/lib/libc.so.6
#2  0xb590e4db in g_poll () from /usr/lib/libglib-2.0.so.0
#3  0xb58ffab0 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0xb58ffc11 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb6d5391f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb6d2047c in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb6d20771 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0xb6c0b42c in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0xb6cfea8d in ?? () from /usr/lib/libQtCore.so.4
#10 0xb6c0e818 in ?? () from /usr/lib/libQtCore.so.4
#11 0xb6b92cf0 in start_thread () from /usr/lib/libpthread.so.0
#12 0xb5f164ce in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0xb5417980 (LWP 8326)):
[KCrash Handler]
#6  0xb6d3742c in QMetaObject::addGuard(QObject**) () from /usr/lib/libQtCore.so.4
#7  0xb0863545 in ?? () from /usr/lib/libQtDeclarative.so.4
#8  0xb09c1e32 in ?? () from /usr/lib/libQtDeclarative.so.4
#9  0xb6d39c76 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#10 0xb09c5eed in ?? () from /usr/lib/libQtDeclarative.so.4
#11 0xb087cba8 in ?? () from /usr/lib/libQtDeclarative.so.4
#12 0xb09c67c6 in ?? () from /usr/lib/libQtDeclarative.so.4
#13 0xb6d39c76 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#14 0xb09b5ecd in QListModelInterface::itemsRemoved(int, int) () from /usr/lib/libQtDeclarative.so.4
#15 0xb07dbb2f in QDeclarativeListModel::remove(int) () from /usr/lib/libQtDeclarative.so.4
#16 0xb09b4375 in ?? () from /usr/lib/libQtDeclarative.so.4
#17 0xb09b44c4 in QDeclarativeListModel::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libQtDeclarative.so.4
#18 0xb6d285f5 in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#19 0xb0957c6b in ?? () from /usr/lib/libQtDeclarative.so.4
#20 0xb09598c1 in ?? () from /usr/lib/libQtDeclarative.so.4
#21 0xbfbc6290 in ?? ()
#22 0x00000000 in ?? ()

Online

#8 2013-04-09 14:57:17

Hyugga
Member
From: Santiago, Chile
Registered: 2010-03-26
Posts: 329

Re: KDE 4.10.1: plasma crashes randomly with notifications

I can confirm the problem is sound related. I disabled the sound in the notification and the problem stopped.

Online

#9 2013-04-09 18:45:23

Hyugga
Member
From: Santiago, Chile
Registered: 2010-03-26
Posts: 329

Re: KDE 4.10.1: plasma crashes randomly with notifications

Hyugga wrote:

I can confirm the problem is sound related. I disabled the sound in the notification and the problem stopped.

It happened again... Not sound related either...

Online

#10 2013-04-10 22:29:34

sagottarius
Member
Registered: 2012-01-23
Posts: 6

Re: KDE 4.10.1: plasma crashes randomly with notifications

I had regular plasma crashes and kdialog crashes since kde 4.10.2
I have reinstalled kdelibs and everything is allright now.

Offline

Board footer

Powered by FluxBB