You are not logged in.

#1 2013-03-21 16:30:20

omeringen
Member
Registered: 2012-05-28
Posts: 109

[Solved] Monitorix 404 not found

Hi,
I installed monitorix from AUR. Changed "enabled = n" to "enabled = y" at /etc/monitorix.conf file

<httpd_builtin>
        enabled = y
        port = 8080
        user = nobody
        group = nobody
        log_file = /var/log/monitorix-httpd
</httpd_builtin>

http://localhost:8080/monitorix/ page works fine but after i click on "ok" button, it's returning a 404 page :

Not Found
The requested URL /monitorix/cgi-bin/monitorix.cgi was not found on this server.

Monitorix HTTP Server listening on 8080

Made a search, file destination is /srv/http/monitorix/cgi-bin/monitorix.cgi
Any suggestions ?

Regards. . .

Last edited by omeringen (2013-03-21 19:00:41)

Offline

#2 2013-03-21 16:52:58

graysky
Member
From: The worse toilet in Scotland
Registered: 2008-12-01
Posts: 8,818
Website

Re: [Solved] Monitorix 404 not found

Do you have the optdep installed?


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#3 2013-03-21 17:17:55

omeringen
Member
Registered: 2012-05-28
Posts: 109

Re: [Solved] Monitorix 404 not found

optdepends=('anything-sync-daemon: offload your databases to tmpfs to save i/o to your disk.'
  'hddtemp: enable support for hdd temp monitoring.'
  'lm_sensors: enable support for system temp monitoring.'
  'nvidia: enable support for nVidia card temp and usage monitoring.'
  'perl-http-server-simple: engine for built-in http server.'
  'smartmontools: enable support for hdd bad sector monitoring.'
  'terminus-font: if graphs do not contain characters, you may need this font package.')

I have hddtemp, lm_sensors and perl-http-server-simple installed. Are the rest of them necessary ?

Offline

#4 2013-03-21 17:35:32

graysky
Member
From: The worse toilet in Scotland
Registered: 2008-12-01
Posts: 8,818
Website

Re: [Solved] Monitorix 404 not found

No.  I run monitorix with lighttpd... I haven't tested it with the built-in server before.  I just wanted to know if you had that dep installed.  Sounds like you do.  Let me disable lighttpd, enable the internal and post back.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#5 2013-03-21 18:04:20

graysky
Member
From: The worse toilet in Scotland
Registered: 2008-12-01
Posts: 8,818
Website

Re: [Solved] Monitorix 404 not found

I get the same when using the internal server.  I email Jordi to see if this is something in his code or in my implementation via packaging.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#6 2013-03-21 18:10:56

omeringen
Member
Registered: 2012-05-28
Posts: 109

Re: [Solved] Monitorix 404 not found

Thanks for your interest. ; )

Offline

#7 2013-03-21 18:50:40

graysky
Member
From: The worse toilet in Scotland
Registered: 2008-12-01
Posts: 8,818
Website

Re: [Solved] Monitorix 404 not found

OK.  Tracked it down.  Jordi made a change in where the cgi dir is expected to be which I have now mapped back to the PKG.  Please try monitorix 3.1.0-6 which works for me.  Just remember to merge your monitorix.conf from the monitorix.conf.pacnew and it should work perfectly.

Thx for the bug report.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#8 2013-03-21 19:00:26

omeringen
Member
Registered: 2012-05-28
Posts: 109

Re: [Solved] Monitorix 404 not found

Works for me. Thanks for the fix.

Offline

Board footer

Powered by FluxBB