You are not logged in.

#26 2013-03-22 14:34:37

mediaserf
Member
Registered: 2010-11-29
Posts: 9

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

davehardy20 wrote:

Must be a bug with kernel 3.8.3-2 kernel.

This is a kernel bug, patches are on the way. Any workaround in the meantime should be temporary.

https://lkml.org/lkml/2013/1/18/147

This is a driver issue, not related to the device name issue mentioned in the thread. twouters: You're not invisible, just off-topic in this case. Cheers.

Offline

#27 2013-03-22 14:45:08

dext
Member
From: Poland, Kraków
Registered: 2008-02-01
Posts: 67

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

It's solved on 3.8.4-1.


English is not my first language, so please forgive me for my mistakes.

Offline

#28 2013-03-22 16:55:17

davehardy20
Member
Registered: 2012-08-12
Posts: 12

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

It's not fixed for me with 3.8.4-1, upgraded this morning and still had to enable the adaptor with;

echo on > /sys/class/net/enp0s25/device/power/control

Thanks mediaserf for the info.

I will await the fixed kernel version

Dave

Offline

#29 2013-03-25 09:14:52

dext
Member
From: Poland, Kraków
Registered: 2008-02-01
Posts: 67

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

You right. Now, it doesn't work after suspend. But:

echo on > /sys/class/net/eth0/device/power/control

helps.

Last edited by dext (2013-03-25 13:09:43)


English is not my first language, so please forgive me for my mistakes.

Offline

#30 2013-03-25 12:59:30

med1972
Member
From: Kingston, ON
Registered: 2009-02-19
Posts: 38

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

Same here, Dell E6320. I have to use "echo on" against my wired interface after every reboot or suspend-resume cycle. Wireless works fine.

$ uname -a
Linux lapcho0147 3.8.4-1-ARCH #1 SMP PREEMPT Wed Mar 20 22:10:25 CET 2013 x86_64 GNU/Linux
$ 

Offline

#31 2013-03-25 20:56:17

Mantichore
Member
Registered: 2012-11-04
Posts: 19

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

Same here with 3.8.4.1. Neither after a fresh reboot nor after suspend the NIC is working.

An "easier" workaround: https://bbs.archlinux.org/viewtopic.php … 7#p1246377

But after a suspend it still has to be done manually. Don't know why, but it's annoying. Looks like udev or perhaps laptop-mode-tools is the problem after a suspend.

Offline

#32 2013-03-25 22:27:30

progandy
Member
Registered: 2012-05-17
Posts: 2,151

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

Maybe this bug is patched in 3.9. The e1000e patches are applied in the master: https://git.kernel.org/cgit/linux/kerne … khlebnikov
Edit: You can test it with linux-mainline from AUR. (there is also a precompiled version avaible, repository in the comments)

Last edited by progandy (2013-03-25 22:39:13)

Offline

#33 2013-03-30 02:33:24

8472
Member
From: Slovakia
Registered: 2010-05-15
Posts: 47

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

Have just updated to 3.8.4-1 (I had 3.7.10-1 before), and have ran straightly into this issue too:

kernel: e1000e 0000:00:19.0: irq 45 for MSI/MSI-X
kernel: e1000e 0000:00:19.0: irq 45 for MSI/MSI-X
kernel: IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
kernel: e1000e 0000:00:19.0: irq 45 for MSI/MSI-X

LTS kernel fixed the problem in the meanwhile for me.
Will see whether I'll give a try to that "echo on" temp. fix.


Logic clearly dictates that the needs of the many outweigh the needs of the few.

Offline

#34 2013-03-30 09:25:03

andmars
Member
Registered: 2012-03-13
Posts: 158

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

8472 wrote:

Have just updated to 3.8.4-1 (I had 3.7.10-1 before), and have ran straightly into this issue too:

kernel: e1000e 0000:00:19.0: irq 45 for MSI/MSI-X
kernel: e1000e 0000:00:19.0: irq 45 for MSI/MSI-X
kernel: IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
kernel: e1000e 0000:00:19.0: irq 45 for MSI/MSI-X

LTS kernel fixed the problem in the meanwhile for me.
Will see whether I'll give a try to that "echo on" temp. fix.

and have you tried this? https://bbs.archlinux.org/viewtopic.php … 0#p1246200
(you're still using eth0)
https://bbs.archlinux.org/viewtopic.php?id=156283

Offline

#35 2013-03-31 07:53:32

8472
Member
From: Slovakia
Registered: 2010-05-15
Posts: 47

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

andmars wrote:
8472 wrote:

Have just updated to 3.8.4-1 (I had 3.7.10-1 before), and have ran straightly into this issue too:

kernel: e1000e 0000:00:19.0: irq 45 for MSI/MSI-X
kernel: e1000e 0000:00:19.0: irq 45 for MSI/MSI-X
kernel: IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
kernel: e1000e 0000:00:19.0: irq 45 for MSI/MSI-X

LTS kernel fixed the problem in the meanwhile for me.
Will see whether I'll give a try to that "echo on" temp. fix.

and have you tried this? https://bbs.archlinux.org/viewtopic.php … 0#p1246200
(you're still using eth0)
https://bbs.archlinux.org/viewtopic.php?id=156283

yes, I did, had no better effect.
after I logged to the shell, I've got this error: "eth0: error fetching interface information: Device not found"
adapting the netcfg profile to new network interface name enp0s25 also didn't helped.
but the "echo on" fix does work. so either this or the LTS kernel.


Logic clearly dictates that the needs of the many outweigh the needs of the few.

Offline

#36 2013-04-04 16:54:25

drdnl
Member
Registered: 2013-03-30
Posts: 15

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

Fixed for me in 3.8.5.1

Just did a fresh boot, checked whether "auto" was on and (un)plugged the cable a  couple times. Then did the same for suspend.

Offline

#37 2013-04-05 06:46:22

ball
Member
From: Germany
Registered: 2011-12-23
Posts: 164

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

drdnl wrote:

Fixed for me in 3.8.5.1

Not for me. It works sometimes but I just did a boot and network stayed off.

Offline

#38 2013-04-05 07:00:04

soul_rebel
Member
Registered: 2012-09-06
Posts: 24

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

Still affected on dell e6430 with kernel 3.8.5.

BTW: is anybody else bothered by this https://bugzilla.kernel.org/show_bug.cgi?id=47091 ?

It seems that this driver sucks for laptop users...

Offline

#39 2013-04-05 07:20:50

drdnl
Member
Registered: 2013-03-30
Posts: 15

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

ball wrote:
drdnl wrote:

Fixed for me in 3.8.5.1

Not for me. It works sometimes but I just did a boot and network stayed off.

Previous kernel didn't work at all, now it works occasionally?

Offline

#40 2013-04-05 12:23:15

ball
Member
From: Germany
Registered: 2011-12-23
Posts: 164

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

drdnl wrote:

Previous kernel didn't work at all, now it works occasionally?

Yes indeed: sometimes I have to do the workaround after booting, sometimes I don't.

Offline

#41 2013-04-05 12:30:34

drdnl
Member
Registered: 2013-03-30
Posts: 15

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

ball wrote:
drdnl wrote:

Previous kernel didn't work at all, now it works occasionally?

Yes indeed: sometimes I have to do the workaround after booting, sometimes I don't.

Oddly, didn't work for me this morning either. Intentionally booted without cable inserted, will have to narrow it down somehow.

Offline

#42 2013-04-05 13:49:00

chron
Member
Registered: 2010-10-18
Posts: 4

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

Still the same problem. Thinkpad x201 with 3.8.5-1.

The workaround works but its a little annoying to do it after every suspend/reboot.

Offline

#43 2013-04-06 23:04:41

olivine
Member
Registered: 2009-10-24
Posts: 15

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

Same problem here with 3.8.5-1 on a Dell Latitude E4300.

Offline

#44 2013-04-08 08:23:48

drdnl
Member
Registered: 2013-03-30
Posts: 15

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

Weirdly, it works fine at home (direct cable to router) but not at work (no idea how or where it goes to)

Offline

#45 2013-04-15 07:58:28

ft
Member
Registered: 2013-04-15
Posts: 1

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

Hi,

Please consider :
https://bugs.launchpad.net/ubuntu/+sour … ug/1112652

The issue is solved in 3.9rc3 with :
https://bugs.launchpad.net/ubuntu/+sour … omments/24

We need this backport in 3.8 kernel...

++

Offline

#46 2013-04-17 18:54:26

niklas974
Member
Registered: 2013-04-17
Posts: 1

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

Hi there

What do I do if this happens:

sudo echo on > /sys/bus/pci/devices/0000\:00\:19.0/power/control
bash: /sys/bus/pci/devices/0000:00:19.0/power/control: Permission denied
ls -al /sys/bus/pci/devices/0000\:00\:19.0/power
total 0
drwxr-xr-x 2 root root    0 17. Apr 20:30 .
drwxr-xr-x 5 root root    0 17. Apr 20:29 ..
-rw-r--r-- 1 root root 4096 17. Apr 20:30 async
-rw-r--r-- 1 root root 4096 17. Apr 20:30 autosuspend_delay_ms
-rw-r--r-- 1 root root 4096 17. Apr 20:32 control
-r--r--r-- 1 root root 4096 17. Apr 20:30 runtime_active_kids
-r--r--r-- 1 root root 4096 17. Apr 20:30 runtime_active_time
-r--r--r-- 1 root root 4096 17. Apr 20:30 runtime_enabled
-r--r--r-- 1 root root 4096 17. Apr 20:30 runtime_status
-r--r--r-- 1 root root 4096 17. Apr 20:30 runtime_suspended_time
-r--r--r-- 1 root root 4096 17. Apr 20:30 runtime_usage
-rw-r--r-- 1 root root 4096 17. Apr 20:30 wakeup
-r--r--r-- 1 root root 4096 17. Apr 20:30 wakeup_abort_count
-r--r--r-- 1 root root 4096 17. Apr 20:30 wakeup_active
-r--r--r-- 1 root root 4096 17. Apr 20:30 wakeup_active_count
-r--r--r-- 1 root root 4096 17. Apr 20:30 wakeup_count
-r--r--r-- 1 root root 4096 17. Apr 20:30 wakeup_expire_count
-r--r--r-- 1 root root 4096 17. Apr 20:30 wakeup_last_time_ms
-r--r--r-- 1 root root 4096 17. Apr 20:30 wakeup_max_time_ms
-r--r--r-- 1 root root 4096 17. Apr 20:30 wakeup_prevent_sleep_time_ms
-r--r--r-- 1 root root 4096 17. Apr 20:30 wakeup_total_time_ms
 uname -a
Linux chaos 3.8.7-1-ARCH #1 SMP PREEMPT Sat Apr 13 09:01:47 CEST 2013 x86_64 GNU/Linux

On a Thinkpad T430

Thanks for any help, might as well just me being dumb…

Offline

#47 2013-04-17 19:51:57

ball
Member
From: Germany
Registered: 2011-12-23
Posts: 164

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

@niklas974: Become root with

$ sudo -i

and try again.

Offline

#48 2013-04-18 08:21:13

drdnl
Member
Registered: 2013-03-30
Posts: 15

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

Here's the script I've been using, asks for sudo if required

#!/bin/bash

if [ $EUID != 0 ]; then
    sudo "$0" "$@"
    sudo tee "/sys/bus/pci/devices/0000:00:19.0/power/control" <<< on
    exit $?
fi

Offline

#49 2013-05-13 07:57:58

8472
Member
From: Slovakia
Registered: 2010-05-15
Posts: 47

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

finally, the yesterday released (arch core repo) kernel 3.9.2-1 fixed the problem, and the temp. fix "echo on > /sys/class/net/eth0/device/power/control" ain't required anymore.


Logic clearly dictates that the needs of the many outweigh the needs of the few.

Offline

#50 2013-10-23 13:20:51

techhat
Member
Registered: 2011-11-30
Posts: 5

Re: Ethernet (eth0) broken after upgrade to kernel 3.8.3-2

It's baaack...

http://pastebin.com/amrdZGqg

This is immediately following a kernel update this weekend.

Offline

Board footer

Powered by FluxBB