You are not logged in.

#1 2013-03-18 23:59:13

rob356
Member
Registered: 2010-12-31
Posts: 8

xorg 1.14 breaks virtualbox

I just installed arch into virtualbox, installed xorg and virtualbox-guest-utils, and xorg would not start. The error said vboxvideo was compiled for ABI 13, and the current version was 14. I tried doing a manual install, but apparently their installer does not support systemd. Has anyone found a way to fix this?

Offline

#2 2013-03-19 04:25:51

MagicSkyFairy
Member
Registered: 2013-03-14
Posts: 79

Re: xorg 1.14 breaks virtualbox

I don't really have any good suggestions but have you tried googling the error message?

Use quotation marks, and take out anything in the message that might be different from computer to computer.

Other than that maybe check out this part of the wiki https://wiki.archlinux.org/index.php/Vi … on_on_host

Install virtualbox-guest-utils, load vboxguest vboxsf vboxvideo modules, create a file in /etc/modprobe.d with the lines stated in the wiki, and maybe try downloading the vboxguest-hook to automatically recompile after an update.

I'm sorry if this is no help to you.  I hope it atleast leads you in the right direction to figure it out on your own.


I have wasted atleast a second of your time by making you read my signature.

Offline

#3 2013-03-19 04:31:13

rob356
Member
Registered: 2010-12-31
Posts: 8

Re: xorg 1.14 breaks virtualbox

Yes I did all that. I got it to work, but only by forcing X to load the module and ignore ABI mis-matches. It seems I just got unlucky with my install timing, 1.14 just got pushed today and virtualbox has not updated. There are some issues like some text has a weird shadow behind it and when logging in for the first time the screen is just garbage, but adjusting the window size fixes it. Hopefully virtualbox updates soon.

For anyone else with this problem I created the file /etc/X11/xorg.conf.d/05-ignoreabi.conf with the contents:

Section "ServerFlags"
        Option "IgnoreABI" "1"
EndSection

Offline

#4 2013-03-19 04:35:23

MagicSkyFairy
Member
Registered: 2013-03-14
Posts: 79

Re: xorg 1.14 breaks virtualbox

Sweet.  Thanks for following up.  Nothing is more frustrating to a person with the same problem than a thread with no follow up!


I have wasted atleast a second of your time by making you read my signature.

Offline

#5 2013-03-19 04:40:04

ryenus
Member
Registered: 2013-03-19
Posts: 1

Re: xorg 1.14 breaks virtualbox

kudos to @rob356, IgnoreABI did the trick. thanks!

Last edited by ryenus (2013-03-19 04:55:53)

Offline

#6 2013-03-19 04:46:05

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,977

Re: xorg 1.14 breaks virtualbox

downgrade xorg, not the kernel.

Offline

#7 2013-03-22 13:39:20

Zygote
Member
Registered: 2013-01-15
Posts: 75

Re: xorg 1.14 breaks virtualbox

Vmware isnt too happy with xorg 1.14 either, and refuses to load x unfortunately.

Offline

#8 2013-03-22 16:08:38

Spremuta
Member
From: Rome - IT
Registered: 2010-03-04
Posts: 6

Re: xorg 1.14 breaks virtualbox

Hello, I have reinstalled a new vbox machine some days ago and now I installed xorg and gnome but cannot manage to start succesfully gnome, I have installed xorg 1.14 and virtualbox  4.2.10-2 (and latest kernel of course)

Can anybody post xorg config files of their own virtualbox arch machine?


Archlinux returns

Offline

#9 2013-03-22 16:57:39

aganders3
Member
Registered: 2010-04-06
Posts: 8

Re: xorg 1.14 breaks virtualbox

Zygote wrote:

Vmware isnt too happy with xorg 1.14 either, and refuses to load x unfortunately.

I had the same experience. Downgrading xorg-server to 1.13 got things working again (still using "startx -- -extension GLX" to get around that freeze).

Offline

#10 2013-03-22 17:21:51

MagicSkyFairy
Member
Registered: 2013-03-14
Posts: 79

Re: xorg 1.14 breaks virtualbox

--disregard this--

Last edited by MagicSkyFairy (2013-03-22 17:25:27)


I have wasted atleast a second of your time by making you read my signature.

Offline

#11 2013-03-22 17:22:28

Antoine
Member
From: Picton Ontario
Registered: 2012-10-11
Posts: 90

Re: xorg 1.14 breaks virtualbox

In case it's of any use to anyone, I get:

(WW) NVIDIA: This server has an unsupported input driver ABI version (have 19.1, need < 19.0).  The driver will continue to load, but may behave strangely.

X works fine; no "strange behaviour" that I can make out. At least, not with XBMC.

Linux x86_64 GNU/Linux; Xorg-server 1.14.0-2; NVidia ION; nvidia 313.26-2

Offline

#12 2013-03-23 08:26:19

Spremuta
Member
From: Rome - IT
Registered: 2010-03-04
Posts: 6

Re: xorg 1.14 breaks virtualbox

rob356 wrote:

Yes I did all that. I got it to work, but only by forcing X to load the module and ignore ABI mis-matches. It seems I just got unlucky with my install timing, 1.14 just got pushed today and virtualbox has not updated. There are some issues like some text has a weird shadow behind it and when logging in for the first time the screen is just garbage, but adjusting the window size fixes it. Hopefully virtualbox updates soon.

For anyone else with this problem I created the file /etc/X11/xorg.conf.d/05-ignoreabi.conf with the contents:

Section "ServerFlags"
        Option "IgnoreABI" "1"
EndSection

Can you post other conf files? I put the ignoreABI but doesn't start again..


Archlinux returns

Offline

#13 2013-03-26 16:56:47

Spremuta
Member
From: Rome - IT
Registered: 2010-03-04
Posts: 6

Re: xorg 1.14 breaks virtualbox

Spremuta wrote:
rob356 wrote:

Yes I did all that. I got it to work, but only by forcing X to load the module and ignore ABI mis-matches. It seems I just got unlucky with my install timing, 1.14 just got pushed today and virtualbox has not updated. There are some issues like some text has a weird shadow behind it and when logging in for the first time the screen is just garbage, but adjusting the window size fixes it. Hopefully virtualbox updates soon.

For anyone else with this problem I created the file /etc/X11/xorg.conf.d/05-ignoreabi.conf with the contents:

Section "ServerFlags"
        Option "IgnoreABI" "1"
EndSection

Can you post other conf files? I put the ignoreABI but doesn't start again..



bump


Archlinux returns

Offline

#14 2013-03-26 17:13:10

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: xorg 1.14 breaks virtualbox

Spremuta wrote:

bump

it should work with the latest packages from our repos. did you actually tested it?


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#15 2013-03-27 10:26:50

Spremuta
Member
From: Rome - IT
Registered: 2010-03-04
Posts: 6

Re: xorg 1.14 breaks virtualbox

wonder wrote:
Spremuta wrote:

bump

it should work with the latest packages from our repos. did you actually tested it?

I did pacman -Syyu but xorg is the same


Archlinux returns

Offline

#16 2013-04-03 10:51:57

Spremuta
Member
From: Rome - IT
Registered: 2010-03-04
Posts: 6

Re: xorg 1.14 breaks virtualbox

Spremuta wrote:
wonder wrote:
Spremuta wrote:

bump

it should work with the latest packages from our repos. did you actually tested it?

I did pacman -Syyu but xorg is the same


Reinstalling latest Arch version solved my issue


Archlinux returns

Offline

Board footer

Powered by FluxBB