You are not logged in.

#1 2013-02-24 17:29:28

kellerman
Member
From: Latvia
Registered: 2011-07-20
Posts: 101

[SOLVED]VLC DVB-T EPG timezone

Hi. I've been wondering for a while how to fix this issue. If I'm guessing right, the timezone for VLC program guide appears to be GMT instead of GMT+2 . Just like in this screenshot:
epg.png
The red line which represents current time is correct (approx. 19:25)
For example the right time for "Karību jūras pirāti: Pasaules malā" should be 20:00-23:25 instead of 18:00-21:25.
System time is correct, and no I've had no other timezone issues in any other application.
Thanks!

Last edited by kellerman (2013-03-24 20:16:04)

Offline

#2 2013-02-26 14:35:44

kellerman
Member
From: Latvia
Registered: 2011-07-20
Posts: 101

Re: [SOLVED]VLC DVB-T EPG timezone

I would really appreciate any help or comments!

Offline

#3 2013-02-26 22:43:31

crondog
Member
Registered: 2011-04-21
Posts: 125

Re: [SOLVED]VLC DVB-T EPG timezone

I don't have my tv tuner handy so I can't reproduce the issue.

The only thing I could suggest at the moment would be to try watching tv with tvheadend or checking the epg with atsc_epg (in linuxtv-dvb-apps) and see if the times are correct or not on that.

Offline

#4 2013-03-24 15:14:20

kellerman
Member
From: Latvia
Registered: 2011-07-20
Posts: 101

Re: [SOLVED]VLC DVB-T EPG timezone

I haven't configured any clock settings when I did set up arch, I did only set the correct time. me-tv has the same issue. I guess I use hardware clock instead of system clock and this has something to do with it.
I'm in GMT +2

EDIT:
I set the timezone to GMT+2 with

timedatectl set-timezone Europe/Riga  

and set the time back for 2 hours in my case and now VLC and me-tv shows correct EPG data smile
Only now I'll have to figure out how to get the clock right when I boot into Windows! big_smile

EDIT:
aaand I fixed that by setting UTC to both operating systems.

Last edited by kellerman (2013-03-24 21:31:18)

Offline

Board footer

Powered by FluxBB