You are not logged in.

#1 2013-01-20 05:28:55

hifitim
Member
Registered: 2013-01-20
Posts: 2

No Sound with Xonar DX

Hi All,
I have a brand new installation of Arch and everything works well except my sound card, an Asus Xonar DX. I've disabled the onboard Intel audio on my motherboard in the BIOS, so that

aplay -l

looks like this:

**** List of PLAYBACK Hardware Devices ****
card 0: DX [Xonar DX], device 0: Multichannel [Multichannel]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: DX [Xonar DX], device 1: Digital [Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

It's also seen just fine in alsamixer and, with all of the channels unmuted, I have no sound from either the front panel or the rear jacks. It works fine on Windows 7 (this PC is dual booted), so the hardware is fine. If I try

 speaker-test -c 2

like wiki suggests, it seems to hang on the front left channel test:

speaker-test 1.0.26

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 16384
Period size range from 1024 to 1024
Using max buffer size 16384
Periods = 4
was set period_size = 1024
was set buffer_size = 16384
 0 - Front Left

If I give it the front panel (aplay -Dfront:DX -c 2) that I get from

 aplay -L 

with 2 channels

null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
default
    Default ALSA Output (currently PulseAudio Sound Server)
sysdefault:CARD=DX
    Xonar DX, Multichannel
    Default Audio Device
front:CARD=DX,DEV=0
    Xonar DX, Multichannel
    Front speakers
surround40:CARD=DX,DEV=0
    Xonar DX, Multichannel
    4.0 Surround output to Front and Rear speakers
surround41:CARD=DX,DEV=0
    Xonar DX, Multichannel
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=DX,DEV=0
    Xonar DX, Multichannel
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=DX,DEV=0
    Xonar DX, Multichannel
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=DX,DEV=0
    Xonar DX, Multichannel
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=DX,DEV=0
    Xonar DX, Multichannel
    IEC958 (S/PDIF) Digital Audio Output

the speaker-test will run, but I still get no sound. If I give it another set of channels, like 5.1:

[tim@arch1 ~]$ speaker-test -Dsurround51:DX -c6

speaker-test 1.0.26

Playback device is surround51:DX
Stream parameters are 48000Hz, S16_LE, 6 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 8 to 87376
Period size range from 8 to 87376
Using max buffer size 87376
Periods = 4
was set period_size = 17480
was set buffer_size = 87376
 0 - Front Left
Write error: -5,Input/output error
xrun_recovery failed: -5,Input/output error
Transfer failed: Operation not permitted

I get that error. Lastly, when I mute/unmute the 'front panel' slider in alsamixer (which has no real slider, actually - it's just 00 or mm), I can hear a relay clicking on or off like it's doing something.

Any thoughts?

Thanks,
Tim

Last edited by hifitim (2013-01-20 05:34:18)

Offline

#2 2013-01-20 11:56:31

Xeitgeist
Member
Registered: 2012-03-14
Posts: 17

Re: No Sound with Xonar DX

hifitim wrote:

Lastly, when I mute/unmute the 'front panel' slider in alsamixer (which has no real slider, actually - it's just 00 or mm), I can hear a relay clicking on or off like it's doing something.

I'm running a DX on Arch too (dual-boot setup), and I can guarantee that the "click" noise happens regardless of OS. I don't know what's causing your issue, but at least it's not that. Sorry, I couldn't be of much help.

EDIT: It just occurred to me. Have you added yourself to the audio group? DEs take care of permissions seamlessly but perhaps you're not running a DE on your machine.

Last edited by Xeitgeist (2013-01-20 11:58:55)

Offline

#3 2013-01-20 14:56:54

hifitim
Member
Registered: 2013-01-20
Posts: 2

Re: No Sound with Xonar DX

Xeitgeist wrote:
hifitim wrote:

Lastly, when I mute/unmute the 'front panel' slider in alsamixer (which has no real slider, actually - it's just 00 or mm), I can hear a relay clicking on or off like it's doing something.

I'm running a DX on Arch too (dual-boot setup), and I can guarantee that the "click" noise happens regardless of OS. I don't know what's causing your issue, but at least it's not that. Sorry, I couldn't be of much help.

EDIT: It just occurred to me. Have you added yourself to the audio group? DEs take care of permissions seamlessly but perhaps you're not running a DE on your machine.

I think I'm part of audio, though I am using Mate - which I suppose is a DE.

[tim@arch1 ~]$ groups
wheel audio users

Offline

#4 2013-01-22 19:13:01

phekdra
Member
From: Devon, UK
Registered: 2011-12-17
Posts: 12

Re: No Sound with Xonar DX

I'm also having a problem with my Xonar. It's only just started happening and the only things I've done recently are upgrade the kernel (routine via pacman), and finally completing the switch to systemd by removing the daemons from rc.conf and adding them properly via systemctl and then removing initscripts.

The sound card is still shown in audio mixers and so on, and it's unmuted, but nothing seems to come out of it. It might be a related problem.

Offline

#5 2013-01-22 20:12:00

phekdra
Member
From: Devon, UK
Registered: 2011-12-17
Posts: 12

Re: No Sound with Xonar DX

Well, I don't know if you're using fluidsynth or timidity as daemons/services - searching around it appears this can cause problems. I removed fluidsynth, which I had as a service, and surprisingly enough sound works fine. I didn't even need to reboot. neutral

Offline

#6 2013-03-03 18:56:25

chetwisniewski
Member
Registered: 2012-03-04
Posts: 26

Re: No Sound with Xonar DX

I am having issues as well. I run testing and it started somewhere around kernel 3.6. Pulseaudio only shows IEC958 digital output no matter how I try to configure it. Had to fallback to crappy integrated Intel. I don't really have any idea how to go about troubleshooting this.

Ideas?

Offline

#7 2013-03-03 19:57:44

chetwisniewski
Member
Registered: 2012-03-04
Posts: 26

Re: No Sound with Xonar DX

Was able to resolve my problems by using pavucontrol and messing with the configuration options. The gnome volume widget for Pulseaudio is a bit messed up, but pavucontrol works well.

Offline

#8 2013-03-04 02:38:21

straykat
Member
From: Queensland, Australia
Registered: 2009-12-06
Posts: 60

Re: No Sound with Xonar DX

Some time ago I had what appears to be a similar issue with my Asus D1 which left me with no sound after a kernel upgrade.

After much fault finding & gnashing of teeth of teeth, found that ALSA in the new kernel included an updated driver which added channels. With the previous kernel/ALSA I had simply unmuted all channels, however in the new kernel/ALSA having all channels unmuted caused conflicts which resulted in no sound.

The channels that caused the conflicts were the ones with only mm (muted) or 00 (unmuted) available, ie; no adjustable bars in alsamixer.

Only unmuting (00) S/PDIF worked for me as I use S/PDIF output.

Hope this helps.

Offline

#9 2013-03-24 18:14:08

rumpelsepp
Member
From: Bavaria
Registered: 2012-11-13
Posts: 105
Website

Re: No Sound with Xonar DX

straykat wrote:

Some time ago I had what appears to be a similar issue with my Asus D1 which left me with no sound after a kernel upgrade.

After much fault finding & gnashing of teeth of teeth, found that ALSA in the new kernel included an updated driver which added channels. With the previous kernel/ALSA I had simply unmuted all channels, however in the new kernel/ALSA having all channels unmuted caused conflicts which resulted in no sound.

The channels that caused the conflicts were the ones with only mm (muted) or 00 (unmuted) available, ie; no adjustable bars in alsamixer.

Only unmuting (00) S/PDIF worked for me as I use S/PDIF output.

Hope this helps.

Thanks a lot man!

https://bbs.archlinux.org/viewtopic.php … 7#p1246667


Every time I see some piece of medical research saying that caffeine is good for you, I high-five myself. Because I'm going to live forever. -- Torvalds, Linus (2010-08-03).

Offline

Board footer

Powered by FluxBB