You are not logged in.

#1 2013-03-20 11:04:20

rumpelsepp
Member
From: Bavaria
Registered: 2012-11-13
Posts: 104
Website

[solved] Xonar D1 problem with front speaker

Hi,

I have a very strange problem with my Xonar D1 Soundcard. Usally I use the 5.1 analog output profile and it worked very well. Today I realized that my front speaker pair doesn't play any single tone. I tried to figure out what's going on but I didn't find anything.

Center, Subwoofer and Rearpair work fine. Front Pair is silent.

I tried:
* Downgrade Kernel to 3.7.10
* LTS Kernel
* Downgrade Pulse Audio
* Look into Alsa Mixer, nothing is muted
* started Windows -> it works

google says: http://ubuntuforums.org/showthread.php?t=2116198

Please help!
Stefan

http://paste.ubuntuusers.de/414047/

stefan@st1 ~ $ pacman -Q |  grep linux 
archlinux-keyring 20130224-1
linux 3.8.3-2
linux-api-headers 3.7.4-1
linux-firmware 20121118-1
linux-headers 3.8.3-2

stefan@st1 ~ $ pacman -Q | grep alsa   
alsa-lib 1.0.26-1
alsa-plugins 1.0.26-1
alsa-utils 1.0.26-1
pulseaudio-alsa 2-2

stefan@st1 ~ $ pacman -Q | grep pulseaudio
pulseaudio 3.0-2
pulseaudio-alsa 2-2

stefan@st1 ~ $ cat /etc/pulse/daemon.conf
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.

## Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for
## more information. Default values are commented out.  Use either ; or # for
## commenting.

; daemonize = no
; fail = yes
; allow-module-loading = yes
; allow-exit = yes
; use-pid-file = yes
; system-instance = no
; local-server-type = user
; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
; lock-memory = no
; cpu-limit = no

; high-priority = yes
; nice-level = -11

; realtime-scheduling = yes
; realtime-priority = 5

; exit-idle-time = 20
; scache-idle-time = 20

; dl-search-path = (depends on architecture)

; load-default-script-file = yes
; default-script-file = /etc/pulse/default.pa

; log-target = auto
; log-level = notice
; log-meta = no
; log-time = no
; log-backtrace = 0

resample-method=speex-float-0
; resample-method = speex-float-3
enable-remixing = yes
enable-lfe-remixing = yes

; flat-volumes = yes

; rlimit-fsize = -1
; rlimit-data = -1
; rlimit-stack = -1
; rlimit-core = -1
; rlimit-as = -1
; rlimit-rss = -1
; rlimit-nproc = -1
; rlimit-nofile = 256
; rlimit-memlock = -1
; rlimit-locks = -1
; rlimit-sigpending = -1
; rlimit-msgqueue = -1
; rlimit-nice = 31
; rlimit-rtprio = 9
; rlimit-rttime = 1000000

; default-sample-format = s16le
; default-sample-rate = 44100
; alternate-sample-rate = 48000
; default-sample-channels = 6
; default-channel-map = front-left,front-right

; default-fragments = 4
; default-fragment-size-msec = 25

; enable-deferred-volume = yes
; deferred-volume-safety-margin-usec = 8000
; deferred-volume-extra-delay-usec = 0

Last edited by rumpelsepp (2013-03-24 18:15:42)


Every time I see some piece of medical research saying that caffeine is good for you, I high-five myself. Because I'm going to live forever. -- Torvalds, Linus (2010-08-03).

Offline

#2 2013-03-20 15:54:12

rumpelsepp
Member
From: Bavaria
Registered: 2012-11-13
Posts: 104
Website

Re: [solved] Xonar D1 problem with front speaker

I played around with OSS -> They work, definitly an ALSA problem... sad


Every time I see some piece of medical research saying that caffeine is good for you, I high-five myself. Because I'm going to live forever. -- Torvalds, Linus (2010-08-03).

Offline

#3 2013-03-20 20:44:13

rumpelsepp
Member
From: Bavaria
Registered: 2012-11-13
Posts: 104
Website

Re: [solved] Xonar D1 problem with front speaker

Just tried Ubuntu 12.04 live CD, it also works. Perhaps a config problem? ...


Every time I see some piece of medical research saying that caffeine is good for you, I high-five myself. Because I'm going to live forever. -- Torvalds, Linus (2010-08-03).

Offline

#4 2013-03-24 18:15:25

rumpelsepp
Member
From: Bavaria
Registered: 2012-11-13
Posts: 104
Website

Re: [solved] Xonar D1 problem with front speaker

Just found the problem:
https://bbs.archlinux.org/viewtopic.php … 7#p1239587

Mute S/PDIF in alsamixer.


Every time I see some piece of medical research saying that caffeine is good for you, I high-five myself. Because I'm going to live forever. -- Torvalds, Linus (2010-08-03).

Offline

Board footer

Powered by FluxBB