You are not logged in.

#26 2013-03-26 03:42:12

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 921

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

tpowa wrote:
Jristz wrote:

but I receive the bug only whit the only precence of a LVM on a partition (not mount not activated only existing), maybe I have (only 1 usb mounted) 1 hd and 2 usb.

How did you manage to not have an activated lvm after boot? Normally archboot enables lvm devices during bootup.

/arch/setup
then go to the filesystem part
then go to any part that scan the filesystems searching for RAID,LVM and these stuff
the these stop in scaning RAID devices and never continue

Q: you use any of the localectl list-locales,list-keymaps or timedatectl list-timezones command??


Well, I suppose that this is somekind of signature, no?

Offline

#27 2013-03-26 06:24:54

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

Jristz wrote:

/arch/setup
then go to the filesystem part
then go to any part that scan the filesystems searching for RAID,LVM and these stuff
the these stop in scaning RAID devices and never continue

And how did you create your LVM device, is it on USB or internal device?
Is it already available when you boot the ISO or do you plug in the usb afterwards?
Do you have an encrypted lvm or a mdam raid on it?
Does /dev/mapper/yourdevice already exist before you enter setup?
I need a way to understand how your system works.

Offline

#28 2013-03-26 08:11:01

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 716

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

Jristz wrote:
tpowa wrote:
Jristz wrote:

but I receive the bug only whit the only precence of a LVM on a partition (not mount not activated only existing), maybe I have (only 1 usb mounted) 1 hd and 2 usb.

How did you manage to not have an activated lvm after boot? Normally archboot enables lvm devices during bootup.

/arch/setup
then go to the filesystem part
then go to any part that scan the filesystems searching for RAID,LVM and these stuff
the these stop in scaning RAID devices and never continue

Q: you use any of the localectl list-locales,list-keymaps or timedatectl list-timezones command??

I didn't realise /arch/setup was still available?  Am I out of date or has something changed with pacstrap?


Mike C

Online

#29 2013-03-26 08:18:39

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

mcloaked wrote:

I didn't realise /arch/setup was still available?  Am I out of date or has something changed with pacstrap?

Please read the main archboot page what it is about. pacstrap is also avaiable on the image but the main installer on archboot is the setup script.

Offline

#30 2013-03-27 21:59:06

zenlord
Member
From: Belgium
Registered: 2006-05-24
Posts: 1,209
Website

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

Hi, reinstalling my macbook pro 5,5 with nvidia 9400M GPU on a brand new SSD.

I have followed the instructions to boot archboot from EFI and I can boot both the main kernel directly (presumably EFISTUB) and via rEFInd. Both kernels boot, but halt at the stage loading the nouveaufb. This is the error: https://bugs.freedesktop.org/show_bug.cgi?id=34508

I have tried editing the kernel options, adding
- maxcpus=1
- modeset=0
- uvesafb=800x600-16
, but none of them helped.

Booting the LTS kernel on the image doesn't seem to work.

I also tried booting archboot without the 'EFI-patches', but the macbook didn't find anything to boot from.

Does anyone have a solution at hand? Should I rebuild the archboot image with the nvidia-module (how?) or is there an easier solution?

Thx!

Last edited by zenlord (2013-03-27 21:59:40)

Offline

#31 2013-03-28 21:55:34

zenlord
Member
From: Belgium
Registered: 2006-05-24
Posts: 1,209
Website

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

For the record: booting the official Archlinux 2013.03.01 halts after 'triggering uevents' (which is laready at the <4s-point. At least Archboot kept it going for >20s...

Offline

#32 2013-04-22 17:48:25

KairiTech
Member
From: Toronto, Canada
Registered: 2011-06-04
Posts: 231

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

If I were to install and configure packages in addition to archboot into the chroot would archboot-allinone.sh include those additional packages in the new Allinone ISO images?


-=[ LIVE enabled UEFI with redundant syslinux pure systemd detached LUKS header partitionless encrypted GPT SSDx3 RAID0 because I can.  ]=-

Backward compatibility is for the masses. There's no dual-boot here...

Offline

#33 2013-04-22 18:18:43

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

No you need to write hooks for including additional things.

Offline

#34 2013-04-22 18:32:52

KairiTech
Member
From: Toronto, Canada
Registered: 2011-06-04
Posts: 231

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

tpowa wrote:

No you need to write hooks for including additional things.

In that case do you have a HowTo for creating the Archboot images? I'd like to create a fully configured desktop that runs entirely in RAM like Archboot.


-=[ LIVE enabled UEFI with redundant syslinux pure systemd detached LUKS header partitionless encrypted GPT SSDx3 RAID0 because I can.  ]=-

Backward compatibility is for the masses. There's no dual-boot here...

Offline

#35 2013-04-23 06:50:26

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

There is no HowTo about that case, you need to write mkinitcpio hooks for this case and add this to the config files.
But I can tell you it will be a lot of RAM you need.
Simplest hook would be add_full_dir "/"

Offline

#36 2013-04-25 13:37:42

KairiTech
Member
From: Toronto, Canada
Registered: 2011-06-04
Posts: 231

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

tpowa wrote:

But I can tell you it will be a lot of RAM you need.

I have lots of RAM available and according to my conky it's almost always 85% unused and I don't even bother to set up swap anymore. With the amount of RAM available in modern computers it wouldn't surprise me at all if becomes de rigueur in the not too distant future to run Linux from RAM with the SSD/HDD being only used for storing the compressed OS and data .

Last edited by KairiTech (2013-04-25 13:54:24)


-=[ LIVE enabled UEFI with redundant syslinux pure systemd detached LUKS header partitionless encrypted GPT SSDx3 RAID0 because I can.  ]=-

Backward compatibility is for the masses. There's no dual-boot here...

Offline

#37 2013-06-09 16:37:00

mianka
Member
From: BE LEUVEN
Registered: 2006-05-30
Posts: 208

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

I am trying to install arch with archboot on an ACER V5-171 laptop and on an ACER XC600-G1610 set in legacy bios mode. Both computers start the CD and the USB-stick:
I see /boot/vmlinuz and /boot/initramfs and then the screen turns black with a white cursor and stays there.
I've played with modeset params and some others but to no avail.
Standard arch and other distro's work without problems and I can install these.(stick and cd)
Any idea where I can start searching to solve the problem?

Offline

#38 2013-06-10 08:11:21

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

Offline

#39 2013-06-10 12:22:57

mianka
Member
From: BE LEUVEN
Registered: 2006-05-30
Posts: 208

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

To tpowa, yes I did read about and apply the workaround for the screen issues, as I mentioned in my mail.I also searched in the forum but no solution was found for this problem.
It seems to be Acer-specific or more precisely the combination with Archboot.
Testwise I installed Fedora18 (I'm now writing on this computer) and it works. The USB-sticks and cd's I made work as a doddle on other computers so they are not to question either. Standard arch also works perfectly, both stick and cd.

Offline

#40 2013-06-19 15:17:53

Omar TS
Member
Registered: 2012-03-31
Posts: 8

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

why the Archboot iso's not updated yet

Offline

#41 2013-06-19 15:45:04

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

Omar TS wrote:

why the Archboot iso's not updated yet

Waiting for kernel 3.10 to be released, thats why.

Offline

#42 2013-06-19 20:08:53

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

We are workin on lot of new stuff, like secure boot support etc. at the moment. Next release is a real big thing.

Offline

#43 2013-06-22 17:30:20

cookiecaper
Member
Registered: 2007-09-22
Posts: 196

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

Hey guys, I'm having something similar to the issue described here today with 2013.03-4. https://bbs.archlinux.org/viewtopic.php … 8#p1017038

I'm trying to install from a USB stick and get the message asking me to manually mount the source on /src.  When I do so, archboot still fails to find the squashfs files although they are clearly in the expected spot (/src/packages/archboot_packages_any.squashfs + /src/packages/archboot_packages_$(uname -m).squashfs) and can be probed from the shell (ls, file, etc.)

Wondering if anyone had a quick fix for this. I've fiddled a bit with the /arch/setup script but not very much. Hoping there's an easy fix already known.

Last edited by cookiecaper (2013-06-22 17:31:05)

Offline

#44 2013-07-11 13:59:48

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

If you want to help us to find bugs in current archboot code, please try the beta ftp images, thx for helping.
https://bbs.archlinux.org/viewtopic.php?id=166552

Offline

#45 2013-08-23 20:14:53

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,024
Website

Re: 2013.03-4 archboot "2k13-R1" ISO hybrid images released

Closing


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB