You are not logged in.

#1 2013-03-10 18:51:46

toringe
Member
Registered: 2011-09-05
Posts: 49

[PROBABLY SOLVED] Chromium freezes in DWM

Chromium freezes when using DWM. I have to manually kill it using pkill.
It bascially looks like this: taHBwbg
That grey/brown section is chromium. (dmesg segfault in image is not related to the issue. Since I don't get any dmesg output on all the crashes)

It happens randomly when I type in the omnibox. Also happens with google-chrome and google-chrome-dev from the AUR.
I'm pretty sure it's related to dwm, or chromium being tiled since I have no problems in XFCE. (I'd like to keep using both chromium and dwm)

No messages in dmesg.
I tried running from the terminal, output:

[11729:11749:0310/194647:ERROR:object_proxy.cc(624)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[11729:11749:0310/194647:ERROR:object_proxy.cc(624)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[11729:11729:0310/194647:ERROR:object_proxy.cc(529)] Failed to call method: org.chromium.Mtpd.EnumerateStorages: object_path= /org/chromium/Mtpd: org.freedesktop.DBus.Error.ServiceUnknown: The name org.chromium.Mtpd was not provided by any .service files
[11729:11729:0310/194647:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
[11729:11729:0310/194649:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[11729:11729:0310/194726:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
[11729:11729:0310/194733:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
[11729:11729:0310/194738:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
[11729:11729:0310/194739:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
[11729:11729:0310/194740:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
^CCheck failed: g_pipe_pid == getpid()
[11729:11729:0310/194802:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()

Last edited by toringe (2013-03-10 22:11:57)

Offline

#2 2013-03-10 19:43:15

capthookb
Member
Registered: 2007-12-10
Posts: 123

Re: [PROBABLY SOLVED] Chromium freezes in DWM

I have the same problem with chromium Version 25.0.1364.152 (185281) and kde 4, for several weeks now.
It freezes when i type in the omnibox, but not always.

Offline

#3 2013-03-10 21:11:48

toringe
Member
Registered: 2011-09-05
Posts: 49

Re: [PROBABLY SOLVED] Chromium freezes in DWM

Well, I might have the same problem in Xfce, haven't quite tested it.
Will check for sure.

Edit: nope, not the same problem in Xfce.
Guess I'll have to stick with Xfce, unless someone knows a fix. Switching to Firefox is not an option since I find FF's dev tools "clunky" compared to Chromium's

Last edited by toringe (2013-03-10 22:05:21)

Offline

#4 2013-03-10 22:11:24

toringe
Member
Registered: 2011-09-05
Posts: 49

Re: [PROBABLY SOLVED] Chromium freezes in DWM

Kind of fixed, I think. Haven't tested it too much but I did

rm -rf .config/chromium

and now it seems to play nice with DWM.
Probably something wrong with my profile synced from my mac.

Edit: Also saw some threads about libcanberra-pulse, I've tried pulseaudio but removed it. But libcanberra-pulse was left behind. Removed that too for good measures.
Hope this will work out now.

Last edited by toringe (2013-03-10 22:25:17)

Offline

#5 2013-03-11 13:34:01

capthookb
Member
Registered: 2007-12-10
Posts: 123

Re: [PROBABLY SOLVED] Chromium freezes in DWM

toringe, I have tried that as well. The issue seemed to be gone, but it didn't. Sooner or later it came back.

Offline

#6 2013-03-11 22:46:20

Draje
Member
Registered: 2007-06-21
Posts: 102
Website

Re: [PROBABLY SOLVED] Chromium freezes in DWM

Same problem here running 25.0.1364.160 in Awesome WM.

Wiping it's config directory did not fix the problem indefinitely.

Offline

#7 2013-03-12 20:21:01

PhilThompson
Member
Registered: 2012-08-15
Posts: 13

Re: [PROBABLY SOLVED] Chromium freezes in DWM

This has been bugging me for ages but I found a post that suggested disabling composite rendering:

chromium-browser --disable-accelerated-compositing

It fixed issues I was having with Twitter and Github specifically. chrome://gpu-internals/ seemed to show it was already disabled but this option did fix my issue.


HTH

Offline

#8 2013-03-14 15:48:11

capthookb
Member
Registered: 2007-12-10
Posts: 123

Re: [PROBABLY SOLVED] Chromium freezes in DWM

I tried that as well. It still freezes.
I tried also installing gtk-qt-engine and changing gtk theme, but still the freezeing is there.
Do you have any extensions installed? I have two: Chromium Wheel smooth scroller and Photo zoom for facebook.

Offline

#9 2013-03-26 19:20:29

capthookb
Member
Registered: 2007-12-10
Posts: 123

Re: [PROBABLY SOLVED] Chromium freezes in DWM

Did you find any solution? It is really annoying. It happens all the time.

https://groups.google.com/a/chromium.or … -lOg0krlDU
Let's hope that it will be fixed in 148444 revision.

Last edited by capthookb (2013-03-26 19:26:13)

Offline

Board footer

Powered by FluxBB