You are not logged in.

#1 2012-03-27 13:37:35

Huulivoide
Member
From: Finaland->Lapland->Kemi
Registered: 2009-11-19
Posts: 19
Website

Systemd canno't connect to dbus

So I've started to get these errors lately while trying to (re)start/stop/status of the services.
These started about a week ago
"Failed to get D-Bus connection: No connection to service manager"

I can boot all fine. But not shutdown (been suspending to RAM for a week or so).

Offline

#2 2012-08-08 01:37:27

neighborhoodhacker
Member
Registered: 2012-08-06
Posts: 45

Re: Systemd canno't connect to dbus

I am getting this same issue. I don't have any inclination how to fix it.

Edit: my computer shuts down fine, but I still get the above mentioned error

Last edited by neighborhoodhacker (2012-08-08 01:46:58)

Offline

#3 2012-08-27 02:24:23

JohnnyDeacon
Member
From: Colombia
Registered: 2012-01-18
Posts: 81

Re: Systemd canno't connect to dbus

I'm getting this issue after install syslinux bootloader today. NetworkManager is not starting too.

My system is booting and shutdown fine too.

Any ideas?

Thanks in advance

Last edited by JohnnyDeacon (2012-08-27 02:25:33)

Offline

#4 2012-08-27 17:16:28

nanix
Member
Registered: 2010-11-07
Posts: 11

Re: Systemd canno't connect to dbus

If you are running a custom kernel make sure you compile with CONFIG_CGROUPS = y, systemd requires it. The aur lqx no longer has this flagged.

Check journalctl after a boot up for any errors.

Remove "quiet" from the kernel parameters in your bootloader's config file so that you will see any important errors.

edit:
This post is kind of irrelevant to these new issues - I believe - and was originally intended to the OP who is months past this problem now.j

Last edited by nanix (2012-08-27 17:40:23)

Offline

#5 2012-09-04 14:07:19

TobyJamesJoy
Member
From: Melbourne, Australia
Registered: 2012-06-13
Posts: 24
Website

Re: Systemd canno't connect to dbus

Hi, I'm having an identical problem to this, if the OP is still lurking around these parts I'd love a couple of pointers.

Cheers,
Toby.

EDIT: Figured it out, I hadn't properly started the session with systemd, forgot to modify the kernel parameters... dummy

Last edited by TobyJamesJoy (2012-09-04 14:16:21)

Offline

#6 2012-09-12 17:24:39

msx
Member
From: solar.system/earth/ar/bue/mdp
Registered: 2010-08-08
Posts: 184
Website

Re: Systemd canno't connect to dbus

nanix wrote:

If you are running a custom kernel make sure you compile with CONFIG_CGROUPS = y, systemd requires it. The aur lqx no longer has this flagged.

Check journalctl after a boot up for any errors.

Remove "quiet" from the kernel parameters in your bootloader's config file so that you will see any important errors.

edit:
This post is kind of irrelevant to these new issues - I believe - and was originally intended to the OP who is months past this problem now.j

I got this error yesterday when I tried to use lm_sensors with Liquorix 3.5.3-2 but this time rather to be a Liquorix-specific fault the flag isn't here at all in this kernel branch, see  http://cateee.net/lkddb/web-lkddb/CGROUPS.html.
However I already asked the Liquorix kernel mantainer to enable this flag in the future to have full sysmted support: http://aur.archlinux.org/packages.php?ID=51332.
Thanks for the tip @nanix.


Enjoying i3wm w/ lifebar + j4-dmenu-desktop + tab_windows / fish shell / Emacs / tmux / Konsole / KDE apps
Arch + Linux-libre kernel: ParabolaGNULinux.org

Offline

#7 2013-03-27 02:06:32

theodoiq
Member
From: Brazil
Registered: 2013-03-20
Posts: 17

Re: Systemd canno't connect to dbus

Hi!

I was with the same situation here, SOLVED in my case, for now. That's my steps:

1 -      Install "systemd" and append the following to your kernel parameters: init=/usr/lib/systemd/systemd (by editing your /boot/grub/menu.lst or in your /etc/lilo.conf).
         In my /boot/grub/menu.lst ->
                    kernel /vmlinuz-linux root=/dev/sda6 ro init=/usr/lib/systemd/systemd

    Once completed you may enable any desired services via the use of systemctl enable <service_name> (this roughly equates to what you included in the DAEMONS array, with different names.). In my case, I want KDM - my boot wasn't starting KDM automatically.

2 -     Reboot your system and verify that systemd is currently active by using the following command: cat /proc/1/comm. This should return the string systemd.

3 -     Make sure your hostname is set correctly under systemd: hostnamectl set-hostname myhostname.

4 -     Proceed to remove "initscripts" and "sysvinit" from your system and install "systemd-sysvcompat".

5 -    Optionally, remove the init=/usr/lib/systemd/systemd parameter as it is no longer needed. systemd-sysvcompat provides the default init.

I hope that works to you!

Offline

Board footer

Powered by FluxBB