You are not logged in.

#1 2013-03-27 01:55:05

powerpoint45
Member
Registered: 2013-03-06
Posts: 23

Messed up characters in awesome wm

Hey guys I have read MANY forum posts about this and have found nothing that fixed my problem. I am hoping someone could fix this for me (: Here is a pic of the type of issue: http://imgur.com/M1nQ8VR look at the awesome wm tab with firefox and you will see some strange characters... 

Here is the output of locale:

LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES=C
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US
.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Here is the output of cat /etc/locale.conf

LANG="en_us.UTF-8"

Here is the output of cat /etc/locale.gen

en_US ISO-8859-1
en_US.UTF-8 UTF-8

Here is the output of locale -a

C
en_US
en_US.iso88591
en_US.utf8
POSIX

Here is the output of localectl list-locales

en_US
en_US.iso88591
en_US.utf8

Here is the output of localectl status

   System Locale: LANG=en_us.UTF-8
       VC Keymap: us
      X11 Layout: n/a

I just can't figure out what's up!!!

Last edited by powerpoint45 (2013-03-27 02:00:52)


Developer of Lucid Launcher for Android

Offline

#2 2013-03-27 02:44:26

cookies
Member
Registered: 2013-01-17
Posts: 253

Re: Messed up characters in awesome wm

Those locale settings seem to be fine.

When exactly do those strange symbols appear? Only when using firefox (on every page/for every tab/just some times)? Are other apps affected too?

Offline

#3 2013-03-27 03:41:51

powerpoint45
Member
Registered: 2013-03-06
Posts: 23

Re: Messed up characters in awesome wm

cookies wrote:

Those locale settings seem to be fine.

When exactly do those strange symbols appear? Only when using firefox (on every page/for every tab/just some times)? Are other apps affected too?

They allways appear...in variouse applications such as closed captioning on a youtube video, other awesome wm tabs, and things like that

Last edited by powerpoint45 (2013-03-27 03:42:32)


Developer of Lucid Launcher for Android

Offline

#4 2013-03-27 03:58:04

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Messed up characters in awesome wm

I am going to guess that this is actually a font configuration issue.  Have you configured your fonts at all?

I would like to mention that font configuration confuses the hell out of me.  So this is probably as much real insight as I will likely be able to give.  You need someone like bohoomil to tell you if this is really a font problem.  I actually just used his infinality configs and packages to make my fonts real nice.



Edit: Do you have a selection of fonts installed?  I think this aur package covers pretty much anything you may need in the way of fonts and the internets and stuffs.

Last edited by WonderWoofy (2013-03-27 04:00:27)

Offline

#5 2013-03-28 13:38:40

cookies
Member
Registered: 2013-01-17
Posts: 253

Re: Messed up characters in awesome wm

I found some messed up characters as well, but I only got them in kate and claws-mail (maybe other apps too, but I haven't tried them all), firefox and chromium are fine.

I'll take a closer look into fonts and see where it takes me.

Offline

#6 2013-10-01 00:25:35

powerpoint45
Member
Registered: 2013-03-06
Posts: 23

Re: Messed up characters in awesome wm

thanks guys. Switched to mate wm (;


Developer of Lucid Launcher for Android

Offline

Board footer

Powered by FluxBB