You are not logged in.

#1 2013-03-27 20:01:39

Don Coyote
Member
From: Great Lakes Region
Registered: 2010-09-06
Posts: 67

USB drives (and card reader) not automounting in Xfce

After a recent reinstall of Arch, USB drives are not mounting automatically. On my previous install on this machine, an X201i Thinkpad, this worked out of the box.

I installed and did the configuration for autofs and saw no results. Then i noticed that Thunar is supposed to have automounting options built in. I checked all the tik boxes i could find in the menu for automounting, but still no automount.

I have been able to manually mount USB sticks. The 3 in 1 card reader (realtek RTS5159) does show up with lsusb but not fdisk -l, a dmesg with a grep for sd* instances, nor blkid -o list -c /dev/null.

Where do i look for automounting clues? How do i make the card reader into a device i can mount?

Last edited by Don Coyote (2013-03-28 15:26:43)


ThinkPad X201i

Offline

#2 2013-03-27 22:12:14

s1ln7m4s7r
Member
Registered: 2013-02-22
Posts: 262

Re: USB drives (and card reader) not automounting in Xfce

Had you read Thunar wiki?

I don't know if it can help you, but here it goes:

https://wiki.archlinux.org/index.php/Thunar

Offline

#3 2013-03-27 22:27:08

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: USB drives (and card reader) not automounting in Xfce

Thunar has it built in? I thought you needed to use something life gvfs for that... though it has been a long time since I have used thunar.


Edit: Nevermind, after reading the wiki page (as the OP should have done before asking here), I see that gvfs is only recommended to mount samba shares.  Otherwise regular automounting uses thunar-volman.

Last edited by WonderWoofy (2013-03-27 22:29:46)

Offline

#4 2013-03-27 23:51:24

smakked
Member
From: Gold Coast , Australia
Registered: 2008-08-14
Posts: 419

Re: USB drives (and card reader) not automounting in Xfce

have you got "polkit-gnome" installed?


Certified Android Junkie
Arch 64

Offline

#5 2013-03-28 00:57:10

Don Coyote
Member
From: Great Lakes Region
Registered: 2010-09-06
Posts: 67

Re: USB drives (and card reader) not automounting in Xfce

Sorry, i'd been looking into some other stuff since i tried Thunar and forgot to mention that i had indeed installed thunar-volman before trying to automount and it did not work. However i now installed gvfs and that fixed it for USB drives. I did read a wiki on Thunar and automounting but must have really been out of it to miss the gvfs part there.

I can also now see the 3in1 card reader as sdbx and manually mount it, but the card reader is not automounting. I do not have polkit-gnome installed. Could polkit have anything to do with this? It does not seem like a permissions issue to me...


ThinkPad X201i

Offline

Board footer

Powered by FluxBB