You are not logged in.

#1 2013-03-27 16:52:27

juma93
Member
Registered: 2012-02-09
Posts: 4

[SOLVED] Disable Secure Boot on Asus Zenbook UX32A

Hi all, I hope I have posted in the right section, please move it otherwise.
I'm trying to install Arch on an Asus Zenbook, but I cannot boot installation media (an USB stick, in this case), as it requires the EFI binary to be signed, and only simple way out is to disable Secure Boot.
Unfortunately I'm not able to disable it from UEFI interface, as it is grayed out. Solutions I've found searching the Web suggested to set a password to BIOS, but even this way I wasn't able to enable it.
Notebook came with Windows 8 built in, and I upgraded BIOS to 214 version.

Thank you.

Last edited by juma93 (2013-03-30 01:29:05)

Offline

#2 2013-03-27 17:12:51

srs5694
Member
From: Woonsocket, RI
Registered: 2012-11-06
Posts: 719
Website

Re: [SOLVED] Disable Secure Boot on Asus Zenbook UX32A

Details of the user interface vary greatly from one computer to another. I've got some notes on disabling Secure Boot on an ASUS P8H77-I motherboard here, but they may not apply to your notebook, or there may be an extra trick. Along the latter lines, look for "fast boot" and "CSM" options and try fiddling with them to see if the Secure Boot option becomes alterable.

Offline

#3 2013-03-28 00:58:53

juma93
Member
Registered: 2012-02-09
Posts: 4

Re: [SOLVED] Disable Secure Boot on Asus Zenbook UX32A

Thank you for you answer, I tried fiddling with these two options, but I had no luck.
Eventually I suceeded to disable it, resetting all the keys in key management section, forcing it to enter in setup mode.
It is a shame altough it should be so complicated, I see no advantage over manufacturers blocking power users, they are only risking losing potential buyers doing so, as Microsoft isn't forcing them (at least I hope).

Offline

Board footer

Powered by FluxBB