You are not logged in.

#1 2013-03-28 04:51:08

owned91
Member
Registered: 2013-03-28
Posts: 3

[Ayuda] Compilando programa con make & make install

Que tal archlinuxeros el motivo de este tema es si alguíen me puede ayudar a compilar un programa, ya que estoy tratando de compilarlo pero me tira errores que no se como arreglarlos de antemano muchas gracias...

El programa que estoy tratando de compilar son estos:
http://shaga.do.am/squid-3.0.STABLE1.shPatch.tar.gz
http://shaga.do.am/squid-2.6.STABLE13.shPatch.tar.gz

Revisando e investigando tambien hay un parche en squid.
http://devel.squid-cache.org/cgi-bin/diff/shaga.patch
si quiere ver el texto del parche click en el enlace de abajo
http://devel.squid-cache.org/cgi-bin/diff/shaga

Lo que no se, es si este parche puedo usarlo en la version de squid que esta en los repositorios de archlinux... Si no me explico me avisan, para tratar de explicarlo mejor...

Offline

#2 2013-04-04 01:13:02

owned91
Member
Registered: 2013-03-28
Posts: 3

Re: [Ayuda] Compilando programa con make & make install

alguien? sad

Offline

#3 2013-04-04 01:25:44

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,219
Website

Re: [Ayuda] Compilando programa con make & make install

Sorry for not responding in Spanish.  I can understand Spanish well, but I'd make a fool out of myself trying to reply in Spanish.

But you say you get errors in compiling that, right?  What are the errors?  Please give the exact error output.

Also, if you wish to use code patches that are not included in the version in the repositories, you can and should use the ABS with `makepkg` to build a package rather than building manually.

------ google translate:

Lo siento por no responder en español. Puedo entender bien el español, pero me gustaría hacer un tonto de mí mismo tratando de responder en español.

Pero usted dice que obtiene errores en la compilación de eso, ¿verdad? ¿Cuáles son los errores? Por favor dar la salida de error exacto.

También, si usted desea utilizar los parches de código que no se incluyen en la versión en los repositorios, usted puede y debe utilizar el ABS con `makepkg` para construir un paquete en lugar de crear manualmente.

ABS: https://wiki.archlinux.org/index.php/Ar … a%C3%B1ol)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#4 2013-04-04 07:04:22

jakobcreutzfeldt
Member
Registered: 2011-05-12
Posts: 1,033

Re: [Ayuda] Compilando programa con make & make install

owned91 wrote:

Que tal archlinuxeros el motivo de este tema es si alguíen me puede ayudar a compilar un programa, ya que estoy tratando de compilarlo pero me tira errores que no se como arreglarlos de antemano muchas gracias...

Por favor añade el texto de los errores al aporte aquí que podamos leerlos...

owned91 wrote:

Lo que no se, es si este parche puedo usarlo en la version de squid que esta en los repositorios de archlinux... Si no me explico me avisan, para tratar de explicarlo mejor...

Normalmente, no se puede aplicar a alguna version de la aplicación un parche que está hecho para otra version. Es importante verificar de cual version este parche está hecho. Si está diferente de la version en los repositorios, es probable que no puedes aplicarlo sin modificarlo.

Last edited by jakobcreutzfeldt (2013-04-04 07:04:42)

Offline

#5 2013-04-04 17:04:56

owned91
Member
Registered: 2013-03-28
Posts: 3

Re: [Ayuda] Compilando programa con make & make install

When is compiling I have messages saying the command g+ +: xxx is
no longer used or no longer supported and this AuthUser.cc:161:17:
error: variable 'username' set but not used
[-Werror=unused-but-set-variable]
cc1plus: all warnings being treated as errors
make[1]: *** [AuthUser.lo] Error 1
make[1]:  se sale del directorio `/home/mike/squid3/src'
make: *** [all-recursive] Error 1

and not to do now :S

Offline

Board footer

Powered by FluxBB