You are not logged in.

#1 2013-03-22 12:16:36

lesto
Member
Registered: 2010-07-13
Posts: 107

[solved][kwin][radeon] can't activate opengl render

Hi
i have a sapphire radeon HD7850.
Yesterday i've decided to drop the catalyst driver and install the open source one.

I've followed the wiki to uninstall the Catalyst driver, and then again to install the open source one.

here my "/etc/X11/xorg.conf.d/20-radeon.conf"

Section "Device"
        Identifier "Radeon"
        Driver "Radeon"
        Option   "SWcursor" "off"
        Option "AccelMethod" "EXA"
        Option "EnablePageFlip" "on"
EndSection

BUTwhen i try to change the Kwin render from (desktop effect -> advanced) Xrender to opengl, everything seems ok (no error, i can accept the new configuration), but it complain some effect aren't activated because they need OpenGL! O.o

so from terminal i've run:

kwin --replace

and tryed againg to set OpenGL; i've got:

kwin(1085) KWin::Compositor::slotCompositingOptionsInitialized: Initializing OpenGL compositing
kwin(1085) KWin::GlxBackend::initBufferConfigs: Drawable visual (depth  24 ): 0x "12e"
kwin(1085) KWin::GlxBackend::initBufferConfigs: Drawable visual (depth  32 ): 0x "58"
kwin(1085) KWin::GlxBackend::initBuffer: Buffer visual (depth  24 ): 0x "132"
OpenGL vendor string:                   VMware, Inc.
OpenGL renderer string:                 Gallium 0.4 on llvmpipe (LLVM 3.2, 128 bits)
OpenGL version string:                  2.1 Mesa 9.1.1
OpenGL shading language version string: 1.20
Driver:                                 LLVMpipe
GPU class:                              Unknown
OpenGL version:                         2.1
GLSL version:                           1.20
Mesa version:                           9.1.1
X server version:                       1.14
Linux kernel version:                   3.8.3
Direct rendering:                       yes
Requires strict binding:                yes
GLSL shaders:                           yes
Texture NPOT support:                   yes
Virtual Machine:                        no
NO VSYNC! glXGetVideoSync, haveSwapInterval, glXIsDirect false false 1 
kwin(1085) KWin::GlxBackend::init: DB: true , Direct: true
kwin(1085) KWin::SceneOpenGL2::supported: Driver does not recommend OpenGL 2 compositing
kwin(1085) KWin::SceneOpenGL1::supported: Driver does not recommend OpenGL 1 compositing
kwin(1085): OpenGL driver recommends XRender based compositing. Falling back to XRender. 
kwin(1085): To overwrite the detection use the environment variable KWIN_COMPOSE 
kwin(1085): For more information see http://community.kde.org/KWin/Environment_Variables#KWIN_COMPOSE 
kwin(1085): Failed to initialize compositing, compositing disabled 
kwin(1085): Consult http://techbase.kde.org/Projects/KWin/4.0-release-notes#Setting_up 
kwin(1085) KWin::Compositor::slotCompositingOptionsInitialized: Initializing XRender compositing
kwin(1085) KWin::currentRefreshRate: Vertical Refresh rate  60 Hz

also

KWIN_COMPOSE=o kwin --replace

give the same result!


LIBGL_DEBUG=verbose glxinfo >> /dev/null

give

libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/swrast_dri.so

I can't understand why the driver can't use OpenGL, as far as i know it should be ok with my graphic card!

anyone have a clue to where i can find some useful log/info, or can tell me what i'm doing wrong?

Last edited by lesto (2013-04-02 20:16:32)

Offline

#2 2013-03-28 20:26:53

nirvanix
Member
From: Saskatoon
Registered: 2005-01-31
Posts: 193

Re: [solved][kwin][radeon] can't activate opengl render

Did you try to turn off the opengl 2 shaders? Maybe turn off/on vsync too?


I've got a lovely bunch of coconuts...

Offline

#3 2013-03-28 23:59:07

lesto
Member
Registered: 2010-07-13
Posts: 107

Re: [solved][kwin][radeon] can't activate opengl render

nothing to do, i still get the same problem.

i can't understand where i should look to track the problem

Last edited by lesto (2013-03-29 00:01:30)

Offline

#4 2013-03-29 01:43:05

s1ln7m4s7r
Member
Registered: 2013-02-22
Posts: 262

Re: [solved][kwin][radeon] can't activate opengl render

Have you removed "nomodeset" from your bootloader kernel entry?

Offline

#5 2013-03-30 08:16:17

andy_v
Member
From: Estonia
Registered: 2012-04-27
Posts: 31

Re: [solved][kwin][radeon] can't activate opengl render

HD 7000 series and newer use glamor for 2D acceleration. Try removing the line containing "EXA" (and other lines beginning with the word "Option" as they might conflict with glamor, once you get everything working, then, if you really need those options, you can try adding them back, apart from "AccelMethod" "EXA" that is) from your 20-radeon.conf and adding those described in the wiki under the glamor section.

Offline

#6 2013-04-02 20:16:11

lesto
Member
Registered: 2010-07-13
Posts: 107

Re: [solved][kwin][radeon] can't activate opengl render

andy_v I love you smile

finally my wobbly windows are back! let's try steam!!

my X11 conf:

Section "Module"
        Load "dri2"
        Load "glamoregl"
EndSection

Section "Device"
        Identifier "Radeon"
        Driver "Radeon"
        Option "AccelMethod" "glamor"
EndSection

Offline

#7 2014-02-17 11:59:05

joanmanel
Member
Registered: 2012-11-06
Posts: 98

Re: [solved][kwin][radeon] can't activate opengl render

Can you report how Steam goes with RadeonSI?

Offline

#8 2014-02-17 12:34:07

Neburski
Member
Registered: 2009-09-15
Posts: 118

Re: [solved][kwin][radeon] can't activate opengl render

joanmanel wrote:

Can you report how Steam goes with RadeonSI?

Why don't you just try it out?

You aren't supposed to necro bump posts, especially not when you have no new information to provide.

Offline

Board footer

Powered by FluxBB