You are not logged in.

#1 2013-03-29 13:50:57

ubunchu
Member
Registered: 2012-05-01
Posts: 176

[SOLVED!] Archiso -- KDM - LXDM don't start at boot (enabled)

Hello,
I have installed on this computer my customized Archiso (with no special configurations). I have enabled kdm.service, but nothing happened. After reboot either.
I have now tried with LXDM, same thing. With "systemctl status" I usually get something like: "enabled, dead"
If I start kdm or lxdm manually, it works.

sudo systemctl start lxdm; sudo systemctl status lxdm 
lxdm.service - LXDE Display Manager
          Loaded: loaded (/usr/lib/systemd/system/lxdm.service; enabled)
          Active: active (running) since vie 2013-03-29 13:54:08 UTC; 46min ago
        Main PID: 319 (lxdm-binary)
          CGroup: name=systemd:/system/lxdm.service
                  └─321 /usr/bin/X :0 vt07 -nolisten tcp
                  ‣ 319 /usr/sbin/lxdm-binary
mar 29 13:54:08 ubunchu systemd[1]: Starting LXDE Display Manager...
mar 29 13:54:08 ubunchu systemd[1]: Started LXDE Display Manager.
mar 29 13:54:12 ubunchu lxdm-binary[319]: pam_unix(lxdm:session): session opened for user ubunchu by (uid=0) 

Dmesg: http://pastie.org/private/8n97afoezf3urejz3qizeq
On some posts they mentioned that maybe nvidia or a module starts up too late, or the login managers too early.
Any tips/hints on what should I try?
Thanks in advance.
Cheers!

Last edited by ubunchu (2013-04-22 22:06:12)


Don't forget to mark as [SOLVED].

Offline

#2 2013-03-29 14:07:39

blackout23
Member
Registered: 2011-11-16
Posts: 780

Re: [SOLVED!] Archiso -- KDM - LXDM don't start at boot (enabled)

What does your /var/log/Xorg.log say?

If you want your nvidia module to be loaded earlier you can put it into MODULES="nvidia" in  /etc/mkinitcpio.conf and rebuild your initramfs with
# mkinitcpio -p linux.

Last edited by blackout23 (2013-03-29 14:08:25)

Offline

#3 2013-03-29 14:24:33

ubunchu
Member
Registered: 2012-05-01
Posts: 176

Re: [SOLVED!] Archiso -- KDM - LXDM don't start at boot (enabled)

ls -al /var/log/X*
-rw-r--r-- 1 root root  17726 mar 29 15:16 /var/log/Xorg.0.log
-rw-r--r-- 1 root root  18321 mar 29 14:51 /var/log/Xorg.0.log.old
-rw-r--r-- 1 root users 20902 mar 24 15:18 /var/log/Xorg.3.log
-rw-r--r-- 1 root users 35526 mar 24 12:59 /var/log/Xorg.5.log
-rw-r--r-- 1 root users 34707 mar 24 09:45 /var/log/Xorg.8.log

Xorg.0.log: http://pastie.org/private/wb7hzj6x48kdf0cqt1arnw (after starting LXDM manually)
Xorg.0.log.old http://pastie.org/private/qhxqhtukce06tft9swoza
Adding "nvidia" into mkinitcpio and rebuilding, did not change it.


Don't forget to mark as [SOLVED].

Offline

#4 2013-04-18 07:17:55

ubunchu
Member
Registered: 2012-05-01
Posts: 176

Re: [SOLVED!] Archiso -- KDM - LXDM don't start at boot (enabled)

At boot I can get:

 [root@ubunchu ~]# systemctl status kdm
kdm.service - K Display Manager
   Loaded: loaded (/usr/lib/systemd/system/kdm.service; enabled)
   Active: inactive (dead)

[root@ubunchu ~]# ls -al /etc/systemd/system/
total 32
drwxr-xr-x 4 root root 4096 abr 10 22:51 .
drwxr-xr-x 5 root root 4096 abr 18 09:10 ..
-rw-r--r-- 1 root root 1660 mar 23 16:43 autologin@.service
lrwxrwxrwx 1 root root   46 mar 24 13:39 dbus-org.freedesktop.NetworkManager.service -> /usr/lib/systemd/system/NetworkManager.service
lrwxrwxrwx 1 root root   41 mar 23 15:50 default.target -> /usr/lib/systemd/system/multi-user.target
-rw-r--r-- 1 root root  230 mar  7 14:07 dhcpcd.service
lrwxrwxrwx 1 root root   35 abr 10 22:51 display-manager.service -> /usr/lib/systemd/system/kdm.service
-rw-r--r-- 1 root root  134 mar  7 14:07 etc-pacman.d-gnupg.mount
drwxr-xr-x 2 root root 4096 abr 18 09:10 multi-user.target.wants
drwxr-xr-x 2 root root 4096 mar 24 13:39 network.target.wants
-rw-r--r-- 1 root root  325 mar  7 14:07 pacman-init.service 

On every system I install my custom archiso (basic install) the same thing happens, what am I missing?


Don't forget to mark as [SOLVED].

Offline

#5 2013-04-19 12:17:10

bb83
Member
Registered: 2009-04-11
Posts: 7

Re: [SOLVED!] Archiso -- KDM - LXDM don't start at boot (enabled)

Did you try changing default target to:

systemctl enable graphical.target

Offline

#6 2013-04-21 19:18:36

ubunchu
Member
Registered: 2012-05-01
Posts: 176

Re: [SOLVED!] Archiso -- KDM - LXDM don't start at boot (enabled)

#systemctl enable graphical.target
Failed to issue method call: File exists
#systemctl status graphical.target
graphical.target - Graphical Interface
          Loaded: loaded (/usr/lib/systemd/system/graphical.target; disabled)
          Active: inactive (dead)
            Docs: man:systemd.special(7)
#systemctl status default.target
multi-user.target - Multi-User
          Loaded: loaded (/usr/lib/systemd/system/multi-user.target; enabled)
          Active: active since dom 2013-04-21 20:14:28 UTC; 1h 4min ago
            Docs: man:systemd.special(7)

abr 21 20:14:28 archiso systemd[1]: Starting Multi-User.
abr 21 20:14:28 archiso systemd[1]: Reached target Multi-User.

You mean editing default.target manually? If so, how?

PS: this error is on other machines with kdm and lxdm. On my computer I got the same thing (enabled but not started after boot) with sshd.

Last edited by ubunchu (2013-04-21 19:21:25)


Don't forget to mark as [SOLVED].

Offline

#7 2013-04-22 21:06:02

Raynman
Member
Registered: 2011-10-22
Posts: 1,112

Re: [SOLVED!] Archiso -- KDM - LXDM don't start at boot (enabled)

Disable multi-user.target first or use --force to overwrite the existing symlink.

To clarify: 'inactive' means it wasn't started at all or was stopped (clean exit), otherwise it would be 'failed'.

Last edited by Raynman (2013-04-22 21:23:45)

Offline

#8 2013-04-22 22:05:36

ubunchu
Member
Registered: 2012-05-01
Posts: 176

Re: [SOLVED!] Archiso -- KDM - LXDM don't start at boot (enabled)

Raynman wrote:

Disable multi-user.target first or use --force to overwrite the existing symlink.

To clarify: 'inactive' means it wasn't started at all or was stopped (clean exit), otherwise it would be 'failed'.

Hoooooly sckittens!
Where have you been all my life?
You're a life saver! Thank you! I owe you one (or a few)!
Thank yooou!!!
Finally!

SOLV'D

THANK YOU AGAIN!!!


(though its weird that on my computer I did not need to do this [on mine both multi-user and graphical are disabled], only on other computers this problem ocurred [which now, solved, has graphical enabled])


Don't forget to mark as [SOLVED].

Offline

Board footer

Powered by FluxBB