You are not logged in.

#1 2013-03-28 08:21:49

vaviary
Member
Registered: 2012-11-06
Posts: 8

Dual screen GDM problem

I have a rather big problem with my dual screen setup. The left screen is 1920x1080 and the right one 1360x768.
This is my /etc/X11/xorg.conf:

Section "Monitor"
	Identifier	"DVI-0"
	Option		"Primary"	"true"
	Option		"Position"	"0 0"
	Option		"PreferredMode"	"1920x1080"
EndSection
#
Section "Monitor"
	Identifier	"DVI-1"
	Option		"Position"	"1920 180"
	Option		"PreferredMode"	"1360x768"
EndSection

I set it up as described here. However, GDM doesn't behave as normal, but gets stuck with a slightly dimmed default GDM background (the one with the blue stripes) on the first screen and a crazily flashing second screen. I never even get to the login prompt.
If I plug the second screen out before the computer boots, GDM starts normally. I can then plug it back in as soon as the GNOME Shell panel has appeared. If I do this before the panel is visible, I get two screens full of graphics errors (a mess of blue/magenta/white squares).
As soon as the second screen is plugged back in, I can immediately use it and drag windows back and forth, however, the "Position" setting in xorg.conf is ignored, i.e. the height is shifted. I can solve this by entering this in the terminal:

xrandr --output DVI-0 --mode 1920x1080 --pos 0x0 --output DVI-1 --mode 1360x768 --pos 1920x180

I hope someone can help me with this. I just want to be able to log in and use the second screen straight away. By the way, if I log out, GDM doesn't seem not have any problem with the second screen: I can log back in normally.
Thanks in advance!

Offline

#2 2013-03-29 14:01:43

olive
Member
From: Belgium
Registered: 2008-06-22
Posts: 1,238

Re: Dual screen GDM problem

With my intel card, I have to put:

        Option      "monitor-VGA1"      "vgamonitor"
        Option      "monitor-LVDS1"     "lvdsmonitor"

in the device section (the VGA1 and LVDS1 is what you see from xrandr). I can then refer the the two monitors with

  Identifier     "vgamonitor"

and

Identifier     "lvdsmonitor"

If gdm cannot behave properly, you can simply disable the external monitor in xorg.conf

Section "Monitor"
  Identifier     "vgamonitor"
  Option           "Disable"     "true"
EndSection

and reactivate it when you have logged in with xrandr (with the command in your post). There should be a possibility to automatically execute the xrandr command (I put in in ~/.xinitrc but I do not know gdm/gnome well).

Last edited by olive (2013-03-29 14:02:17)

Offline

#3 2013-03-29 14:07:04

Archimaredes
Member
Registered: 2013-01-23
Posts: 50

Re: Dual screen GDM problem

I noticed:

Option		"Position"	"1920 180"

I don't have much experience with this, so forgive me if I'm wrong, but should that not be 1080, instead of 180?

Offline

#4 2013-03-30 12:20:16

vaviary
Member
Registered: 2012-11-06
Posts: 8

Re: Dual screen GDM problem

Archimaredes wrote:

I don't have much experience with this, so forgive me if I'm wrong, but should that not be 1080, instead of 180?

Thank you, but "180" actually means that the upper border of the 2nd display starts 180 pixels below that of the 1st one. The number may be a bit misleading, but it is how my displays are physically set up.

olive wrote:

If gdm cannot behave properly, you can simply disable the external monitor in xorg.conf

This is a fabulous idea, I hadn't even thought about this! Launching the xrandr command at the start of the GNOME session is really easy with gnome-session-properties.
I tried disabling the 2nd display, but it just ignores the line and starts with GDM flashing like usual. This is my xorg.conf:

Section "Monitor"
	Identifier	"DVI-0"
	Option		"Primary"	"true"
	Option		"Position"	"0 0"
	Option		"PreferredMode"	"1920x1080"
EndSection
#
Section "Monitor"
	Identifier	"DVI-1"
	Option		"Position"	"1920 180"
	Option		"PreferredMode"	"1360x768"
	Option		"Disable"	"true"
EndSection

If I could get this to work, this would be a wonderful workaround.

Offline

#5 2013-03-30 15:10:52

olive
Member
From: Belgium
Registered: 2008-06-22
Posts: 1,238

Re: Dual screen GDM problem

Are you sue that your monitor section does correspond to the real monitor. It seems that it is being ignored. In my case I have to put option like this in the device section:

Option      "monitor-VGA1"      "vgamonitor"

for this to work. I cannot simply use Identifier "VGA-1" (I use the intel driver). This depends of the driver of the graphic card. Try to google somelike "dualscreen <your device card> linux" or something alike.

Offline

#6 2013-04-05 15:19:24

vaviary
Member
Registered: 2012-11-06
Posts: 8

Re: Dual screen GDM problem

Sorry to bother you again, I just seem to be too dumb to get this to work. It is so frustrating!
So, I understood what you said and changed the xorg.conf accordingly:

Section "Device"
	Identifier	"RadeonHD-6870"
	Driver		"radeon"
	Option		"monitor-DVI0"	"DVI-0"
	Option		"monitor-DVI1"	"DVI-1"
EndSection
#
Section "Monitor"
	Identifier	"DVI-0"
	Option		"Primary"		"true"
	Option		"Position"		"0 0"
	Option		"PreferredMode"	"1920x1080"
EndSection
#
Section "Monitor"
	Identifier	"DVI-1"
	Option		"Enable"		"false"
EndSection

But it seems that it is still ignoring it.  After trying your 'Option "Disable" "true"' I changed it for 'Option "Enable" "false"' because it is the one that appears in the xorg.conf man pages. Still, GDM just doesn't work, the screen doesn't turn off at the start of the X server.
I did also try 'Option "Ignore" "true"', which succesfully turns off the screen, but then I can't turn it back on with XRandR, which seems to be expected behavior, as the man pages say "This optional entry specifies that the monitor should be ignored entirely, and not reported through RandR.".

I am desperate, can someone tell me what exactly I am doing wrong? I just can't figure it out.

Offline

#7 2013-04-05 17:37:21

jacobopantoja
Member
From: Madrid
Registered: 2011-03-16
Posts: 44

Re: Dual screen GDM problem

If you are using GNOME 3, try without any xorg.conf and configuring through the built-in system setting.

Offline

Board footer

Powered by FluxBB