You are not logged in.

#1 2013-03-18 16:37:46

mjb
Member
From: Germany
Registered: 2012-01-28
Posts: 66

[WORKAROUND] rEFInd doesn't boot new linux 3.8.3-2

Hello!

Today I updated linux to 3.8.3-2 and rEFInd stopped booting. Instead I was stuck with the rEFInd screen (the one saying: booting vmlinux-linux).

Before you ask: Yes, I did copy the new kernel and initramfs to /boot/efi/EFI/arch by doing

sudo cp /boot/vmlinuz-linux /boot/efi/EFI/arch/vmlinuz-arch.efi
sudo cp /boot/initramfs-linux.img /boot/efi/EFI/arch/initramfs-arch.img
sudo cp /boot/initramfs-linux-fallback.img /boot/efi/EFI/arch/initramfs-arch-fallback.img

as I always do.

I solved the problem by starting from a Live-CD and downgrading the kernel. Does anyone know what the issue is?

Any help is much appreciated!

Last edited by mjb (2013-03-29 17:35:36)

Offline

#2 2013-03-18 18:04:39

srs5694
Member
From: Woonsocket, RI
Registered: 2012-11-06
Posts: 719
Website

Re: [WORKAROUND] rEFInd doesn't boot new linux 3.8.3-2

Please see this thread, which is probably the same problem you're having. Somebody has also finally created a bug report on the problem.

Offline

#3 2013-03-18 23:14:51

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,670

Re: [WORKAROUND] rEFInd doesn't boot new linux 3.8.3-2

@srs5694,

Are you sure this is the same problem? I thought that issue only affected more recent kernels but I can reproduce this failure with the LTS kernel. I have not had the issue at all with 3.7.* kernels - this is the first time it has happened. Both kernels were updated so is it the kernel or the config or...? Way out of my depth here.

With rEFInd, with both the standard and fallback options for the current kernel, it hangs mid line. That is, it prints almost all of the usual loading line up to "initram" and then stops mid-word.

With rEFInd and the LTS kernel, with both standard and fallback options, it hangs in the same place but then a message in yellow is overlaid which says "Error: unsupported while loading vmlinuz-linux-ltx".

GRUB boots fine. (But obviously this is expected as it is not using the stub loader.)

If it is a kernel bug, it is in the 3.0.69 as well (but it hasn't appeared in any other current or LTS kernel for me).

EDIT: Ignore this - I'm an idiot. (Result with LTS is *expected*.)

Last edited by cfr (2013-03-19 02:21:08)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#4 2013-03-19 02:24:59

srs5694
Member
From: Woonsocket, RI
Registered: 2012-11-06
Posts: 719
Website

Re: [WORKAROUND] rEFInd doesn't boot new linux 3.8.3-2

cfr wrote:

Are you sure this is the same problem? I thought that issue only affected more recent kernels but I can reproduce this failure with the LTS kernel. I have not had the issue at all with 3.7.* kernels - this is the first time it has happened.

The 3.8.3-2 reported by the OP is pretty recent, in my book. The thread to which I linked specifies that the problem began with certain 3.7.x kernels.

With rEFInd, with both the standard and fallback options for the current kernel, it hangs mid line. That is, it prints almost all of the usual loading line up to "initram" and then stops mid-word.

That's new, and suggests that you may be seeing something else -- either your kernel options are being truncated somehow (probably in a rEFInd bug) or there's a firmware bug that's causing the system to hang while rEFInd is displaying text. (rEFInd uses a system call called Print() to do this, so a hang mid-word suggests an EFI bug.) It might be best to start a new thread for this problem if you want to pursue it, if it's new.

With rEFInd and the LTS kernel, with both standard and fallback options, it hangs in the same place but then a message in yellow is overlaid which says "Error: unsupported while loading vmlinuz-linux-ltx".

The "unsupported" message means that the kernel lacks an EFI stub loader.

If it is a kernel bug, it is in the 3.0.69 as well (but it hasn't appeared in any other current or LTS kernel for me).

Unless it's been patched with a back-port of the EFI stub loader, I wouldn't expect 3.0.69 to boot directly via rEFInd or gummiboot.

Offline

#5 2013-03-20 08:36:50

Joekickass
Member
Registered: 2012-10-04
Posts: 25

Re: [WORKAROUND] rEFInd doesn't boot new linux 3.8.3-2

I'm actually using rEFInd (v0.6.7) to boot my Arch Linux installation, kernel 3.8.3-2. However, it's a macbook, so my rEFInd installation (and conf file) is located on my MacOSX partition, so it might be a little different from you setup. But I can confirm that it boots my kernel though...

Offline

#6 2013-03-21 00:56:17

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,670

Re: [WORKAROUND] rEFInd doesn't boot new linux 3.8.3-2

srs5694 wrote:

Unless it's been patched with a back-port of the EFI stub loader, I wouldn't expect 3.0.69 to boot directly via rEFInd or gummiboot.

Yes, I know. Hence the edit in my post above. I removed my confusion in the longer thread I'd posted in but I left it here because I was afraid that maybe I shouldn't just delete it given the forum rules. So I just edited the post with the comment to ignore it. Sorry for the confusion.

srs5694 wrote:

With rEFInd, with both the standard and fallback options for the current kernel, it hangs mid line. That is, it prints almost all of the usual loading line up to "initram" and then stops mid-word.

That's new, and suggests that you may be seeing something else -- either your kernel options are being truncated somehow (probably in a rEFInd bug) or there's a firmware bug that's causing the system to hang while rEFInd is displaying text. (rEFInd uses a system call called Print() to do this, so a hang mid-word suggests an EFI bug.) It might be best to start a new thread for this problem if you want to pursue it, if it's new.

If I try to boot to the rescue target (which is a shorter kernel command line), the line is not truncated but completes. Then it hangs. If you still think it is a different issue, I'll start a new thread, though.

Thanks.

Last edited by cfr (2013-03-21 01:00:51)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#7 2013-03-26 07:56:55

mjb
Member
From: Germany
Registered: 2012-01-28
Posts: 66

Re: [WORKAROUND] rEFInd doesn't boot new linux 3.8.3-2

Did anyone try it with 3.8.4 yet?

EDIT: oops. yes someone did: see comments here. The problem persists.

Last edited by mjb (2013-03-26 08:00:47)

Offline

#8 2013-03-29 17:35:17

mjb
Member
From: Germany
Registered: 2012-01-28
Posts: 66

Re: [WORKAROUND] rEFInd doesn't boot new linux 3.8.3-2

I switched to grub now and everything works fine. Think I'll just stick with that.

Offline

Board footer

Powered by FluxBB