You are not logged in.

#1 2012-08-15 18:58:34

Registered: 2012-08-01
Posts: 21

[SOLVED]ERROR: Unable to find root device. On first boot.

I installed Arch Linux today on my Macbook pro (several time with no success). The other installation methods were directly from the beginner guide. I following the beginners guide step by step, the only change I made on this install is I followed these instructions for the bootloader … _systems_2. When I rebooted my mac Refind detects the Arch installation and I select it. When it boots it gives me the following error:

ERROR: device 'UUID=e0cbe083..............................' not found. Skipping fsck.
ERROR: Unable to find root device 'UUID=e0cbe083........................'.
You are being dropped to a recovery shell
                      Type 'exit' to try and continue booting
sh: can't access tty; job control turned off
[rootfs /]#

I first created fstab, then chrooted to the drive, I ran this # mkinitcpio -p linux then installed the bootloader via # pacman -S grub-efi-x86_64, then I followed these instructions … boot_files. Once that was complete I installed pacman -S os-prober, then created the grub.cfg. Does anyone know how to fix this, I would really appreciate it. I've been at this for more than a week now. Thank you.

EDIT: Also my partitions are as follow:

/dev/sda4 EFI ext.vfat # boot
/dev/sda5 swap #swap
/dev/sda6 ext4 # root
/dev/sda7 ext4 #home

EDIT: I included ahci in my modules for /etc/mcinitcpio, now it works.

Last edited by ArchVillian (2012-08-16 03:05:57)


#2 2013-03-31 17:10:02

From: .earth
Registered: 2010-02-18
Posts: 907

Re: [SOLVED]ERROR: Unable to find root device. On first boot.

Same problem, but adding ahci didn't work for me. - joe at true skater dot io.


#3 2013-03-31 18:22:45

From: .nz
Registered: 2009-05-09
Posts: 25,059

Re: [SOLVED]ERROR: Unable to find root device. On first boot.

trusktr, you were allowed back on the proviso that you followed the Forum Etiquette; necrobumping a solved thread is not helpful.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438


Board footer

Powered by FluxBB