You are not logged in.

#1 2013-04-02 06:32:42

sl1pkn07
Member
From: Spanishtán
Registered: 2010-03-30
Posts: 312

warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst'

what is the new syntax for 'SyncFirst' in pacman 4.1?

greetings

Offline

#2 2013-04-02 06:35:48

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst'

What are those pages that tell you about software?

MAN I wish I could remember...

Offline

#3 2013-04-02 06:36:30

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst'

Offline

#4 2013-04-02 06:36:52

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,329
Website

Re: warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst'

Merge your pacman files...

Online

#5 2013-04-02 06:39:07

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,108
Website

Re: warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst'

Moving to [testing]...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

#6 2013-04-02 08:44:14

sl1pkn07
Member
From: Spanishtán
Registered: 2010-03-30
Posts: 312

Re: warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst'

Allan wrote:

Merge your pacman files...

it's  the first i make when update package (merge changes in /etc/makepkg and /etc/pacman.conf)

but need keep SyncFirst

# If upgrades are available for these packages they will be asked for first
SyncFirst  = linux-headers linux-lts-headers

need this to update kernel headers before update kernel, because i use mkinitcpio to update DKMS modules [1]

if upgrade kernel before install headers, the build dkms modules fail

[1] https://aur.archlinux.org/packages/mkinitcpio-dkms/

related:
https://wiki.archlinux.org/index.php/NV … any_kernel
https://wiki.archlinux.org/index.php/Vi … any_kernel

Last edited by sl1pkn07 (2013-04-18 12:11:34)

Offline

#7 2013-04-02 11:17:58

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,329
Website

Re: warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst'

That feature was broken and regularly caused more harm than good so was removed.   What we really need is post update hooks added to pacman to provide what you are looking for, but unfortunately that has never progressed beyond planning.   (Not a solution for now I know...)

Online

#8 2013-04-02 18:40:50

sl1pkn07
Member
From: Spanishtán
Registered: 2010-03-30
Posts: 312

Re: warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst'

oks, thanks sad

Offline

#9 2013-04-08 08:08:56

Corubba
Member
From: Germany
Registered: 2010-11-14
Posts: 80

Re: warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst'

Hi,

since I am the maintainer of the mentioned mkinitcpio-dkms package and in the same situation, I was thinking about a solution for this problem. There are various threads in the forums discussing it, which recommence to use something like `pacman -Sy linux headers && pacman -Su` for system update. But this approach doesn't feel right to me.
So I came up with the idea of installing the headers within my dkms hook, maybe with check of header and kernel version to match, and put the header package as IgnorePkg in the pacman.conf. But that doesn't look very solid either.
I am curious what others think about this approach. Maybe only as workaround until we get the mentioned post update hooks for pacman. wink

Greetz Corubba

Offline

#10 2013-04-08 08:42:33

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,329
Website

Re: warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst'

How will you install something while pacman has a lock on the database?

Online

#11 2013-04-08 09:13:26

Awebb
Member
Registered: 2010-05-06
Posts: 4,126

Re: warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst'

By manually downloading and extracting the package :-D

Offline

#12 2013-04-08 10:57:38

Corubba
Member
From: Germany
Registered: 2010-11-14
Posts: 80

Re: warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst'

Allan wrote:

How will you install something while pacman has a lock on the database?

Good point, indeed you can't. So the only solution seems to be this wrapper-ish UDF.

Offline

#13 2013-04-08 11:00:41

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,388
Website

Re: warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst'

Or just rebuild the initramfs after the update: `pacman -Syu && mkinitcpio -p linux`


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#14 2013-04-08 12:06:35

Corubba
Member
From: Germany
Registered: 2010-11-14
Posts: 80

Re: warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst'

Trilby wrote:

Or just rebuild the initramfs after the update: `pacman -Syu && mkinitcpio -p linux`

The point is, you need more than one command to update your system including kernel and modules. If you have two pacman calls or one pacman and one mkinitcpio in your UDF doesn't matter here. There should be one command to manage all (except wrapper calls wink ). It may sound stupid but that's what it should be imho. No fancy stuff for non-fancy things.

And like Allan said, post update hooks are planned for quite some time. They will simplify many things. If they come.

That's what I'm using now.

update-yaourt() {
  yaourt --needed -S -y linux-headers
  yaourt -S -u $@ --aur
}

Last edited by Corubba (2013-04-08 12:13:45)

Offline

#15 2013-06-10 03:55:36

savithari
Member
From: Marietta, GA
Registered: 2012-01-28
Posts: 45

Re: warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst'

So the answer is to comment the SyncFirst line then in the /etc/pacman.conf file ?

Offline

#16 2013-06-10 04:03:27

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst'

savithari wrote:

So the answer is to comment the SyncFirst line then in the /etc/pacman.conf file ?

SyncFirst option has been removed https://projects.archlinux.org/pacman.git/tree/NEWS#n27

Offline

Board footer

Powered by FluxBB