You are not logged in.

#1 2013-04-02 10:23:23

D4ve
Member
Registered: 2012-08-02
Posts: 209

[Solved] pacman 4.1 has issues with resolving file-conflicts

Today i wanted to upgrade protobuf-python which will be replaced by python2-protobuf, but pacman ignores the fact, that protobuf-python will be removed:

# pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 community-testing is up to date
 testing is up to date
:: Starting full system upgrade...
warning: pacman: local (4.1.0-1) is newer than core (4.0.3-7)
:: Replace protobuf-python with community/python2-protobuf? [Y/n] 
resolving dependencies...
looking for inter-conflicts...

Packages (20): binutils-2.23.2-1  gcc-4.8.0-1  gcc-libs-4.8.0-1  glibc-2.17-4  libltdl-2.4.2-8  libpulse-3.0-3  libtool-2.4.2-8  libxkbcommon-0.3.0-1  linux-api-headers-3.8.4-1  protobuf-python-2.5.0-1
               protobuf-python-2.5.0-1 [removal]  pulseaudio-3.0-3  python2-dirspec-4.2.0-1  python2-oauthlib-0.4.0-1  python2-protobuf-2.5.0-2  python2-ubuntuone-storageprotocol-4.2.0-1
               ubuntu-sso-client-4.2.0-1  ubuntuone-client-4.2.0-1  ubuntuone-client-gnome-4.2.0-1  ubuntuone-control-panel-4.2.0-1

Total Installed Size:   178.39 MiB
Net Upgrade Size:       6.89 MiB

:: Proceed with installation? [Y/n] 
(19/19) checking keys in keyring                                                                                               [-----------------------------------------------------------------------------] 100%
(19/19) checking package integrity                                                                                             [-----------------------------------------------------------------------------] 100%
(19/19) loading package files                                                                                                  [-----------------------------------------------------------------------------] 100%
(19/19) checking for file conflicts                                                                                            [-----------------------------------------------------------------------------] 100%
error: failed to commit transaction (conflicting files)
/usr/lib/python2.7/site-packages/google/protobuf/__init__.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/__init__.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/compiler/__init__.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/compiler/__init__.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/compiler/plugin_pb2.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/compiler/plugin_pb2.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/descriptor.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/descriptor.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/descriptor_database.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/descriptor_database.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/descriptor_pb2.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/descriptor_pb2.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/descriptor_pool.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/descriptor_pool.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/__init__.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/__init__.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/api_implementation.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/api_implementation.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/containers.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/containers.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/cpp_message.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/cpp_message.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/decoder.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/decoder.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/encoder.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/encoder.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/enum_type_wrapper.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/enum_type_wrapper.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/message_listener.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/message_listener.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/python_message.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/python_message.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/type_checkers.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/type_checkers.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/wire_format.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/internal/wire_format.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/message.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/message.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/message_factory.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/message_factory.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/reflection.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/reflection.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/service.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/service.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/service_reflection.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/service_reflection.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/text_format.py exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/google/protobuf/text_format.pyc exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/protobuf-2.5.0-py2.7-nspkg.pth exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/protobuf-2.5.0-py2.7.egg-info/PKG-INFO exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/protobuf-2.5.0-py2.7.egg-info/SOURCES.txt exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/protobuf-2.5.0-py2.7.egg-info/dependency_links.txt exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/protobuf-2.5.0-py2.7.egg-info/namespace_packages.txt exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/protobuf-2.5.0-py2.7.egg-info/requires.txt exists in both 'python2-protobuf' and 'protobuf-python'
/usr/lib/python2.7/site-packages/protobuf-2.5.0-py2.7.egg-info/top_level.txt exists in both 'python2-protobuf' and 'protobuf-python'
Errors occurred, no packages were upgraded.

Anyone with the same problem here or is it just me?

Btw: If it's a bug: Please fill a bug report, i don't want to register just for 1 bug...

Last edited by D4ve (2013-04-02 11:22:49)

Offline

#2 2013-04-02 10:36:28

foutrelis
Developer/TU
From: Athens, Greece
Registered: 2008-07-28
Posts: 675
Website

Re: [Solved] pacman 4.1 has issues with resolving file-conflicts

This seems like a bug, yes. (Don't be lazy and register for an account on the bug tracker! tongue)

It's worth noting that protobuf-python still exists in the repo; pacman is attempting to both update and replace it, so you get the following targets:

protobuf-python-2.5.0-1
protobuf-python-2.5.0-1 [removal]
python2-protobuf-2.5.0-2

Offline

#3 2013-04-02 10:47:25

D4ve
Member
Registered: 2012-08-02
Posts: 209

Re: [Solved] pacman 4.1 has issues with resolving file-conflicts

Oh, i failed to see that pacman still wants to upgrade the old package (well, because pacman asked if i want to replace it...)

foutrelis wrote:

Don't be lazy and register for an account on the bug tracker!

Ok, if you think it's the right way to register again on something i will only use a few times in my life... smile

EDIT: Bugreport

Last edited by D4ve (2013-04-02 10:58:37)

Offline

#4 2013-04-02 11:06:50

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,358
Website

Re: [Solved] pacman 4.1 has issues with resolving file-conflicts

As I explain in the bug report - this is a packaging bug.

Offline

#5 2013-04-02 11:34:54

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 3,423
Website

Re: [Solved] pacman 4.1 has issues with resolving file-conflicts

D4ve wrote:

Ok, if you think it's the right way to register again on something i will only use a few times in my life...

If you want to receive information about the progress made on the bug and contribute to getting it fixed then, yes, you need to register.

Otherwise, just use bugmenot.com.

Lastly, don't be cheeky. Otherwise, Allan will install a special surprise just for you in pacman.

if (strcmp(username, "D4ve") == 0) {
    set_dependency_for_all_packages("akonadi");
}

Offline

#6 2013-04-02 11:53:51

D4ve
Member
Registered: 2012-08-02
Posts: 209

Re: [Solved] pacman 4.1 has issues with resolving file-conflicts

drcouzelis wrote:

If you want to receive information about the progress made on the bug and contribute to getting it fixed then, yes, you need to register.

Otherwise, just use bugmenot.com.

Too late, i already registered.

drcouzelis wrote:

Lastly, don't be cheeky.

Huh? In the whole discussion i wasn't once cheeky

drcouzelis wrote:

Otherwise, Allan will install a special surprise just for you in pacman.

if (strcmp(username, "D4ve") == 0) {
    set_dependency_for_all_packages("akonadi");
}

That would be awesome. Three lines of code just for me big_smile

(Just for information: I hate gnome-shell for displaying my name in the top right corner so i switched my username to "<*)))><")

Offline

#7 2013-04-02 14:18:04

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 3,423
Website

Re: [Solved] pacman 4.1 has issues with resolving file-conflicts

That's OK. I just like using the word "cheeky". tongue

D4ve wrote:

(Just for information: I hate gnome-shell for displaying my name in the top right corner so i switched my username to "<*)))><")

That might be the craziest username I've ever seen. big_smile

Last edited by drcouzelis (2013-04-02 14:19:01)

Offline

Board footer

Powered by FluxBB