You are not logged in.

#1 2013-04-03 06:12:54

hazard
Member
Registered: 2011-07-04
Posts: 14

[SOLVED] pacman warning message (annoying)

Ran a system upgrade tonight and now anytime I run certain pacman commands such as those containing the -y parameter (pacman -Syu) I receive the following error:

WARNING: Ignoring invalid value 'share' for parameter 'security'

I tried reverting from pacman 4.1.0 to 4.0.3 and tried different pacman.conf but no change. Not sure where the problem is.


It's just annoying, doesn't break anything. Particularly annoying since my AUR helper spits the warning out N times, where N is the number of dependencies.

$ packer -S qlprism-bin
WARNING: Ignoring invalid value 'share' for parameter 'security'
WARNING: Ignoring invalid value 'share' for parameter 'security'
WARNING: Ignoring invalid value 'share' for parameter 'security'
WARNING: Ignoring invalid value 'share' for parameter 'security'

Aur Targets    (2): lib32-libxxf86dga qlprism-bin
Pacman Targets (4): gcc-multilib lib32-gtk2 lib32-libxt xorg-util-macro

Last edited by hazard (2013-04-03 06:44:15)

Offline

#2 2013-04-03 06:35:57

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,437
Website

Re: [SOLVED] pacman warning message (annoying)

That is not a pacman warning...

Offline

#3 2013-04-03 06:36:29

hazard
Member
Registered: 2011-07-04
Posts: 14

Re: [SOLVED] pacman warning message (annoying)

Weird, but I think I've isolated the problem to samba and/or smbclient from [testing] repo.

Downgrading from testing/samba 4.0.4-1 to extra/samba 3.6.13-1 along with testing/smbclient 4.0.4-1 to extra/smbclient 3.6.13-1 seems to be the fix.

Very strange that some components of samba are running every time I use the networking parts of pacman. Possibly a nss misconfiguration or something, hmm.

Offline

#4 2013-04-03 06:43:37

hazard
Member
Registered: 2011-07-04
Posts: 14

Re: [SOLVED] pacman warning message (annoying)

I really need to figure out why a samba error message was being displayed when running pacman...

However in the mean time, I've added samba and smbclient to my IgnorePkg line in pacman.conf, re-enabled the testing repos and marking this thread as solved.

Sorry Allan.

Offline

#5 2013-04-03 06:47:55

foutrelis
Developer/TU
From: Athens, Greece
Registered: 2008-07-28
Posts: 675
Website

Re: [SOLVED] pacman warning message (annoying)

First Google result for "Ignoring invalid value 'share' for parameter 'security'":

http://serverfault.com/questions/470650 … lic-shares

No idea how that makes it through to your terminal, but it appears to be something you can fix.

Offline

#6 2013-04-03 06:51:22

HalosGhost
Member
From: Twin Cities, MN
Registered: 2012-06-22
Posts: 1,486
Website

Re: [SOLVED] pacman warning message (annoying)

Perhaps it is worth noting that you're not running pacman, you're running a pacman wrapper. Do you get the same problem actually running pacman?

All the best,

-HG


"All errors are ᴘᴇʙᴋᴀᴄ errors—It's just a matter of narrowing down which keyboard and chair." -Trilby
\ldots

Offline

#7 2013-04-03 06:54:22

hazard
Member
Registered: 2011-07-04
Posts: 14

Re: [SOLVED] pacman warning message (annoying)

@fourtrelis,

Thanks, that did the trick! Now samba 4.x from testing isn't causing me grief.

I was convinced it was pacman related in someway. I'm still scratching my head as to why the errors were appearing in my terminal.


EDIT:
@ HalosGhost,

# pacman -Syu
:: Synchronizing package databases...
WARNING: Ignoring invalid value 'share' for parameter 'security'
 testing is up to date
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 mate is up to date
:: Starting full system upgrade...
 there is nothing to do

I only mentioned AUR, because the problem was worse (the error would display multiple times) when using an AUR helper, but the problem was occurring when using plain old pacman as well.

Last edited by hazard (2013-04-03 06:57:25)

Offline

Board footer

Powered by FluxBB