You are not logged in.

#1 2013-04-02 22:24:55

fisi
Member
Registered: 2013-04-02
Posts: 11

[gnome 3.6] sound problems

as said in the subject i have some troubles with the audio using gnome 3.6...i don't see the icon in the traybar and volume keys don't work (fn+f11, fn+f12)...how can i solve this problem? with kde always works properly, but with gnome no, why? thanks for your help!

Offline

#2 2013-04-03 02:33:03

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: [gnome 3.6] sound problems

Read this https://wiki.archlinux.org/index.php/PulseAudio for more understanding.


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#3 2013-04-03 10:43:14

fisi
Member
Registered: 2013-04-02
Posts: 11

Re: [gnome 3.6] sound problems

i used the guide linked when i first install pulseaudio, and now i tried to reinstall it, but with no success, my problems still remains...i think there's a dbus problem but i cannot resolve it.

Offline

#4 2013-04-03 15:55:27

chrk
Member
Registered: 2013-04-03
Posts: 2

Re: [gnome 3.6] sound problems

fisi wrote:

i used the guide linked when i first install pulseaudio, and now i tried to reinstall it, but with no success, my problems still remains...i think there's a dbus problem but i cannot resolve it.

Did pulseaudio work in the past?

If yes, have you already tried to reset pulseaudio?

$ rm -rf /tmp/pulse* ~/.pulse*

should do the trick.

Afterwards, restart pulseaudio

Last edited by chrk (2013-04-03 15:58:29)

Offline

#5 2013-04-03 23:02:47

fisi
Member
Registered: 2013-04-02
Posts: 11

Re: [gnome 3.6] sound problems

pulseaudio works with other distros, such as mint, but not with arch...when i try to kill and restart pulseaudio i receive this output:

$ sudo pulseaudio --kill
E: [pulseaudio] main.c: Failed to kill daemon: No such process
$ pulseaudio --start
W: [pulseaudio] core-util.c: Failed to open configuration file '/home/davide/.config/pulse//daemon.conf': Permission denied
W: [pulseaudio] daemon-conf.c: Failed to open configuration file: Permission denied

Offline

#6 2013-04-04 15:05:49

chrk
Member
Registered: 2013-04-03
Posts: 2

Re: [gnome 3.6] sound problems

I don't have a daemon.conf file in my own home directory. The preinstalled default file /etc/pulse/daemon.conf is sufficient for me.

Does pulseaudio have read access to this file?
You could try to rename the file /home/david/.config/pulse/daemon.conf to /home/david/.config/pulse/daemon.conf.bak. Afterwards pulseaudio should use the default configuration file /etc/pulse/daemon.conf . Maybe this will work.

Offline

#7 2013-04-05 20:37:48

fisi
Member
Registered: 2013-04-02
Posts: 11

Re: [gnome 3.6] sound problems

i don't have the file /home/davide/.config/pulse/daemon.cong...is this a problem?

Offline

#8 2013-04-05 21:03:47

bwat47
Member
Registered: 2009-10-07
Posts: 637

Re: [gnome 3.6] sound problems

fisi wrote:

i don't have the file /home/davide/.config/pulse/daemon.cong...is this a problem?

Its should not a problem. I have arch with gnome 3.6 and I don't have that file either, but my audio works totally fine. This just means that pulseaudio should  use the system config file instead (/etc/pulse/daemon.conf)

Its pretty strange that your pulseaudio is trying to access the one in your home dir when it doesn't exist, it should be trying to use the system one in that case.

Last edited by bwat47 (2013-04-05 21:07:12)

Offline

#9 2013-04-05 23:07:26

fisi
Member
Registered: 2013-04-02
Posts: 11

Re: [gnome 3.6] sound problems

furthermore in "System Settings > Sound" there are no outputs available...can you please send/post me your /etc/pulse/.config, so that i can compare it with mine?

Offline

Board footer

Powered by FluxBB