You are not logged in.

#1 2013-04-04 16:10:17

Forest_Leaves
Member
Registered: 2013-03-04
Posts: 4

Chromium-dev build error

I've been trying to figure out what's going wrong when I attempt to build Chromium-dev. I keep getting the same error:

make: *** [out/Release/obj/gen/tc_newlib/lib32/libgles2_implementation_untrusted.a] Error 1

I haven't seen anyone else post about this, so I'm guessing it's a problem on my end.  If someone has an idea how to remedy this error I'd be appreciative.

I'm using Yaourt if that is at all relevant.

Offline

#2 2013-04-04 16:57:06

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: Chromium-dev build error

after installing the dependencies try building Chromium-dev yourselves without yaourt.


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#3 2013-04-04 17:46:50

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,988

Re: Chromium-dev build error

And if you still get the error, post something useful about it. The error happened earlier in the log than that.

Offline

#4 2013-04-04 21:19:48

Forest_Leaves
Member
Registered: 2013-03-04
Posts: 4

Re: Chromium-dev build error

When I just use pkgbuild to build chromium-dev my computer locks up, oddly enough.

Using packer it again failed. I believe this is the error you were looking for?

FAILED with 1: /tmp/packerbuild-1000/chromium-dev/chromium-dev/src/chromium-build/out/Release/obj/gen/sdk/toolchain/linux_x86_newlib/bin/x86_64-nacl-g++ -c command_buffer/client/gles2_implementation.cc -o /tmp/packerbuild-1000/chromium-dev/chromium-dev/src/chromium-build/out/Release/obj.target/gles2_implementation_untrusted/geni/newlib-x86-32/gles2_implementation_untrusted/gles2_implementation.o -MD -MF /tmp/packerbuild-1000/chromium-dev/chromium-dev/src/chromium-build/out/Release/obj.target/gles2_implementation_untrusted/geni/newlib-x86-32/gles2_implementation_untrusted/gles2_implementation.o.d -m32 -mtls-use-call -fomit-frame-pointer -fasynchronous-unwind-tables -O2 -g -Wall -Werror -fdiagnostics-show-option -D__linux__ -D__STDC_LIMIT_MACROS=1 -D__STDC_FORMAT_MACROS=1 -D_GNU_SOURCE=1 -D_BSD_SOURCE=1 -D_POSIX_C_SOURCE=199506 -D_XOPEN_SOURCE=600 -DDYNAMIC_ANNOTATIONS_ENABLED=1 -DDYNAMIC_ANNOTATIONS_PREFIX=NACL_ -DNACL_BUILD_ARCH=x86 -DUSE_SKIA -D_FILE_OFFSET_BITS=64 -DUSE_LINUX_BREAKPAD -DNO_TCMALLOC -DCHROMIUM_BUILD -DUSE_DEFAULT_RENDER_THEME=1 -DUSE_LIBJPEG_TURBO=1 -DUSE_NSS=1 -DENABLE_ONE_CLICK_SIGNIN -DGTK_DISABLE_SINGLE_INCLUDES=1 -DENABLE_REMOTING=1 -DENABLE_WEBRTC=1 -DUSE_PROPRIETARY_CODECS -DENABLE_PEPPER_THREADING -DENABLE_CONFIGURATION_POLICY -DENABLE_INPUT_SPEECH -DENABLE_NOTIFICATIONS -DENABLE_GPU=1 -DENABLE_EGLIMAGE=1 -DENABLE_TASK_MANAGER=1 -DENABLE_EXTENSIONS=1 -DENABLE_PLUGIN_INSTALLATION=1 -DENABLE_PLUGINS=1 -DENABLE_SESSION_SERVICE=1 -DENABLE_THEMES=1 -DENABLE_BACKGROUND=1 -DENABLE_AUTOMATION=1 -DENABLE_GOOGLE_NOW=1 -DENABLE_LANGUAGE_DETECTION=1 -DENABLE_PRINTING=1 -DENABLE_CAPTIVE_PORTAL_DETECTION=1 -DENABLE_MANAGED_USERS=1 -DGLES2_IMPL_IMPLEMENTATION -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -DNACL_WINDOWS=0 -DNACL_OSX=0 -DNACL_LINUX=0 -I/tmp/packerbuild-1000/chromium-dev/chromium-dev/src/chromium-build/out/Release/obj/gen/tc_newlib/include -I.. -I../ppapi -I/tmp/packerbuild-1000/chromium-dev/chromium-dev/src/chromium-build/out/Release/obj/gen/shim_headers/khronos_headers/target -I/tmp/packerbuild-1000/chromium-dev/chromium-dev/src/chromium-build/out/Release/obj/gen/khronos_symlinks -I../gpu -I..

Last edited by Forest_Leaves (2013-04-04 21:20:28)

Offline

#5 2013-04-13 11:28:13

sl1pkn07
Member
From: Spanishtán
Registered: 2010-03-30
Posts: 312

Re: Chromium-dev build error

more error log please

Offline

Board footer

Powered by FluxBB