You are not logged in.

#1 2004-01-11 09:01:52

Guest
Guest

USB hard drive not working

I finally decided to really give Arch Linux a chance and so far my impression of it has been very nice. I am now having problems with my USB hard drive. It has worked on all previous distributions I have used (Slackware, Debian, Gentoo, SuSe). They all detected it as /dev/sda1 as an SCSI device. I used the IDE kernel. Is this why? If so what can I do to make it work? Thanks!  big_smile

#2 2004-01-19 14:39:41

kog
Member
From: Earth/Europe/Poland/Gdynia
Registered: 2003-06-02
Posts: 16
Website

Re: USB hard drive not working

I got Casio Camera, It works as USB-storage and it can be found
as /dev/sda1
Do you have USB-storage modukl in kernel ??
Please try 'modprobe usb-storage', then 'lsmod' to check it is in memmory.
Then try to mount it.


--
Tomasz Bakiera, jabber: kog@jabber.wp.pl
http://www.oxiv.net

Offline

#3 2004-01-19 14:43:42

dariball
Member
From: Germany - Frankfurt
Registered: 2002-10-20
Posts: 118
Website

Re: USB hard drive not working

i don't know exactlly but as a usb device is handled as a scsi device u also have to load sd_mod i guess?!

correct me if i'm wrong...


nothing,
maybe I have a perfect signature _someday_

Offline

#4 2004-01-19 15:07:45

kog
Member
From: Earth/Europe/Poland/Gdynia
Registered: 2003-06-02
Posts: 16
Website

Re: USB hard drive not working

dariball wrote:

i don't know exactlly but as a usb device is handled as a scsi device u also have to load sd_mod i guess?!

correct me if i'm wrong...

I'm not sure about it.
I got CD-RW on IDE and I loading ide-scsi module when system starts. I read somewhere to have ide recorder or usb storage you need to have scsi emulation in the kernel or module. For my box it looks like rest of modules (responsible for USB and my CDRW) are loaded automaticaly. I can't give you results of 'lsmod' now becouse I'm at work.


--
Tomasz Bakiera, jabber: kog@jabber.wp.pl
http://www.oxiv.net

Offline

#5 2004-01-19 15:30:11

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: USB hard drive not working

add to /etc/rc.conf to MODULES this 3 modules to have a external hdd working on usb:

usb-storage sr_mod sd_mod

enjoy


The impossible missions are the only ones which succeed.

Offline

Board footer

Powered by FluxBB