You are not logged in.

#1 2013-04-05 13:14:06

rogorido
Member
Registered: 2009-08-17
Posts: 85

[solved] yaourt not installing after upgrade to pacman 4.1

Yesterday I had to remove yaourt in order to install the last version of pacman.

I'm trying to install yaourt again, but I am getting all the time the following error:

error: package-query: missing required signature
:: File /var/cache/pacman/pkg/package-query-1.2-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: yaourt: missing required signature
:: File /var/cache/pacman/pkg/yaourt-1.2.2-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).

(I have of course removed these packages from /var/cache/...)

Last edited by rogorido (2013-04-05 14:36:34)

Offline

#2 2013-04-05 13:16:57

parazyd
Member
From: Amsterdam
Registered: 2012-10-14
Posts: 259
Website

Re: [solved] yaourt not installing after upgrade to pacman 4.1

Wait for them to update.

Offline

#3 2013-04-05 13:27:18

Spyhawk
Member
Registered: 2006-07-07
Posts: 399

Re: [solved] yaourt not installing after upgrade to pacman 4.1

The above looks more like a signature check problem. The package-query package seems to have been updated in the AUR.
If you are using the [archlinuxfr] repo, simply get the f*** out of this crap remove it and install yaourt/package-query from the AUR.

Offline

#4 2013-04-05 13:27:40

alphaniner
Member
From: Ancapistan
Registered: 2010-07-12
Posts: 2,619

Re: [solved] yaourt not installing after upgrade to pacman 4.1

Take the opportunity to try a different AUR helper. I moved from yaourt to packer a long time ago, and recently moved to cower. Cower is up to date already. And it looks like pacaur is too; it might be a good choice for a yoaurt refugee.


But whether the Constitution really be one thing, or another, this much is certain - that it has either authorized such a government as we have had, or has been powerless to prevent it. In either case, it is unfit to exist.
-Lysander Spooner

Offline

#5 2013-04-05 13:28:04

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,978

Re: [solved] yaourt not installing after upgrade to pacman 4.1

You want yaourt-git and package-query-git I think anyways unless yaourt and package-query have been updated recently.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Online

#6 2013-04-05 14:36:20

rogorido
Member
Registered: 2009-08-17
Posts: 85

Re: [solved] yaourt not installing after upgrade to pacman 4.1

Thansk for your answers and recommendations. I was actually using archlinuxfr. I have installed yaourt directly from AUR and it is working again.

Offline

#7 2013-04-06 08:40:19

toketin
Member
From: Belluno (Italy)
Registered: 2007-04-17
Posts: 317

Re: [solved] yaourt not installing after upgrade to pacman 4.1

You can install yaourt from Archlinuxfr repo commenting this line: SigLevel    = Required DatabaseOptional under /etc/pacman.conf, the problem is that i don't know how safe is this solution because you prevent the sign's control doing so.

Offline

#8 2013-04-06 09:33:12

knedlyk
Member
From: L'viv, Ukraine
Registered: 2009-04-14
Posts: 153
Website

Re: [solved] yaourt not installing after upgrade to pacman 4.1

toketin wrote:

You can install yaourt from Archlinuxfr repo commenting this line: SigLevel    = Required DatabaseOptional under /etc/pacman.conf, the problem is that i don't know how safe is this solution because you prevent the sign's control doing so.

You'd better change Required --> Optional in SigLevel in /etc/pacman.conf.

Last edited by knedlyk (2013-04-06 09:33:45)

Offline

#9 2013-04-06 10:18:32

Spyhawk
Member
Registered: 2006-07-07
Posts: 399

Re: [solved] yaourt not installing after upgrade to pacman 4.1

Or better: Use "SignLevel = never" under the [archlinuxfr] repo only.

Offline

#10 2013-04-06 10:22:14

tuxce
Member
Registered: 2008-02-19
Posts: 56
Website

Re: [solved] yaourt not installing after upgrade to pacman 4.1

@rogorido, [archlinuxfr] is an unsigned repository, you should define it this way :

[archlinuxfr]
SigLevel = Never
Server = http://repo.archlinux.fr/$arch

(And keep the default general SigLevel line for the official repos)

Last edited by tuxce (2013-04-06 11:03:52)

Offline

#11 2013-04-07 13:58:13

felipense
Member
Registered: 2013-04-05
Posts: 62

Re: [solved] yaourt not installing after upgrade to pacman 4.1

just dowload the pkgbulid to an folder and exec "makepkg -s".  and then install the package with "pacman -U  <packagename> "Is not necesary any aur helper...

Last edited by felipense (2013-04-07 13:59:49)

Offline

Board footer

Powered by FluxBB