You are not logged in.

#51 2013-04-05 14:17:54

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 363

Re: [SOLVED] libgl

bumblebee starts the xserver from non-standard paths.

Offline

#52 2013-04-05 15:08:05

Thaodan
Member
From: Dortmund, Nordrein-Westfalen
Registered: 2012-04-28
Posts: 432

Re: [SOLVED] libgl

Yes but it doesn't contains an LibGL from NVIDIA like nvidia-utils-bumblebee did.


Linux odin 3.13.1-pf #1 SMP PREEMPT Wed Mar 5 21:47:28 CET 2014 x86_64 GNU/Linux

Offline

#53 2013-04-05 15:27:16

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 363

Re: [SOLVED] libgl

Of course not because your primary graphics are driven by intel. The symlinks from nvidia-libgl are not needed.

Offline

#54 2013-04-09 07:03:40

Thaodan
Member
From: Dortmund, Nordrein-Westfalen
Registered: 2012-04-28
Posts: 432

Re: [SOLVED] libgl

You're wrong we need a nvidia-libgl-bumblebee see the error when running primusrun:

primus: fatal: failed to load any of the libraries: /usr/$LIB/nvidia-bumblebee/libGL.so.1
/usr/$LIB/nvidia-bumblebee/libGL.so.1: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden

Linux odin 3.13.1-pf #1 SMP PREEMPT Wed Mar 5 21:47:28 CET 2014 x86_64 GNU/Linux

Offline

#55 2013-04-09 08:09:02

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 363

Re: [SOLVED] libgl

It looks like you are still using AUR packages. Reinstall your bumblebee chain.

Offline

#56 2013-04-09 09:33:53

Thaodan
Member
From: Dortmund, Nordrein-Westfalen
Registered: 2012-04-28
Posts: 432

Re: [SOLVED] libgl

A sorry I don't saw that nvidia-utils includes nvidiq's libgl.


Linux odin 3.13.1-pf #1 SMP PREEMPT Wed Mar 5 21:47:28 CET 2014 x86_64 GNU/Linux

Offline

#57 2013-05-30 08:48:21

d3mian88
Member
Registered: 2013-04-28
Posts: 4

Re: [SOLVED] libgl

hi guys.
i have a similar issue when try to upgrade with pacman  -Syu

pacman says:

verificando conflictos...  //conflict checking
error: error al preparar la transacción (no se pudieron satisfacer las dependencias) /
:: linux37-nvidia: necesita/need nvidia-utils=313.18
.
i try with some solutions in this thread but nothing works.

please help, i don't know what to do, i cant upgrade.

Offline

#58 2013-05-30 08:49:21

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 363

Re: [SOLVED] libgl

You are using a deprecated kernel. Use linux, not linux37.

Offline

#59 2013-05-30 10:39:39

d3mian88
Member
Registered: 2013-04-28
Posts: 4

Re: [SOLVED] libgl

Svenstaro wrote:

You are using a deprecated kernel. Use linux, not linux37.

sorry for the question , but ,how i do that, ?

Offline

#60 2013-05-30 10:41:51

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] libgl

d3mian88 wrote:
Svenstaro wrote:

You are using a deprecated kernel. Use linux, not linux37.

sorry for the question , but ,how i do that, ?

Where did you get linux37-nvidia from?

Offline

#61 2013-05-30 10:53:11

d3mian88
Member
Registered: 2013-04-28
Posts: 4

Re: [SOLVED] libgl

from manjaro.

i just intalled and i can't upgrade.

i don't know what to do.

Offline

#62 2013-05-30 10:56:26

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,365
Website

Re: [SOLVED] libgl

d3mian88 wrote:

from manjaro.

i just intalled and i can't upgrade.

i don't know what to do.

Ask on their forums.   You installed Manjaro and not Arch Linux.

Offline

Board footer

Powered by FluxBB