You are not logged in.

#1 2013-04-05 13:33:54

plam
Member
From: Bulgaria
Registered: 2010-03-16
Posts: 37

[WORKAROUND] what controls screen blanking(dpms)?

Hi fellow archers,

I run an updated arch on a lenovo x200s with i3wm and no power-manager, except for laptop-mode-tools. Something keeps turning my screen off when I do not touch anything for 5-10 minutes. I have laptop-mode-tools running, but I disabled the dpms-standby module, with no success. I noticed this behavior right after a fresh install - the screen goes off in 5 minutes, and I haven't installed any packages back then, so I am guessing I will have to edit something in /etc. The really annoying thing is that this sometimes happens when I am watching video(if I start watching the video and don't pause it it won't blank the screen, but if I pause and resume, it will).

I am kindly asking anyone who has a suggestion to say it, even if not sure smile

EDIT: The only thing that prevents the timeouts to go back to the default values is to set a systemd timer which runs every 4 minutes and executes xset dpms 0 0 0

Last edited by plam (2013-04-19 17:05:20)

Offline

#2 2013-04-05 14:16:40

andmars
Member
Registered: 2012-03-13
Posts: 156

Re: [WORKAROUND] what controls screen blanking(dpms)?

put these two lines in your .xinitrc

xset -dpms
xset s off

Last edited by andmars (2013-04-05 14:18:05)

Offline

#3 2013-04-05 15:35:39

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: [WORKAROUND] what controls screen blanking(dpms)?

Offline

#4 2013-04-05 16:42:53

plam
Member
From: Bulgaria
Registered: 2010-03-16
Posts: 37

Re: [WORKAROUND] what controls screen blanking(dpms)?

@andmars: I did this, but it does not work for some reason.

@karol: I have indeed, but none of the commands there seem to have any effect. For instance I have xset -dpms and
xset s off in my .xinitrc, but xset q still shows dpms as active. I now typed xset -dpms in terminal, and it seems to have disabled dpms, but I think that the line being present in .xinitrc should have worked as well.

By the way the last lines from dmesg right after the display turned off were:
[ 7262.133076] uhci_hcd 0000:00:1a.0: power state changed by ACPI to D2
[ 7262.141235] uhci_hcd 0000:00:1a.2: power state changed by ACPI to D2
[ 7262.145357] uhci_hcd 0000:00:1d.0: power state changed by ACPI to D2
[ 7264.366250] ehci-pci 0000:00:1a.7: power state changed by ACPI to D3cold
maybe acpi is doing something?

Offline

#5 2013-04-05 17:17:58

plam
Member
From: Bulgaria
Registered: 2010-03-16
Posts: 37

Re: [WORKAROUND] what controls screen blanking(dpms)?

The only thing that seems to work is creating a /etc/X11/xorg.conf.d/10-monitor.conf with:

Section "ServerLayout"
    Identifier "ServerLayout0"
    Option "BlankTime"  "0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"
EndSection

Offline

#6 2013-04-05 17:57:33

root
Member
From: 127.0.0.1
Registered: 2012-04-13
Posts: 297

Re: [WORKAROUND] what controls screen blanking(dpms)?

As far as I am concerned I am using it in my openbox autostart file (only the xset s off option) and it works like a charm.

Did you log out and in again after applying the changes to your .xinitrc file?


\(o_X)/
                        'Cause I wanna be an Archy - An Archy in the UK // Sex Pistols

Offline

#7 2013-04-05 18:23:46

plam
Member
From: Bulgaria
Registered: 2010-03-16
Posts: 37

Re: [WORKAROUND] what controls screen blanking(dpms)?

I even rebooted, just to be sure. It works after the reboot, but as soon as I blank the screen myself(xset dpms force off) and move  my mouse to wake the display up, dpms gets turned on. xorg.conf works after turning the display on and off, so I'll be using that.

Offline

#8 2013-04-07 09:42:52

plam
Member
From: Bulgaria
Registered: 2010-03-16
Posts: 37

Re: [WORKAROUND] what controls screen blanking(dpms)?

plam wrote:

The only thing that seems to work is creating a /etc/X11/xorg.conf.d/10-monitor.conf with:

Section "ServerLayout"
    Identifier "ServerLayout0"
    Option "BlankTime"  "0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"
EndSection

Actually this also does not work consistently. Last night I was watching something, and the screen went off again. I checked the output of 'xset q', and it was back to the default 300/310/320 secs for standby/suspend/off. Now I checked it again and it is 1200/1500/1800, which is strange, because I have not entered these values, and they do not come as a default. I have not installed any DE on this machine ever, so this is not ruins of gnome or xfce taking over power management.

I really tried to figure out what sets these timeouts, but I have absolutely no idea. I think that this is not a feature, but rather a bug, since it can not be controlled.

Last edited by plam (2013-04-07 09:44:28)

Offline

#9 2013-04-15 12:52:58

plam
Member
From: Bulgaria
Registered: 2010-03-16
Posts: 37

Re: [WORKAROUND] what controls screen blanking(dpms)?

After some playing around I found out that the timeouts change when I plug in/out the charger, but I can't seem to find the file that does this. Anyone has any suggestions?

Offline

#10 2013-04-15 16:19:14

cookies
Member
Registered: 2013-01-17
Posts: 253

Re: [WORKAROUND] what controls screen blanking(dpms)?

Sounds like laptop-mode-tools (it's screwing around with my brightness, whenever I connect or disconnect AC; doesn't annoy me enough yet to change it though). Take a look at /etc/laptop-mode/conf.d/dpms-standy.conf

Offline

#11 2013-04-15 21:28:58

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,057
Website

Re: [WORKAROUND] what controls screen blanking(dpms)?

In my case the xset configuration is reset when i use suspend on the laptop. Any chance that is the case here?

Offline

#12 2013-04-16 07:48:52

plam
Member
From: Bulgaria
Registered: 2010-03-16
Posts: 37

Re: [WORKAROUND] what controls screen blanking(dpms)?

@cookies: I tried CONTROL_DPMS_STANDBY=0, and I also tried CONTROL_DPMS_STANDBY=1 and set all the timeouts to 0 in the file, but timeouts still change when I plug in/out the charger anyway.

@teateawhy: I created /usr/lib/systemd/system-sleep/dpms with su sxdw -c "DISPLAY=:0 xset dpms 0 0 0" and it works, but still after I plug in/out the charger the timeouts are reset.

Offline

#13 2013-04-16 08:17:37

skanky
Member
From: WAIS
Registered: 2009-10-23
Posts: 1,838

Re: [WORKAROUND] what controls screen blanking(dpms)?

I don't use them any more (and it's been a while), but IIRC there are two levels of laptop mode tools config. There's the main conf file, and the area specific conf file. You might want to look at both.
Also, check other display related files, eg terminal-blanking.conf


"...one cannot be angry when one looks at a penguin."  - John Ruskin
"Life in general is a bit shit, and so too is the internet. And that's all there is." - scepticisle

Offline

#14 2013-04-19 17:04:05

plam
Member
From: Bulgaria
Registered: 2010-03-16
Posts: 37

Re: [WORKAROUND] what controls screen blanking(dpms)?

I tried any possible configuration of all the laptop-mode files that may have something to do with turning off the screen, but nothing helps. The only solution that works in keeping my screen on is to make a systemd timer which runs every 4 minutes and executes xset dpms 0 0 0.

Offline

#15 2013-04-26 10:03:41

Hacksign
Member
Registered: 2012-07-30
Posts: 68

Re: [WORKAROUND] what controls screen blanking(dpms)?

plam wrote:

I tried any possible configuration of all the laptop-mode files that may have something to do with turning off the screen, but nothing helps. The only solution that works in keeping my screen on is to make a systemd timer which runs every 4 minutes and executes xset dpms 0 0 0.

I'm using a PC.
the situation is same to u

set ServerLayout is useless ...

Offline

Board footer

Powered by FluxBB