You are not logged in.

#1 2013-01-07 16:16:22

awesome_welles
Member
Registered: 2008-12-12
Posts: 25

Unable to get sound working with ALSA

Fresh install on a desktop computer.

.asoundrc is empty

$ alsactl init
Found hardware: "HDA-Intel" "Realtek ALC880" "HDA:10ec0880,08600000,00090000" "0x107b" "0x4040"
Hardware is initialized using a generic method
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
$ lsmod | grep '^snd' | column -t
snd_hda_codec_realtek  52472  1
snd_hda_intel          22257  0
snd_hda_codec          83678  2  snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              4843   1  snd_hda_codec
snd_pcm                61958  2  snd_hda_codec,snd_hda_intel
snd_page_alloc         5902   2  snd_pcm,snd_hda_intel
snd_timer              14903  1  snd_pcm
snd                    45098  6  snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_pcm,snd_hda_codec,snd_hda_intel
$ ls -l /dev/snd
total 0
drwxr-xr-x  2 root root       60 Jan  7 15:56 by-path
crw-rw----+ 1 root audio 116,  3 Jan  7 15:56 controlC0
crw-rw----+ 1 root audio 116,  2 Jan  7 15:56 hwC0D2
crw-rw----  1 root audio 116,  1 Jan  7 15:56 seq
crw-rw----+ 1 root audio 116, 33 Jan  7 15:56 timer
$ speaker-test

speaker-test 1.0.26

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
Playback open error: -2,No such file or directory

Have been looking at the wiki but struggling to find out why no playback devices are listed. Any help greatly appreciated.

Offline

#2 2013-01-07 17:13:25

Kubouch
Member
From: Czech Republic
Registered: 2013-01-03
Posts: 25

Re: Unable to get sound working with ALSA

I'm also solving audio issue so you might look at this thread: https://bbs.archlinux.org/viewtopic.php?id=155603.

Maybe you need to specify your default sound card. This can be done by editing your ~/.asoundrc file (if you don't have any, create one) according to this page: https://wiki.archlinux.org/index.php/Al … sound_card. The easy way to check which card is default you can use alsamixer (you might need to install it). There you press F6, scroll to '(default)' and press Enter. It should jump you into the configuration of your default sound card. This one kinda doesn't work for me, though :-D.

Speaking of alsamixer, you could also try to unmute your channels. Just open alsamixer and keep pressing 'M' on the channels to toggle mute/unmute. If channel is muted it shows 'MM' under it. If it is unmuted it shows '00'. You scroll between channels by pressing right and left arrows.

Please bear in mind that I'm Arch beginner and try to look at wiki as much as possible.

Cheers,
Kubouch

Offline

#3 2013-01-08 16:48:50

awesome_welles
Member
Registered: 2008-12-12
Posts: 25

Re: Unable to get sound working with ALSA

Thanks for the reply. Have already tried that though. I think my problem must be to do with the fact that "aplay -l" returns no devices!

Offline

#4 2013-01-08 17:16:19

chris_l
Member
Registered: 2010-12-01
Posts: 387

Re: Unable to get sound working with ALSA

are you on the audio group? can you play from root?


"open source is about choice"
No.
Open source is about opening the source code complying with this conditions, period. The ability to choose among several packages is just a nice side effect.

Offline

#5 2013-01-08 18:01:10

awesome_welles
Member
Registered: 2008-12-12
Posts: 25

Re: Unable to get sound working with ALSA

Thanks for the reply Chris. No I have not been able to play audio from root either. "speaker-test" give this output from root and my login also:

speaker-test 1.0.26

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
Playback open error: -2,No such file or directory

Neither my account nor the root account were members of the "audio" group but after adding them with "gpasswd" it seems to have made no difference.

Is there perhaps a kernel module I need to load?

Offline

#6 2013-01-08 18:50:58

Kubouch
Member
From: Czech Republic
Registered: 2013-01-03
Posts: 25

Re: Unable to get sound working with ALSA

awesome_welles wrote:

Thanks for the reply. Have already tried that though. I think my problem must be to do with the fact that "aplay -l" returns no devices!

Oh, that's it. The last thing I can think about is to make sure the device is enabled in BIOS. I have an option to disable my sound card in BIOS and I used it for some time.

Offline

#7 2013-01-09 11:22:59

awesome_welles
Member
Registered: 2008-12-12
Posts: 25

Re: Unable to get sound working with ALSA

Nope it is enabled in the BIOS. I think it might be a kernel module that needs to be loaded.

Offline

#8 2013-01-09 15:54:22

chris_l
Member
Registered: 2010-12-01
Posts: 387

Re: Unable to get sound working with ALSA

I would boot from several livecds to check if one of them gives me sound. If one give me sound, then I'll check the uploaded modules (with lsmod, btw)

But first, whats the output of your lspci ?


"open source is about choice"
No.
Open source is about opening the source code complying with this conditions, period. The ability to choose among several packages is just a nice side effect.

Offline

#9 2013-01-09 16:00:08

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,766
Website

Re: Unable to get sound working with ALSA

What do you get from `lsmod | grep snd`?


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#10 2013-01-09 21:35:54

awesome_welles
Member
Registered: 2008-12-12
Posts: 25

Re: Unable to get sound working with ALSA

Thanks for the suggestion Chris, unfortunately I don't have any live CDs to hand. I'll root around and see if I can find one, would an old ubuntu disc work even though they are different kernel versions?


$ lspci
00:00.0 Host bridge: Intel Corporation 82915G/P/GV/GL/PL/910GL Memory Controller Hub (rev 04)
00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Integrated Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corporation 82915G Integrated Graphics Controller (rev 04)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 04)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 (rev 04)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 3 (rev 04)
00:1c.3 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 4 (rev 04)
00:1d.0 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 04)
00:1d.1 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 04)
00:1d.2 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 04)
00:1d.3 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 04)
00:1d.7 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d4)
00:1f.0 ISA bridge: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface Bridge (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 04)
00:1f.2 IDE interface: Intel Corporation 82801FB/FW (ICH6/ICH6W) SATA Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 04)
05:01.0 Modem: Smart Link Ltd. SmartLink SmartPCI562 56K Modem (rev 04)
05:05.0 FireWire (IEEE 1394): LSI Corporation FW322/323 [TrueFire] 1394a Controller (rev 61)
05:08.0 Ethernet controller: Intel Corporation 82562ET/EZ/GT/GZ - PRO/100 VE (LOM) Ethernet Controller (rev 04)
$ lsmod | grep snd
snd_hda_codec_realtek    52472  1 
snd_hda_intel          22257  0 
snd_hda_codec          83678  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               4843  1 snd_hda_codec
snd_pcm                61958  2 snd_hda_codec,snd_hda_intel
snd_page_alloc          5902  2 snd_pcm,snd_hda_intel
snd_timer              14903  1 snd_pcm
snd                    45098  6 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_pcm,snd_hda_codec,snd_hda_intel
soundcore               4379  1 snd

Offline

#11 2013-01-09 22:06:07

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,766
Website

Re: Unable to get sound working with ALSA

It looks like all the right modules are loaded, so that should not be the issue.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#12 2013-01-16 09:12:16

fivedigits
Member
Registered: 2012-12-12
Posts: 13

Re: Unable to get sound working with ALSA

A year ago i had similar problems with a realtek card, i don't exactly know how to solve your problem, but for me editing /etc/modprobe.d/alsa-base.conf and making sure the card grabs the right slot worked.

Offline

#13 2013-04-05 18:14:15

awesome_welles
Member
Registered: 2008-12-12
Posts: 25

Re: Unable to get sound working with ALSA

Sorry to dig this thread up again but I still haven't been able to solve the problem. Could you please elaborate fivedigits? I don't seem to have an alsa-base cofig file!

Offline

#14 2013-04-05 19:03:13

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,766
Website

Re: Unable to get sound working with ALSA

You create that file yourself.  See here for details.

I have never had to do this myself, but that is what fivedigits is referring to.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#15 2013-06-19 05:45:30

useraddition
Member
Registered: 2013-06-07
Posts: 47

Re: Unable to get sound working with ALSA

Try this:

vim /etc/asound.conf

pcm.!default {
  type hw
  card 0
  device 1
}

That worked for me on the error: ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave

Offline

Board footer

Powered by FluxBB