You are not logged in.

#1 2013-04-06 20:33:45

mathben
Member
Registered: 2013-04-06
Posts: 7

[Solved]Upgrade pacman 4.1 - no usable package repositories configured

Hi, i am another guy who fail with upgrade pacman 4.1

I has pacman 4.0.3-7 and for some dependancy (like yaourt), i need pacman 4.1
He wasn't in system update, so i download it from git : git clone git://projects.archlinux.org/pacman.git pacman

sh ./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-doc
make -j8
sudo make install

And now, i got this error

sudo pacman -Syu

error: no usable package repositories configured.

I backup my /etc/pacman.conf and use the new one like this topic : https://bbs.archlinux.org/viewtopic.php … 7#p1254497

I check the version :

Pacman v4.1.0 - libalpm v8.0.0

I try to upgrade my DB

sudo /usr/local/bin/pacman-db-upgrade

==> ERROR: /usr/local/var/lib/pacman/ is not a pacman database directory.

The only solution i found right now is reinstalling arch linux o.0
Thanks for you help.

Last edited by mathben (2013-04-06 22:56:39)

Offline

#2 2013-04-06 20:40:17

progandy
Member
Registered: 2012-05-17
Posts: 2,152

Re: [Solved]Upgrade pacman 4.1 - no usable package repositories configured

You have really not done the most intelligent thing. NEVER install an essential application without a package or at least a PKGBUILD and makepkg. I suggest you issue a make uninstall if that works.
Then download the pacman package manually from a mirror (pacman 4.1 is in core) and extract it to your root (make a backup of your pacman.conf first and then restore it)
Update your database and reinstall pacman (pacman -Sy pacman), maybe you need --force
Perform a normal system updgrade.
But be careful, this could also result in more problems instead of helping though I doubt it. I won't be held liable for further problems, though.

Last edited by progandy (2013-04-06 20:42:46)

Offline

#3 2013-04-06 20:50:15

mathben
Member
Registered: 2013-04-06
Posts: 7

Re: [Solved]Upgrade pacman 4.1 - no usable package repositories configured

I uninstall it.
Download from https://www.archlinux.org/packages/core/x86_64/pacman/
Extract it : sudo tar xvf pacman-4.1.0-2-x86_64.pkg.tar.xz -C /

sudo pacman --force -Sy  pacman
error: no usable package repositories configured.

Offline

#4 2013-04-06 20:56:00

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 5,810
Website

Re: [Solved]Upgrade pacman 4.1 - no usable package repositories configured

mathben wrote:

I has pacman 4.0.3-7 and for some dependancy (like yaourt), i need pacman 4.1
He wasn't in system update, so i download it from git : git clone git://projects.archlinux.org/pacman.git pacman

sh ./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-doc
make -j8
sudo make install

Why would you do that? Why would you not use pacman to upgrade/install pacman, or any other package for that matter?

Honestly, this was such a bad idea that I'm finding it difficult to keep myself from berating you with inappropriate language (some of which I instinctively blurted out when I read your post).

mathben wrote:

I try to upgrade my DB

sudo /usr/local/bin/pacman-db-upgrade

==> ERROR: /usr/local/var/lib/pacman/ is not a pacman database directory.

pacman-db-upgrade is a transition tool to convert pacman 3.x databases to pacman 4.x databases. Is there some guide that told you to use that to update the database?



I pride myself on trying to be helpful on the forum, but you do not seem to have any idea of how package management works on Arch Linux. This is all covered in the wiki and on the forum. I really do not mean to be rude, but I believe that you would be better off with something else as you seem to just be naively trying random shit.


If you really want to clean up the mess that you've made, uninstall the manually installed pacman, remove whatever AUR apps you have installed that prevent you from upgrading via pacman, then rebuild and re-install those apps after the upgrade.

I also suspect that you are using Archbang or some other distro given that you seem to be new to the distro yet already have yaourt installed. If this is the case then you should direct yourself to their forum. This forum is for Arch Linux.

Offline

#5 2013-04-06 20:58:23

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 5,810
Website

Re: [Solved]Upgrade pacman 4.1 - no usable package repositories configured

mathben wrote:

I uninstall it.
Download from https://www.archlinux.org/packages/core/x86_64/pacman/
Extract it : sudo tar xvf pacman-4.1.0-2-x86_64.pkg.tar.xz -C /

sudo pacman --force -Sy  pacman
error: no usable package repositories configured.

Wtf is wrong with you? Why are you extracting the package manually? Why are you forcing an upgrade? Why are you running "-Sy" without "-u"?

The skin on my face has just peeled off from the force of a thousand facepalms.

Offline

#6 2013-04-06 22:31:19

mcmillan
Member
Registered: 2006-04-06
Posts: 703

Re: [Solved]Upgrade pacman 4.1 - no usable package repositories configured

Since nobody has suggested the most obvious thing based on that error, do you actually have any repositories configured in /etc/pacman.d/mirrorlist?

I suspect since you tried installing things outside of a proper package you ended up overwriting those with the default (which is entirely commented out), and you only mentioned restoring pacman.conf.

I will also second the people wondering why you were approaching this problem they way you did, while clearly not understanding what you were actually doing.

Offline

#7 2013-04-06 22:55:42

mathben
Member
Registered: 2013-04-06
Posts: 7

Re: [Solved]Upgrade pacman 4.1 - no usable package repositories configured

I finally fix the problem.

I download my last version of pacman ftp://ftp.archlinux.org/other/pacman/pa … 0.3.tar.gz

sudo tar xvf pacman-4.0.3-7-x86_64.pkg.tar.xz -C /

Now, i want to update DDB.

sudo pacman -Syu

I have error
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: package-query: requires pacman<4.1

I uninstall yaourt and package-query.
sudo pacman -R package-query yaourt

Update pacman
sudo pacman --force -S pacman
Need to force after my newbie manipulation...

I reinstall yaourt and package-query.

Problem solved, thanks for you positive comments.

Xyne wrote:

I also suspect that you are using Archbang or some other distro given that you seem to be new to the distro yet already have yaourt installed. If this is the case then you should direct yourself to their forum. This forum is for Arch Linux.

I installed Arch Linux from scratch two months ago with the guide Beginners_guide .

On the beginning, i try to update pacman with

pacman -Syu

It didn't upgrade to last release version, I suspected mirror, but I prefer to compile it. Finally, it's not a good method I see sad

Offline

#8 2013-04-06 23:36:03

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 5,810
Website

Re: [Solved]Upgrade pacman 4.1 - no usable package repositories configured

mathben wrote:

On the beginning, i try to update pacman with

pacman -Syu

It didn't upgrade to last release version, I suspected mirror, but I prefer to compile it. Finally, it's not a good method I see sad

In the future, when something doesn't work, check the forum and the news on the front page ("Home" link at the top of the page).

You should also read about PKGBUILDs and how to create your own packages for pacman.

Offline

Board footer

Powered by FluxBB