You are not logged in.

#1 2013-04-06 20:21:40

Registered: 2013-04-06
Posts: 2

Boot fails during installation from usb on a transmeta crusoe

the mission:
I'm trying to install arch on a HP t5300 computer running a transmeta cruose cpu.

what did I do before the problem occur:
I got the installation image onto a thumbrive following the wiki instructions.

the problem:
when choosing to boot to arch from the boot menu, the process get stuck at the beginning with a TSC calibration error and the computer stays hanging there, keyboard doesn't work.

Any idea how to fix this ? Also is there some documentation for installing arch on a transmeta I missed or should I simply refer to the regular wiki entry for installing arch ?


#2 2013-04-06 21:00:38

Registered: 2013-02-22
Posts: 262

Re: Boot fails during installation from usb on a transmeta crusoe

Actually for what i've read arround is that, because transmeta crusoe cpu is a i586 cpu it should not be compatible with latest arch because they removed all arquitectures older that i686 from kernel.

But there is also information that a patch appeard to linux kernel, that made possible it's use, by kind of turning it into a i686. There is also an information that it was added to the official archlinux kernel, but i really don't know if it still remanes.

Read these pages that may help you with dealing with your problem … -full-i686

Last edited by s1ln7m4s7r (2013-04-06 21:01:11)


#3 2013-04-06 22:56:48

Registered: 2013-04-06
Posts: 2

Re: Boot fails during installation from usb on a transmeta crusoe

Thanks for your answer, unfortunately already found and read those links. From reading synthead comment and I couldn't find more recent information of current status of transmeta support in arch, I understand the stock arch runs on transmeta crusoe:

synthead  7 months ago

The stock Arch kernel and glibc run on the Transmeta Crusoe CPU without any problems now. If you're running into difficulty, don't hesitate to say something on freenode-dot-net's #archlinux or post a thread on bbs-dot-archlinux-dot-org (what is up with YouTube blocking links?).

From what I gather TSC is a register where cpu since pentiums store the number of clock cycles since it powered up and fast tsc calibration is used during the cpu identification/autoconfiguration step of the boot process or something.

The only things I could try is kernel parameters, I found a suggestion to use clocksource=apci_pm but it didn't help.

going through kernel parameters at … meters.txt I noticed this, i'll give it a try.

tsc=        Disable clocksource stability checks for TSC.
            Format: <string>
            [x86] reliable: mark tsc clocksource as reliable, this
            disables clocksource verification at runtime, as well
            as the stability checks done at bootup.    Used to enable
            high-resolution timer mode on older hardware, and in
            virtualized environment.

Trying tsc=reliable and notsc kernel parameters brought no change to the situation.

Last edited by sonofrobin (2013-04-07 00:48:22)


#4 2013-11-14 04:27:55

Registered: 2013-11-13
Posts: 4

Re: Boot fails during installation from usb on a transmeta crusoe

SImilar issue perhaps?  Trying to install via usb to an HD though.  Replaced the flash DOM with an ATA HD.  Fast TSC fails, but boot continues until it mounts the cowspace and then it hooks right into 'Bailing out'.  Same thin client, 256MB RAM.

Last edited by DannyIkard (2013-11-14 04:35:45)


Board footer

Powered by FluxBB