You are not logged in.

#1 2013-04-07 05:37:48

Opanos
Member
Registered: 2012-09-16
Posts: 42

[Solved]armh [for Arch Rollback Machine]: warning output messages

Hi guys,
today -for learning reasons and to get familiar with- i tried the suggested from arm page:

armh --search vlc --color --table

the output is

[root@arch panos]# armh --search vlc --color --table
/usr/lib/python3.3/site-packages/pycman/config.py:130: InvalidSyntax: unable to parse /etc/pacman.conf, unrecognized option: 'Color'
  warnings.warn(InvalidSyntax(f.name, 'unrecognized option', key))
/usr/lib/python3.3/site-packages/pycman/config.py:125: InvalidSyntax: unable to parse /etc/pacman.conf, unrecognized option: 'LocalFileSigLevel'
  warnings.warn(InvalidSyntax(f.name, 'unrecognized option', key))

The armh command works fine 5-6 days before.
Both dependencies are present.

My pacman.conf

#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
HoldPkg     = pacman glibc
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =


#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
Color
#TotalDownload
CheckSpace
#VerbosePkgLists

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`

Since i am prety sure that i dont edit pacman.conf in order to use armh at first,
is it something that i miss with the latest pacman's update?
Thank you,

Last edited by Opanos (2013-04-07 09:50:49)

Offline

#2 2013-04-07 08:46:39

illusionist
Member
From: localhost
Registered: 2012-04-03
Posts: 498

Re: [Solved]armh [for Arch Rollback Machine]: warning output messages

You should describe what is 'armh' first. Otherwise some people may think it is something related to arm architecture.
Second the error you are getting, can not be clear than what it is right now. All the problem clearly described there. Since the pacman update, there are some new options introduced in the pacman.conf file which armh is not aware of. That is why it is throwing these errors. Either comment those options it the pacman.conf file or update your armh to the newer version if availabe.


  Never argue with stupid people,They will drag you down to their level and then beat you with experience.--Mark Twain
@github

Offline

#3 2013-04-07 09:45:13

Opanos
Member
Registered: 2012-09-16
Posts: 42

Re: [Solved]armh [for Arch Rollback Machine]: warning output messages

Sorry,
One can use it to handle ARM, for downgrading packages that are not locally exist.

http://xyne.archlinux.ca/projects/armh/

Can be installed from AUR.

As i mentioned, i don't edit the pacman.conf file due to use it at first place and those messages, are not exist.
All though, the behavior is what i expect -the output is what i am looking for- my concern is about these messages.
If i can safely ignored them or not.
There is no armh update at the moment.
it's the first that i check.
Yes, if i put a comment at the proper lines of pacman.conf those messages will disappear.
So i am pretty sure that i can safely ignore them.

Thank you,

Last edited by Opanos (2013-04-07 09:52:09)

Offline

#4 2013-04-07 10:28:27

karol
Archivist
Registered: 2009-05-06
Posts: 25,431

Re: [Solved]armh [for Arch Rollback Machine]: warning output messages

As illusionist wrote, maybe armh doesn't currently work with pacman 4.1. You can always ask in the armh thread: https://bbs.archlinux.org/viewtopic.php?id=145517

In the future, if you're using [testing] repo, please post in the testing forum: https://bbs.archlinux.org/viewforum.php?id=49

Offline

#5 2013-04-07 12:52:54

Opanos
Member
Registered: 2012-09-16
Posts: 42

Re: [Solved]armh [for Arch Rollback Machine]: warning output messages

Thanks, but i am not even imply that i am using [testing]

And in fact, i don't.

Offline

#6 2013-04-07 18:42:12

karol
Archivist
Registered: 2009-05-06
Posts: 25,431

Re: [Solved]armh [for Arch Rollback Machine]: warning output messages

Sorry, I somehow missed pacman 4.1 being moved to [core].


To make it easier for anyone who's interested in this issue: Opanos followed Xyne's suggestion and opened a bug report: https://bugs.archlinux.org/task/34659

Offline

Board footer

Powered by FluxBB