You are not logged in.

#1 2013-04-07 11:41:20

eherranzr
Member
Registered: 2011-06-28
Posts: 112

Not updating or installing

Hi guys!

After reading for a while about the qt upgrade I'm unable to save some problems I have with pacman

I want to install inkscape so:

LC_ALL=C sudo pacman -S inkscape
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: poppler-qt: requires poppler=0.22.1

As it failed I tried to upgrade first the whole system but there's another error:

LC_ALL=C sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 archlinuxfr is up to date
:: Starting full system upgrade...
:: Replace kdesdk-kioslave with extra/kdesdk-kioslaves? [Y/n] Y
:: Replace kdesdk-kmtrace with extra/kdesdk-dev-utils? [Y/n] Y
:: Replace kdesdk-kpartloader with extra/kdesdk-dev-utils? [Y/n] Y
:: Replace kdesdk-kprofilemethod with extra/kdesdk-dev-utils? [Y/n] Y
:: Replace kdesdk-kstartperf with extra/kdesdk-dev-utils? [Y/n] Y
:: Replace kdesdk-kuiviewer with extra/kdesdk-dev-utils? [Y/n] Y
:: Replace kdesdk-scripts with extra/kdesdk-dev-scripts? [Y/n] Y
:: Replace kdesdk-strigi-analyzer with extra/kdesdk-strigi-analyzers? [Y/n] Y
:: Replace khrplatform-devel with extra/mesa? [Y/n] Y
:: Replace lib32-libgl with multilib/lib32-mesa-libgl? [Y/n] Y
:: Replace lib32-libglapi with multilib/lib32-mesa? [Y/n] Y
:: Replace lib32-qt with multilib/lib32-qt4? [Y/n] Y
:: Replace libegl with extra/mesa? [Y/n] Y
:: Replace libgbm with extra/mesa? [Y/n] Y
:: Replace libgl with extra/mesa-libgl? [Y/n] Y
:: Replace libglapi with extra/mesa? [Y/n] Y
:: Replace libgles with extra/mesa? [Y/n] Y
:: Replace ntfsprogs with extra/ntfs-3g? [Y/n] Y
:: Replace qt with extra/qt4? [Y/n] Y
resolving dependencies...
warning: dependency cycle detected:
warning: lib32-gcc-libs will be installed before its gcc-libs-multilib dependency
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: makemkv: requires qt
:: smplayer-svn: requires qt
:: tsmuxer-gui: requires lib32-qt

Any solution?
I've read a lot about the update but I can't find a solution

Thanks

Regards

Offline

#2 2013-04-07 11:55:41

mar04
Member
From: Poland
Registered: 2010-02-08
Posts: 116

Re: Not updating or installing

pacman -R makemkv smplayer-svn tsmuxer-gui
pacman -Syu

and reinstall your AUR packages.

Offline

#3 2013-04-07 12:51:57

eherranzr
Member
Registered: 2011-06-28
Posts: 112

Re: Not updating or installing

mar04 wrote:
pacman -R makemkv smplayer-svn tsmuxer-gui
pacman -Syu

and reinstall your AUR packages.

Thanks!
It seems to work

Last edited by eherranzr (2013-04-07 13:42:42)

Offline

Board footer

Powered by FluxBB