You are not logged in.

#1 2013-04-07 13:56:01

Registered: 2011-08-09
Posts: 57

acpi_call-git and latest kernel upgrade


as you could see reading comments on the acpi_call-git AUR package page, acpi_call-git package is not ready for the latest kernel upgrade.

The fix proposed doesn't work for me, I still get:

==> Checkout completed
make -C /usr/lib/modules/3.8.5-1-ARCH/build M=/home/enrico/acpi_call-git/src/acpi_call-build modules
make[1]: Entering directory `/usr/src/linux-3.8.5-1-ARCH'
CC [M] /home/enrico/acpi_call-git/src/acpi_call-build/acpi_call.o
In file included from include/linux/cache.h:4:0,
from include/linux/time.h:4,
from include/linux/stat.h:18,
from include/linux/module.h:10,
from /home/enrico/acpi_call-git/src/acpi_call-build/acpi_call.c:3:
/home/enrico/acpi_call-git/src/acpi_call-build/acpi_call.c: In function ‘acpi_result_to_
include/linux/kernel.h:595:17: warning: comparison of distinct pointer types lacks a cas
(void) (&_min1 == &_min2); \
/home/enrico/acpi_call-git/src/acpi_call-build/acpi_call.c:48:27: note: in expansion of
int show_values = min(result->buffer.length, get_avail_bytes() / 6);
Building modules, stage 2.
MODPOST 1 modules
CC /home/enrico/acpi_call-git/src/acpi_call-build/acpi_call.mod.o
LD [M] /home/enrico/acpi_call-git/src/acpi_call-build/acpi_call.ko
make[1]: Leaving directory `/usr/src/linux-3.8.5-1-ARCH'
==> Entering fakeroot environment...

any idea on how to fix this?

many thanks!



#2 2013-04-18 07:30:08

Registered: 2013-04-11
Posts: 13

Re: acpi_call-git and latest kernel upgrade

same problem here.
I 've edited the PKGBUILD git repo with dkao's repo he fixed the build with this commit: … dccd49caef
Now the module builds, but...

I think the pkgbuild in a bad shape, it isn't installing the kernel module.
I've tried a manual insmod and depmod -a with no luck.
Did something has changed with the module installation procedure using kmod? modules has to be signed or gz compressed?


well I've succeeded.
1) modify git repo to dkao's in git url
2) go to /tmp/yaourt-tmp-user/aur-acpi_call-git/src/acpi_call-build (before merging the package)
3) make install
4) depmod -a

Last edited by parad0x (2013-04-18 07:39:15)


Board footer

Powered by FluxBB