You are not logged in.

#1 2013-04-01 14:02:49

Boogie
Member
Registered: 2012-06-17
Posts: 27

Pacman 4.1 and Packagekit dependency

I cant upgrade and test pacman 4.1 due to packagekit and gnome-packagekit depends on pacman <= 4.0

Can force upgrade, and is it safe?

Last edited by jasonwryan (2013-04-01 20:28:46)

Offline

#2 2013-04-01 14:26:31

parazyd
Member
From: Amsterdam
Registered: 2012-10-14
Posts: 259
Website

Re: Pacman 4.1 and Packagekit dependency

Just wait for the official release.

Offline

#3 2013-04-01 15:46:17

sidneyk
Member
From: Bonner Springs, KS. USA
Registered: 2011-04-22
Posts: 129

Re: Pacman 4.1 and Packagekit dependency

I can confirm the same issue here.

resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: packagekit: requires pacman<4.1.0

[EDIT] Bug report filed.

Last edited by sidneyk (2013-04-01 16:47:35)

Offline

#4 2013-04-01 16:11:13

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 921

Re: Pacman 4.1 and Packagekit dependency

fill a bug on the bugtracker


Well, I suppose that this is somekind of signature, no?

Offline

#5 2013-04-01 17:52:45

canolucas
Member
Registered: 2010-05-23
Posts: 34

Re: Pacman 4.1 and Packagekit dependency

sidneyk wrote:

I can confirm the same issue here.

resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: packagekit: requires pacman<4.1.0

[EDIT] Bug report filed.

For the people that ended up here and want to know more about this issue, here is the link:

https://bugs.archlinux.org/task/34552

Last edited by canolucas (2013-04-01 17:53:17)

Offline

#6 2013-04-01 19:59:27

canolucas
Member
Registered: 2010-05-23
Posts: 34

Re: Pacman 4.1 and Packagekit dependency

The above bug was closed as "not a pacman bug". Proper report has been filled for the package that depends on pacman < 4.1.0 (PackageKit):

https://bugs.archlinux.org/task/34557

NOTE
The mantainer of package-query has been contacted by email, as this package belongs to the AUR.

Last edited by canolucas (2013-04-01 20:46:05)

Offline

#7 2013-04-01 20:22:41

progandy
Member
Registered: 2012-05-17
Posts: 2,151

Re: Pacman 4.1 and Packagekit dependency

canolucas wrote:

NOTE
The mantainer of package-query has been contacted by email, as this package belongs to the AUR.

package-query-git has already been updated for the new 4.1 API/ABI. I think that the stable version will follow as soon as pacman 4.1 hits the stable repo and leavers the testing stage.

Offline

#8 2013-04-02 04:17:22

sidneyk
Member
From: Bonner Springs, KS. USA
Registered: 2011-04-22
Posts: 129

Re: Pacman 4.1 and Packagekit dependency

canolucas wrote:

The above bug was closed as "not a pacman bug". Proper report has been filled for the package that depends on pacman < 4.1.0 (PackageKit):

https://bugs.archlinux.org/task/34557

NOTE
The mantainer of package-query has been contacted by email, as this package belongs to the AUR.

Sorry about that. That was the first bug report I've done and I guess I thought about it backwards. I see that the new packagekit is in the repos now. I'll try again in the morning when I get back to my machine. Thanks.

[EDIT] Updated to new packagekit and new pacman successfully.

Last edited by sidneyk (2013-04-02 13:36:48)

Offline

#9 2013-04-05 01:50:47

pappy97
Member
Registered: 2013-03-20
Posts: 3

Re: Pacman 4.1 and Packagekit dependency

I tried to update to packagekit 0.7.6-6 64 bit so I could fix this pacman issue but apparently it's not in the repos anymore?  Can't even download it directly.  Is there an issue with it?

Thanks!

Last edited by pappy97 (2013-04-05 02:03:35)

Offline

#10 2013-04-05 03:03:05

sidneyk
Member
From: Bonner Springs, KS. USA
Registered: 2011-04-22
Posts: 129

Re: Pacman 4.1 and Packagekit dependency

pappy97 wrote:

I tried to update to packagekit 0.7.6-6 64 bit so I could fix this pacman issue but apparently it's not in the repos anymore?  Can't even download it directly.  Is there an issue with it?

Thanks!

Just checked it on the packages page, it shows up for me. Also, just did a 'sudo pacman -S packagekit' and reinstalled it.

Last edited by sidneyk (2013-04-05 03:07:13)

Offline

#11 2013-04-05 03:12:32

ANOKNUSA
Member
Registered: 2010-10-22
Posts: 2,141

Re: Pacman 4.1 and Packagekit dependency

Absolutely none of this is a problem with Pacman.  Period.

EDIT: Packagekit isn't even a GNOME dependency, so there's really no reason to even post this on these forums.

Last edited by ANOKNUSA (2013-04-05 03:14:10)

Offline

#12 2013-04-05 08:32:48

Awebb
Member
Registered: 2010-05-06
Posts: 4,317

Re: Pacman 4.1 and Packagekit dependency

And your contribution to the problem's solution is what, ANOKNUSA?

Offline

#13 2013-04-05 14:25:17

sidneyk
Member
From: Bonner Springs, KS. USA
Registered: 2011-04-22
Posts: 129

Re: Pacman 4.1 and Packagekit dependency

ANOKNUSA wrote:

Absolutely none of this is a problem with Pacman.  Period.

EDIT: Packagekit isn't even a GNOME dependency, so there's really no reason to even post this on these forums.

I am now versed on the fact that the devs say this is not a pacman problem, but rather a packagekit problem, as I filled the original bug report on it against pacman. But it was, originally, a definite problem with upgrading to the latest pacman for anyone that had this installed. Fortunately, the packagekit maintainer was fairly quick to fix the problem of packagekit depending on an older version of pacman. I was merely pointing out and confirming to the person that I replied to that the new version is definitely on at least some repo or mirror somewhere because I was able to install it twice so that the poster might be encouraged to try again and doublecheck his commands or choose a different mirror or something. Sorry, if I offended you.

Offline

#14 2013-04-07 19:07:25

Tombula
Member
Registered: 2013-01-18
Posts: 2

Re: Pacman 4.1 and Packagekit dependency

Hello.

First i call

sudo pacman -S packagekit

Answer "NO" on question about upgrading pacman first. Then system upgrade packagekit and pacman.

sudo pacman -Syu

works now ok.

Offline

#15 2013-04-07 22:04:07

ANOKNUSA
Member
Registered: 2010-10-22
Posts: 2,141

Re: Pacman 4.1 and Packagekit dependency

Awebb wrote:

And your contribution to the problem's solution is what, ANOKNUSA?

Every time there's a Pacman upgrade, the forums balloon with inane complaints about third-party wrappers blocking upgrades, and this somehow being an Arch problem.  The answer is always the same:  Either wait for the third party to update, or don't use such packages.  And anyone using [testing] is expected to take full responsibility for any issues they run into, and understand how the dependency chain works; that's just how it is.  If one isn't prepared to accept that, one shouldn't use [testing], as was stated in the second post in this thread.

Useful information: That's my contribution.  Though in retrospect I should have posted it the first time around. hmm

Offline

#16 2013-04-08 18:35:21

Thaodan
Member
From: Dortmund, Nordrein-Westfalen
Registered: 2012-04-28
Posts: 438

Re: Pacman 4.1 and Packagekit dependency

It's a bit OT but how is the status of alpm packagekit 0.8.x?


Linux odin 3.13.1-pf #1 SMP PREEMPT Wed Mar 5 21:47:28 CET 2014 x86_64 GNU/Linux

Offline

#17 2013-04-09 08:50:52

Boogie
Member
Registered: 2012-06-17
Posts: 27

Re: Pacman 4.1 and Packagekit dependency

http://www.packagekit.org/pk-matrix.html

It doesnt seem alpm is implemented, dont know if that is ever gonna happen.

Offline

#18 2013-04-09 10:02:05

Thaodan
Member
From: Dortmund, Nordrein-Westfalen
Registered: 2012-04-28
Posts: 438

Re: Pacman 4.1 and Packagekit dependency

So PackageKit is a deadend on arch currently?


Linux odin 3.13.1-pf #1 SMP PREEMPT Wed Mar 5 21:47:28 CET 2014 x86_64 GNU/Linux

Offline

#19 2013-04-09 10:43:56

Awebb
Member
Registered: 2010-05-06
Posts: 4,317

Re: Pacman 4.1 and Packagekit dependency

And what's all that stuff in the third column?

Offline

Board footer

Powered by FluxBB