You are not logged in.

#1 2013-04-08 08:25:08

drobole
Member
From: Norway
Registered: 2012-07-23
Posts: 123

Unable to pacman -Syu [SOLVED]

I have removed package-query and yaourt, and I have upgraded pacman to version 4.1
And I have renamed pacman.conf.pacnew to pacman.conf

Now, when I do pacman -Syu I get this error from all the mirrors:

--->
error: <package> from <url> : The requested URL returned error : 403 Forbidden: IPS signature match
<---

I got these messages with the old pacman.conf too.

Any suggestions?

Last edited by drobole (2013-04-09 11:41:05)

Offline

#2 2013-04-08 08:35:47

Opanos
Member
Registered: 2012-09-16
Posts: 42

Re: Unable to pacman -Syu [SOLVED]

I am prety sure that you are mistaken by just rename the pacnew file.

Read this wiki section.

Offline

#3 2013-04-08 09:01:46

drobole
Member
From: Norway
Registered: 2012-07-23
Posts: 123

Re: Unable to pacman -Syu [SOLVED]

No, the file is named correctly

I have also run this command:
# pacman-key --refresh-keys

And it finishes with the error:
ERROR: A specified local key could not be updated from a keyserver

edit:
It may be the package kdepimlibs that is causing the problem...

Last edited by drobole (2013-04-08 09:08:51)

Offline

#4 2013-04-08 09:10:54

Awebb
Member
Registered: 2010-05-06
Posts: 4,180

Re: Unable to pacman -Syu [SOLVED]

Error 403 is an HTTP error. It does not seem to have anything to do with package signing. Change your mirror, it might be down.

Offline

#5 2013-04-08 09:15:53

drobole
Member
From: Norway
Registered: 2012-07-23
Posts: 123

Re: Unable to pacman -Syu [SOLVED]

I have tried to change mirror but the package kdepimlibs fails with all of them. Upgrading other packages individually seems to work

Offline

#6 2013-04-08 09:48:15

hokasch
Member
Registered: 2007-09-23
Posts: 1,461

Re: Unable to pacman -Syu [SOLVED]

Googling the http status code it seems some "intrusion preventions system" in your network path is blocking the request. Try to download the package manually, chances are you will get the same error. If you are on a company network, ask your network sysadmin about it.

Last edited by hokasch (2013-04-08 09:50:01)

Offline

#7 2013-04-08 10:02:55

drobole
Member
From: Norway
Registered: 2012-07-23
Posts: 123

Re: Unable to pacman -Syu [SOLVED]

hokasch wrote:

Googling the http status code it seems some "intrusion preventions system" in your network path is blocking the request. Try to download the package manually, chances are you will get the same error. If you are on a company network, ask your network sysadmin about it.

Downloading the package using a browser and the first mirror in mirrorlist works.

I am on a company network, but unfortunately I also am a sysadmin.

I could ask the boss about it but he(we) don't really support linux so I wouldn't get anywhere.

I'll rather give it a try from my home network later today.

Thanks

Offline

#8 2013-04-08 17:50:47

shulamy
Member
From: israel
Registered: 2010-09-11
Posts: 323

Re: Unable to pacman -Syu [SOLVED]

i still think it is the renaming instead of merging.

ezik

Offline

#9 2013-04-08 18:21:26

Awebb
Member
Registered: 2010-05-06
Posts: 4,180

Re: Unable to pacman -Syu [SOLVED]

Renaming sets pacman to its defaults. If the defaults do not work then there is something wrong.

Offline

#10 2013-04-08 19:54:40

drobole
Member
From: Norway
Registered: 2012-07-23
Posts: 123

Re: Unable to pacman -Syu [SOLVED]

I still have the old file so I'll look into merging tomorrow, even though it is strange that only one package has this problem

Offline

#11 2013-04-09 11:40:49

drobole
Member
From: Norway
Registered: 2012-07-23
Posts: 123

Re: Unable to pacman -Syu [SOLVED]

Upgrading works now. Not sure what was wrong earlier

Offline

Board footer

Powered by FluxBB