You are not logged in.

#1 2013-04-10 08:58:33

heimi
Member
Registered: 2013-04-10
Posts: 2

Archlinux on arch=i586 (Geode GX1 / GXm / VIA Nehemiah ... )

Hello,

I managed to install archlinux on a GX1 based platform an used pacman updates for month.
Since one or two weeks the update was not working anymore because of 404 errors, the reason for this might be that i586 urls were deleted. (support finally dropped ?)
Since pacman.conf was configured using arch=auto (I never touched this), i switched to i686 and that was the beginning: After kernel upgrade to 3.8.5 (and maybe some libraries -- perhaps even glibc / binutils) the system was not working correctly anymore.
Processes were stated 'defunct' (sshd / metalog)  and now I'm not able to login anymore. dmesg / logs are calm, I tried sshd with -ddd debugging without success an strace is currently not installable. Switching to the previous kernel didn't solve the problem so it is in fact library related.
I can reproduce problems on other i586 hardware (Nehemiah based) which are all not PAE capable.

I found a diskussion of dropping support even for i686 (32bit) but since I'm quite comfortable running a "frozen" system which is not too old (3.x kernel ~1 year) since the hardware is ~10 years-  I'd like to know were I can find an archived mirror (aka vault in some distributions) just to add some packages.

I'm using a backup right now.

Offline

#2 2013-04-10 09:03:00

HalosGhost
Member
From: Twin Cities, MN
Registered: 2012-06-22
Posts: 1,486
Website

Re: Archlinux on arch=i586 (Geode GX1 / GXm / VIA Nehemiah ... )

As far as I know, Arch has not supported i586 in a very long time (ever?). You'll either need to find an unofficial mirror that builds packages for i586, or use a different, faster computer to build them yourself and use that as your mirror.

Honestly, I'd recommend you upgrade your hardware, especially with all the talk surrounding dropping i686 support altogether. Plus, there's almost no benefit in running Arch if you won't/can't keep it up-to-date.

All the best,

-HG


"All errors are ᴘᴇʙᴋᴀᴄ errors—It's just a matter of narrowing down which keyboard and chair." -Trilby
\ldots

Online

#3 2013-04-10 09:38:19

heimi
Member
Registered: 2013-04-10
Posts: 2

Re: Archlinux on arch=i586 (Geode GX1 / GXm / VIA Nehemiah ... )

Building on my own just requires too much resources. There is a outdated wiki entry about
i586 support
which suggest the same.

I was just wondering why this worked with arch=auto (it generated i586 urls) in the past

There are some threads on i386/i486 in the forum (Getting arch for i486) suggesting specialized distributions (eg. ConnochaetOS which seems arch based), maybe I will try.

Offline

#4 2013-04-10 10:56:14

scar
Member
From: Hungary
Registered: 2009-10-01
Posts: 411

Re: Archlinux on arch=i586 (Geode GX1 / GXm / VIA Nehemiah ... )

I had the same problem witha VIA itx(-like) board too, it runs Debian now. If you don't really care about using arch on that hardware, give it a try. (They support i386, just download the right image)

(If I remember right, the reason was an i368-incompatible CUPS package)


“The future has already arrived. It's just not evenly distributed yet.”
― William Gibson

Offline

#5 2013-04-10 13:11:38

fsckd
Forum Moderator
Registered: 2009-06-15
Posts: 3,538

Re: Archlinux on arch=i586 (Geode GX1 / GXm / VIA Nehemiah ... )

Moving from Installation to Other Architectures.


aur S & M :: forum rules :: Community Ethos
Resources for Women, POC, LGBT*, and allies

Offline

#6 2013-04-10 19:01:56

Barthalion
Developer
From: Poland
Registered: 2010-02-26
Posts: 109

Re: Archlinux on arch=i586 (Geode GX1 / GXm / VIA Nehemiah ... )

Take a look at Alpine Linux, it should suit your needs.


Arch Linux - rolling release distro, which users want to downgrade to the previous version

Offline

Board footer

Powered by FluxBB